Zahlenkombinationen unter Bedingungen bilden

Bild

Betrifft: Zahlenkombinationen unter Bedingungen bilden
von: Joerschi
Geschrieben am: 03.07.2015 12:30:24

Hallo liebes Forum,
folgendes Problem möchte ich lösen (siehe auch Skizze unten):
Es gibt zwei verschiedene Zahlenreihen (z. B. "A" und "B").
Aufgabe: Es sollen (per Formel) nebeneinander alle Kombinationen der beiden Zahlenreihen abgebildet werden.
Bedingung: per Vorgabe soll es möglich sein, dass Kombinationen mit Zahlen über dem Vorgabewert nicht angezeigt werden.
Es sollen auch keine Lücken (also leere Zellen) zwischen den ausgerechneten Zahlenkombinationen vorkommen.
am Beispiel (gelb ist der gesuchte Formelbereich):
Userbild
Musterdatei: https://www.herber.de/bbs/user/98618.xlsx
In Zelle B4 wurde z.b. die 10 für Zahlenreihe A definiert, wodurch alle Kombinationen mit dem Wert 15 entfallen.
In Zelle B5 hingegen wurde die 100 für Zahlenreihe B definiert, wodurch alle Werte erhalten bleiben (weil alle kleiner 100 sind).
Ein zusätzliche Schwierigkeit könnte bestehen, wenn beide Vorgaben Werte ausschließen.
so zum Beispiel:
Userbild
Hat jemand einen Tip, ob/wie man das als Formel lösen könnte?
Danke vorab und liebe Grüße
Joerschi

Bild

Betrifft: zwei INDEX()-Formeln ...
von: der neopa C
Geschrieben am: 03.07.2015 13:15:54
Hallo Joerschi,
... und diese nach rechts ziehend kopieren:
Tabelle1

 ABCDEFGHIJ
1Zahlenreihe A:35915     
2Zahlenreihe B:45810     
3          
4für Zahlenreihe A: zeige nicht an bei Wert >:10        
5für Zahlenreihe B: zeige nicht an bei Wert >:5        
6          
7Ergebnis A:335599   
8Ergebnis B:454545   
9          

Formeln der Tabelle
ZelleFormel
B7=WENN(SPALTE(A1)>ZÄHLENWENN($B1:$Z1;"<="&$B4)*ZÄHLENWENN($B2:$Z2;"<="&$B5); "";INDEX(1:1;2+KÜRZEN((SPALTE(A1)-1)/ZÄHLENWENN($B2:$Z$2;"<="&$B5); )))
B8=WENN(B7="";"";INDEX(2:2;2+REST(SPALTE(A1)-1;ZÄHLENWENN($B2:$Z2;"<="&$B5))))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß Werner
.. , - ...


Bild

Betrifft: AW: zwei INDEX()-Formeln ...
von: Joerschi
Geschrieben am: 03.07.2015 13:29:27
wow...
Danke Werner, funktioniert einwandfei.
Hätte nicht gedacht, dass man da um so viele Ecken denken muss :-)

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Zahlenkombinationen unter Bedingungen bilden"