Brauche Hilfe bei Formel die Kalenderdaten berechn

Bild

Betrifft: Brauche Hilfe bei Formel die Kalenderdaten berechn
von: Christian
Geschrieben am: 10.07.2015 08:41:27

Hallo an alle,
ich bitte euch, mir bei folgendem Problem zu helfen.
https://www.herber.de/bbs/user/98752.xlsx
Ich suche eine Möglichkeit, die Formel in Spalte A meinen Wünschen anzupassen.
Und zwar wenn wie in L36 nur ein Monat und ein Jahr steht, dass die Formel dann statt wie bislang #WERT! den ersten Tag dieses Monats, also in diesem Beispiel den 01.02.1985 ausgibt.
Außerdem noch wenn ich wie in L37 nur eine Jahreszahl habe, soll die Formel in A37 den ersten Tag dieses Jahres, also den 01.01.1985 ausgeben.
Ansonsten soll natürlich der Mechanismus vollständige Daten umzuwandeln beibehalten bleiben.
Vielen Dank und viele Grüße
Christian

Bild

Betrifft: AW: Brauche Hilfe bei Formel die Kalenderdaten berechn
von: Christian
Geschrieben am: 10.07.2015 08:49:17
sorry ich hab mich vertan, ich brauche den letzten Tag, nicht den ersten, also in A36 den 28.02.1985 und in L37 den 31.12.1985

Bild

Betrifft: AW: Brauche Hilfe bei Formel die Kalenderdaten berechn
von: Matthias L
Geschrieben am: 10.07.2015 09:27:06
Hallo
Für L37 kannst Du versuchen das in Deine Formel zu basteln

 KL
3731.12.19851985
3831.12.20042004

Formeln der Tabelle
ZelleFormel
K37=WENN(UND(ISTZAHL(L37);LÄNGE(L37)=4);DATUM(L37;12;31);"")
K38=WENN(UND(ISTZAHL(L38);LÄNGE(L38)=4);DATUM(L38;12;31);"")


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Ist aber ne Krücke.
Bei L36 würde ich abfragen, ob links eine Zahl steht.
Bei Falsch könntest Du dann mit WennFehler das Datum generieren.
Gruß Matthias

Bild

Betrifft: AW: Brauche Hilfe bei Formel die Kalenderdaten berechn
von: Christian
Geschrieben am: 10.07.2015 09:35:52
Hallo Matthias,
danke erstmal,
habe noch ein paar Spalten zwischenzeitlich eingefügt, daher ist es jetzt in meiner Tabelle nicht mehr Spalte L sondern Spalte N
aber

=WENN(UND(ISTZAHL(N43);LÄNGE(N43)=4);DATUM(N43;12;31);WENN(ISTZAHL(N43);N43;DATUM(RECHTS(N43;4)+0; SUCHEN(TEIL(N43;SUCHEN(" ";N43)+1;3);"xxjanfebmaraprmayjunjulaugsepoctnovdec")/3;LINKS(N43; SUCHEN(" ";N43)-1)))) 
funktioniert schonmal soweit, eins der beiden Probleme gelöst.
Gruß
Christian

Bild

Betrifft: noch offen
von: Christian
Geschrieben am: 10.07.2015 09:36:32
noch offen

Bild

Betrifft: AW: Brauche Hilfe bei Formel die Kalenderdaten berechn
von: Christian
Geschrieben am: 10.07.2015 09:43:55
einen Ansatz hätte ich, um da weiterzukommen, vielleicht schafft es ja jemand von euch ihn zu vollenden
ich hab die Formel =WENN(LÄNGE(O2)=7;DATUM(LINKS(O2;4);RECHTS(O2;2)+1;);O2+0) um diese Umwandlung zu machen, wenn das Format JJJJ-MM ist.
Eine Möglichkeit, den Text in eine Monatszahl umzuwandeln hab ich ja bereits durch meine Ursprungsformel gegeben.
Vielleicht schafft ihr es ja mit diesem Ansatz..
Danke
Christian

Bild

Betrifft: AW: Brauche Hilfe bei Formel die Kalenderdaten berechn
von: Matthias L
Geschrieben am: 10.07.2015 11:07:02
Hallo

 LM
36Feburary 198528.02.1985
37June 198630.06.1986
38December 198931.12.1989

Formeln der Tabelle
ZelleFormel
M36=DATUM(JAHR(WECHSELN(L36;LINKS(L36;LÄNGE(L36)-5);"1." & SUCHEN(LINKS(L36;3); "xxjanfebmaraprmayjunjulaugsepoctnovdec")/3 &"."));MONAT(WECHSELN(L36;LINKS(L36;LÄNGE(L36)-5);"1." & SUCHEN(LINKS(L36;3); "xxjanfebmaraprmayjunjulaugsepoctnovdec")/3 &"."))+1;0)
M37=DATUM(JAHR(WECHSELN(L37;LINKS(L37;LÄNGE(L37)-5);"1." & SUCHEN(LINKS(L37;3); "xxjanfebmaraprmayjunjulaugsepoctnovdec")/3 &"."));MONAT(WECHSELN(L37;LINKS(L37;LÄNGE(L37)-5);"1." & SUCHEN(LINKS(L37;3); "xxjanfebmaraprmayjunjulaugsepoctnovdec")/3 &"."))+1;0)
M38=DATUM(JAHR(WECHSELN(L38;LINKS(L38;LÄNGE(L38)-5);"1." & SUCHEN(LINKS(L38;3); "xxjanfebmaraprmayjunjulaugsepoctnovdec")/3 &"."));MONAT(WECHSELN(L38;LINKS(L38;LÄNGE(L38)-5);"1." & SUCHEN(LINKS(L38;3); "xxjanfebmaraprmayjunjulaugsepoctnovdec")/3 &"."))+1;0)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß Matthias

Bild

Betrifft: AW: Brauche Hilfe bei Formel die Kalenderdaten berechn
von: Christian
Geschrieben am: 10.07.2015 11:17:28
Hallo Matthias,
das sieht schonmal recht gut aus, vielen Dank.
Das einzige was jetzt noch fehlt ist die Möglichkeit,
=DATUM(JAHR(WECHSELN(N43;LINKS(N43;LÄNGE(N43)-5);"1." & SUCHEN(LINKS(N43;3); "xxjanfebmaraprmayjunjulaugsepoctnovdec")/3 &"."));MONAT(WECHSELN(N43;LINKS(N43;LÄNGE(N43)-5); "1." & SUCHEN(LINKS(N43;3); "xxjanfebmaraprmayjunjulaugsepoctnovdec")/3 &"."))+1;0)
und
=WENN(UND(ISTZAHL(N43);LÄNGE(N43)=4);DATUM(N43;12;31);WENN(ISTZAHL(N43);N43;DATUM(RECHTS(N43;4)+0; SUCHEN(TEIL(N43;SUCHEN(" ";N43)+1;3);"xxjanfebmaraprmayjunjulaugsepoctnovdec")/3;LINKS(N43; SUCHEN(" ";N43)-1))))
zu einer Formel zu machen, die ich dann über die Tabelle hinweg kopieren kann, genau genommen fällt mir keine Wenn Bedingung ein, nach der ich überprüfen könnte ob der Fall deiner gerade eben geschriebenen Formel zutrifft.
Hast du da auch noch eine Idee?
Gruß
Christian

Bild

Betrifft: Zähl die Leerzeichen
von: Matthias L
Geschrieben am: 10.07.2015 11:37:26
Hallo
Wenn Du die Leerzeichen zählst hast Du 3 Wenn-Bedingungen.

 HI
361Feburary 1985
371June 1986
381December 1989
3901985
40213 December 2006

Formeln der Tabelle
ZelleFormel
H36=LÄNGE(I36)-LÄNGE(WECHSELN(I36;" ";""))
H37=LÄNGE(I37)-LÄNGE(WECHSELN(I37;" ";""))
H38=LÄNGE(I38)-LÄNGE(WECHSELN(I38;" ";""))
H39=LÄNGE(I39)-LÄNGE(WECHSELN(I39;" ";""))
H40=LÄNGE(I40)-LÄNGE(WECHSELN(I40;" ";""))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß Matthias

Bild

Betrifft: hier mit 3 x Wenn
von: Matthias L
Geschrieben am: 10.07.2015 11:55:52
Hallo
Da ich nicht weiß ob Du zurecht kommst
Hier mal konkret:

 LM
36Feburary 198528.02.1985
37June 198630.06.1986
38December 198931.12.1989
39198531.12.1985
4013 December 200613.12.2006

Formeln der Tabelle
ZelleFormel
M36=WENN(LÄNGE(L36)-LÄNGE(WECHSELN(L36;" ";""))=1;DATUM(JAHR(WECHSELN(L36;LINKS(L36;LÄNGE(L36)-5);"1." & SUCHEN(LINKS(L36;3); "xxjanfebmaraprmayjunjulaugsepoctnovdec")/3 &"."));MONAT(WECHSELN(L36;LINKS(L36;LÄNGE(L36)-5);"1." & SUCHEN(LINKS(L36;3); "xxjanfebmaraprmayjunjulaugsepoctnovdec")/3 &"."))+1;0);WENN(LÄNGE(L36)-LÄNGE(WECHSELN(L36;" ";""))=0;WENN(UND(ISTZAHL(L36);LÄNGE(L36)=4);DATUM(L36;12;31);"");WENN(LÄNGE(L36)-LÄNGE(WECHSELN(L36;" ";""))=2;WENN(ISTZAHL(L36);L36;DATUM(RECHTS(L36;4)+0;SUCHEN(TEIL(L36;SUCHEN(" ";L36)+1;3); "xxjanfebmaraprmayjunjulaugsepoctnovdec")/3;LINKS(L36;SUCHEN(" ";L36)-1)));"")))
M37=WENN(LÄNGE(L37)-LÄNGE(WECHSELN(L37;" ";""))=1;DATUM(JAHR(WECHSELN(L37;LINKS(L37;LÄNGE(L37)-5);"1." & SUCHEN(LINKS(L37;3); "xxjanfebmaraprmayjunjulaugsepoctnovdec")/3 &"."));MONAT(WECHSELN(L37;LINKS(L37;LÄNGE(L37)-5);"1." & SUCHEN(LINKS(L37;3); "xxjanfebmaraprmayjunjulaugsepoctnovdec")/3 &"."))+1;0);WENN(LÄNGE(L37)-LÄNGE(WECHSELN(L37;" ";""))=0;WENN(UND(ISTZAHL(L37);LÄNGE(L37)=4);DATUM(L37;12;31);"");WENN(LÄNGE(L37)-LÄNGE(WECHSELN(L37;" ";""))=2;WENN(ISTZAHL(L37);L37;DATUM(RECHTS(L37;4)+0;SUCHEN(TEIL(L37;SUCHEN(" ";L37)+1;3); "xxjanfebmaraprmayjunjulaugsepoctnovdec")/3;LINKS(L37;SUCHEN(" ";L37)-1)));"")))
M38=WENN(LÄNGE(L38)-LÄNGE(WECHSELN(L38;" ";""))=1;DATUM(JAHR(WECHSELN(L38;LINKS(L38;LÄNGE(L38)-5);"1." & SUCHEN(LINKS(L38;3); "xxjanfebmaraprmayjunjulaugsepoctnovdec")/3 &"."));MONAT(WECHSELN(L38;LINKS(L38;LÄNGE(L38)-5);"1." & SUCHEN(LINKS(L38;3); "xxjanfebmaraprmayjunjulaugsepoctnovdec")/3 &"."))+1;0);WENN(LÄNGE(L38)-LÄNGE(WECHSELN(L38;" ";""))=0;WENN(UND(ISTZAHL(L38);LÄNGE(L38)=4);DATUM(L38;12;31);"");WENN(LÄNGE(L38)-LÄNGE(WECHSELN(L38;" ";""))=2;WENN(ISTZAHL(L38);L38;DATUM(RECHTS(L38;4)+0;SUCHEN(TEIL(L38;SUCHEN(" ";L38)+1;3); "xxjanfebmaraprmayjunjulaugsepoctnovdec")/3;LINKS(L38;SUCHEN(" ";L38)-1)));"")))
M39=WENN(LÄNGE(L39)-LÄNGE(WECHSELN(L39;" ";""))=1;DATUM(JAHR(WECHSELN(L39;LINKS(L39;LÄNGE(L39)-5);"1." & SUCHEN(LINKS(L39;3); "xxjanfebmaraprmayjunjulaugsepoctnovdec")/3 &"."));MONAT(WECHSELN(L39;LINKS(L39;LÄNGE(L39)-5);"1." & SUCHEN(LINKS(L39;3); "xxjanfebmaraprmayjunjulaugsepoctnovdec")/3 &"."))+1;0);WENN(LÄNGE(L39)-LÄNGE(WECHSELN(L39;" ";""))=0;WENN(UND(ISTZAHL(L39);LÄNGE(L39)=4);DATUM(L39;12;31);"");WENN(LÄNGE(L39)-LÄNGE(WECHSELN(L39;" ";""))=2;WENN(ISTZAHL(L39);L39;DATUM(RECHTS(L39;4)+0;SUCHEN(TEIL(L39;SUCHEN(" ";L39)+1;3); "xxjanfebmaraprmayjunjulaugsepoctnovdec")/3;LINKS(L39;SUCHEN(" ";L39)-1)));"")))
M40=WENN(LÄNGE(L40)-LÄNGE(WECHSELN(L40;" ";""))=1;DATUM(JAHR(WECHSELN(L40;LINKS(L40;LÄNGE(L40)-5);"1." & SUCHEN(LINKS(L40;3); "xxjanfebmaraprmayjunjulaugsepoctnovdec")/3 &"."));MONAT(WECHSELN(L40;LINKS(L40;LÄNGE(L40)-5);"1." & SUCHEN(LINKS(L40;3); "xxjanfebmaraprmayjunjulaugsepoctnovdec")/3 &"."))+1;0);WENN(LÄNGE(L40)-LÄNGE(WECHSELN(L40;" ";""))=0;WENN(UND(ISTZAHL(L40);LÄNGE(L40)=4);DATUM(L40;12;31);"");WENN(LÄNGE(L40)-LÄNGE(WECHSELN(L40;" ";""))=2;WENN(ISTZAHL(L40);L40;DATUM(RECHTS(L40;4)+0;SUCHEN(TEIL(L40;SUCHEN(" ";L40)+1;3); "xxjanfebmaraprmayjunjulaugsepoctnovdec")/3;LINKS(L40;SUCHEN(" ";L40)-1)));"")))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Userbild

Bild

Betrifft: AW: hier mit 3 x Wenn
von: Christian
Geschrieben am: 10.07.2015 12:05:06
Hallo Matthias,
hier tritt jetzt leider ein Fehler auf, der mit den einzelnen Formeln noch nicht aufgetreten ist.
Und zwar es gibt ja auch Monatsnamen, die in deutscher und englischer Sprache identisch sind.
Wenn ich jetzt in Spalte N zum Beispiel 23 September 2005 eingebe, macht mein Excel daraus 23. Sep 05, deine Formel erkennt 2 Leerzeichen und lässt dann das Ergebnis leer.
Lässt sich da noch was mit Wenn(Istzahl), dann Datum oder so rumbauen damit auch das nicht auftritt?
Gruß
Christian

Bild

Betrifft: AW: hier mit 3 x Wenn
von: Christian
Geschrieben am: 10.07.2015 12:09:31
ok, das hab ich jetzt selber hinbekommen
=WENN(ISTZAHL(N43);N43;WENN(LÄNGE(N43)-LÄNGE(WECHSELN(N43;" ";""))=1;DATUM(JAHR(WECHSELN(N43; LINKS(N43;LÄNGE(N43)-5);"1."&SUCHEN(LINKS(N43;3);"xxjanfebmaraprmayjunjulaugsepoctnovdec")/3&".")); MONAT(WECHSELN(N43;LINKS(N43;LÄNGE(N43)-5);"1."&SUCHEN(LINKS(N43;3); "xxjanfebmaraprmayjunjulaugsepoctnovdec")/3&"."))+1;0);WENN(LÄNGE(N43)-LÄNGE(WECHSELN(N43;" ";""))=0; WENN(UND(ISTZAHL(N43);LÄNGE(N43)=4);DATUM(N43;12;31);"");WENN(LÄNGE(N43)-LÄNGE(WECHSELN(N43;" ";"")) =2;WENN(ISTZAHL(N43);N43;DATUM(RECHTS(N43;4)+0;SUCHEN(TEIL(N43;SUCHEN(" ";N43)+1;3); "xxjanfebmaraprmayjunjulaugsepoctnovdec")/3;LINKS(N43;SUCHEN(" ";N43)-1)));""))))
funktioniert.
Danke für die viele viele Mühe
Christian

Bild

Betrifft: Danke für Deine Rückmeldung :-) owT
von: Matthias L
Geschrieben am: 10.07.2015 12:15:13


 Bild

Beiträge aus den Excel-Beispielen zum Thema "Brauche Hilfe bei Formel die Kalenderdaten berechn"