Herbers Excel-Forum - das Archiv

Zellwert immer um einen bestimmten Wert erhöhen!

Bild

Betrifft: Zellwert immer um einen bestimmten Wert erhöhen!
von: Viktoria
Geschrieben am: 28.09.2003 17:58:10
Hallo Excel-Experten!

weiß jemand ob es eine Möglichkeit gibt, den „Zeilenwert“ einer Zelle, in einer Formel, so zu definieren das beim „Klicken und Ziehen“ der Zellwert immer um einen bestimmten Wert erhöht wird? In der Formel soll also sinngemäß stehen:

=WENN(B4=x;x;x) bzw. WENN(B4=x;x;x)
=WENN(B(4+25)=x;x;x) bzw. WENN(B29=x;x;x)
=WENN(B(4+50)=x;x;x) bzw. WENN(B54=x;x;x)
=WENN(B(4+75)=x;x;x) bzw. WENN(B79=x;x;x)
…..

Für jede Hilfestellung vielen Dank im voraus.

Herzliche Grüße
Viktoria

Bild

Betrifft: AW: Zellwert immer um einen bestimmten Wert erhöhen!
von: axel.meyer
Geschrieben am: 28.09.2003 18:32:19
hi viktoria,

ich glaube daß das nciht geht. das war damals exakt der grund, weshalb ich mit den allerersten zarten schritten in VBA angefangen habe. dort geht das ohne weiteres, und die sprache ist auch noch so einfach, daß man schnell in der makro-programmierung fuß faßt. da sieht das dann ungefähr so aus:


for i = 0 to ende

if range("B" & 4 + (i * 25)) = "x;x;x" then
' tu was
' das "&" verknüpft B mit der zahl, die sich jeweils für die zahl aus "4 + 25·i" bildet. so entsteht ein zellenname. erst B4, dann...
end if

next i




wenn du noch fragen zum einstieg in die entwicklungsumgebung (das ist der bereich, in den man die programmzeilen schreibt), makros, den code etc hast, meld dich.

gruß, axel
Bild

Betrifft: AW: Zellwert immer um einen bestimmten Wert erhöhen!
von: Josef Ehrensberger
Geschrieben am: 28.09.2003 18:41:22
Hallo Viktoria,

sieh mal hier nach.


http://www.excelformeln.de/formeln.html?gruppe=11

Gruß Sepp
Bild

Betrifft: AW: Zellwert immer um einen bestimmten Wert erhöhen!
von: Viktoria
Geschrieben am: 28.09.2003 19:11:45
Herzlichen Dank nochmal,

damit sollte ich mein Problem eigentlich lösen können.

MfG Viktoria
Bild

Betrifft: AW: Zellwert immer um einen bestimmten Wert erhöhen!
von: Jörg Gradert
Geschrieben am: 28.09.2003 19:36:12
Hallo Viktoria,
da ich lange probiert habe, möchte ich dir meine Lösung nicht vorenthalten.

https://www.herber.de/bbs/user/1199.xls

Gruss Jörg
 Bild
Excel-Beispiele zum Thema " Zellwert immer um einen bestimmten Wert erhöhen!"
Makroaufruf abhängig vom Zellwert Zellwert in Kommentar übernehmen
Summe einzelner Zellwerte ermitteln Maximalwert eines SpinButtons nach Zellwert festlegen
Den vorhergehenden Zellwert in einer zweiten Zelle zeigen Von der Fundstelle eines Zellwertes abhängige Daten eintragen
Zellwerte über SpinButton und ScrollBar hochzählen Wahrheitsprüfung einer mit Zellwerten zusammengestzten Formel
Pfeilfarbe- und Bewegung abhängig von Zellwerten Zellwert nach Doppelklick in Tabelle suchen