Microsoft Excel

Herbers Excel/VBA-Archiv

Monat finden nach min/max wert

Betrifft: Monat finden nach min/max wert von: Karel
Geschrieben am: 19.12.2007 20:49:05

Hallo Forum.

Habe eine Sheet mit 2 Tabelle sehe beispiel

https://www.herber.de/bbs/user/48551.xls

in Tabelle 1 zeitraum von 12 Monaten mit min/max werten

1) in Tabelle 2 habe ich auswertung mit uber sverweis eingelesene Daten mit min/max
mochte gerne in zelle daneben die Monat ausgegeben bekommen welche monat als erste min wert hat und welche Monat der Max wert hat.

2) Kan men min/max wert auch direkt in Tabelle 2 bekomen ohne hilfsspalte in Tabelle 1

viele Gruße
Karel


  

Betrifft: AW: Monat finden nach min/max wert von: Josef Ehrensberger
Geschrieben am: 19.12.2007 21:15:58

Hallo Karel,

Zu 1:
Bedarfsermittlung

 BCDEFGHIJKL
8 Bezeichnungwert wert      
9 Item no. MinMonatMaxMonat     
10 SverweisSverweis Sverweis      
1110578a1Nov 07285Apr 07     
1210603b1Feb 0743Apr 07     
1314698c1Feb 077Mai 07     
1412962d11Mai 0769Mrz 07     
1514839e21Nov 07176Sep 07     
1614985g1Feb 07131Apr 07     
1710668h2Sep 0711Jan 07     
1812963i2Feb 0760Nov 07     
1910599j1Feb 0776Apr 07     
2015675k4Dez 0663Apr 07     
2110600l1Dez 0642Apr 07     
2216455m3Apr 0735Jul 07     

Formeln der Tabelle
ZelleFormel
C11=WENN(B11="";"";SVERWEIS(B11;ABC_XYZ;2;FALSCH))
D11=WENN(B11="";"";SVERWEIS(B11;ABC_XYZ;16;FALSCH))
E11=INDEX(ABC_XYZ!$D$2:$O$2;VERGLEICH(D11;BEREICH.VERSCHIEBEN(ABC_XYZ!$C$3;VERGLEICH(B11;ABC_XYZ!$B$4:$B$15;0); 1;1;12); 0))
F11=WENN(B11="";"";SVERWEIS(B11;ABC_XYZ;17;FALSCH))
G11=INDEX(ABC_XYZ!$D$2:$O$2;VERGLEICH(F11;BEREICH.VERSCHIEBEN(ABC_XYZ!$C$3;VERGLEICH(B11;ABC_XYZ!$B$4:$B$15;0); 1;1;12); 0))
Namen in Formeln
ZelleNameBezieht sich auf
C11ABC_XYZ=ABC_XYZ!$B:$S
D11ABC_XYZ=ABC_XYZ!$B:$S
F11ABC_XYZ=ABC_XYZ!$B:$S
Namen verstehen
Excel Tabellen im Web darstellen  Excel Jeanie HTML

Zu 2:

Geht, aber wenn die Hilfspalte nicht stört, würde ich es dabei belassen.


Gruß Sepp



  

Betrifft: AW: Monat finden nach min/max wert von: Karel
Geschrieben am: 19.12.2007 22:20:30

Hallo Sepp,

Sehr schon, genau so sollte es sein danke dir.

hilfssparte stört daten Tabelle 1 geht über 10.000 Zeilen sehr dynamisch komen manchmal Spalte dazu
Daten Tabelle 2 nur max 200 Zeilen andert sich nicht

viele grusse und Danke

Karel


  

Betrifft: AW: Monat finden nach min/max wert von: Karel
Geschrieben am: 19.12.2007 22:20:44

Hallo Sepp,

Sehr schon, genau so sollte es sein danke dir.

hilfssparte stört daten Tabelle 1 geht über 10.000 Zeilen sehr dynamisch komen manchmal Spalte dazu
Daten Tabelle 2 nur max 200 Zeilen andert sich nicht

viele grusse und Danke

Karel


  

Betrifft: AW: Monat finden nach min/max wert von: Josef Ehrensberger
Geschrieben am: 19.12.2007 22:33:49

Hallo Karel,

bei 10.000 Zeilen wird das mit Matrixformeln aber eine Weile rechnen.

Bedarfsermittlung

 BCDEFGHIJKL
8 Bezeichnungwert wert      
9 Item no. MinMonatMaxMonat     
10 SverweisSverweis Sverweis      
1110578a1Nov 07285Apr 07     
1210603b1Feb 0743Apr 07     
1314698c1Feb 077Mai 07     
1412962d11Mai 0769Mrz 07     
1514839e21Nov 07176Sep 07     
1614985g1Feb 07131Apr 07     
1710668h2Sep 0711Jan 07     
1812963i2Feb 0760Nov 07     
1910599j1Feb 0776Apr 07     
2015675k4Dez 0663Apr 07     
2110600l1Dez 0642Apr 07     
2216455m3Apr 0735Jul 07     

Formeln der Tabelle
ZelleFormel
C11=WENN(B11="";"";SVERWEIS(B11;ABC_XYZ;2;FALSCH))
D11{=MIN(WENN(BEREICH.VERSCHIEBEN(ABC_XYZ!$C$3;VERGLEICH(B11;ABC_XYZ!$B$4:$B$15;0); 1;1;12)<>0;BEREICH.VERSCHIEBEN(ABC_XYZ!$C$3;VERGLEICH(B11;ABC_XYZ!$B$4:$B$15;0); 1;1;12)))}
E11=INDEX(ABC_XYZ!$D$2:$O$2;VERGLEICH(D11;BEREICH.VERSCHIEBEN(ABC_XYZ!$C$3;VERGLEICH(B11;ABC_XYZ!$B$4:$B$15;0); 1;1;12); 0))
F11=MAX(BEREICH.VERSCHIEBEN(ABC_XYZ!$C$3;VERGLEICH(B11;ABC_XYZ!$B$4:$B$15;0); 1;1;12))
G11=INDEX(ABC_XYZ!$D$2:$O$2;VERGLEICH(F11;BEREICH.VERSCHIEBEN(ABC_XYZ!$C$3;VERGLEICH(B11;ABC_XYZ!$B$4:$B$15;0); 1;1;12); 0))
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen
Namen in Formeln
ZelleNameBezieht sich auf
C11ABC_XYZ=ABC_XYZ!$B:$S
Namen verstehen
Excel Tabellen im Web darstellen  Excel Jeanie HTML




Gruß Sepp



  

Betrifft: AW: Monat finden nach min/max wert ot von: Karel
Geschrieben am: 21.12.2007 12:41:06

Hallo Sepp







Danke







Karel


 

Beiträge aus den Excel-Beispielen zum Thema "Monat finden nach min/max wert"