Microsoft Excel

Herbers Excel/VBA-Archiv

Fehlermeldung #NV | Herbers Excel-Forum


Betrifft: Fehlermeldung #NV von: ing.grohn
Geschrieben am: 21.12.2009 17:55:31

Hallo Forum,
nachstehende Tabelle soll Zinsen bzw Zinsessinsen (Spalte C = v) berechnen:
in Zeile 5 müßte also die Zahl 913,14 stehen. Sobald ich aber ein v in Spalte C schreibe,
kommt die Fehler Meldung:
Ich habe die Datei hochgeladen, "ZinsesZins.xls"

https://www.herber.de/bbs/user/66753.xls

Für eine Hilfe bedanke ich mich.
Mit freundlichen Grüßen
Albrecht Grohn

PS: die Struktur der tabelle habe ich irgendwo gefunden (wer weiss wo?)

  

Betrifft: Was soll denn bspw hierbei herauskommen,... von: Luc:-?
Geschrieben am: 21.12.2009 18:14:03

...Albrecht...
VERWEIS(2;1/C$1:C4<>"") ?
Hier wird aufsteigende Sortierung angenommen. Aber das ist es evtl nicht mal (allein). C1 enthält den Text Verr., durch den sich 1 wohl kaum teilen lässt, die anderen Zellen sind leer, also 0. Auch, wenn du - wie du viell beabsichtigt hast 1/(C$1:C4<>"") schreiben würdest, hättest du noch 3x 0 als Ergebnis. Der andere Wert wäre 1. Was anderes als 0 oder 1 käme hier auch nie raus und damit würde 2 auch nie gefunden wdn, worauf VERWEIS mit #NV reagiert...
Gruß Luc :-?


  

Betrifft: AW: Was soll denn bspw hierbei herauskommen,... von: BoskoBiati
Geschrieben am: 21.12.2009 18:43:55

Hallo,

so funktionierts:

=WENN(ZEILE(A6)>ANZAHL(A:A;G$2);"";SUMME(D6;B7;WENN(C7="v";INDIREKT("E"&VERWEIS(9;1/(C$2:C7<>"")) &":E"&ZEILE(A6));0))) 
@Luc, die Verweisformel ist schon ok, damit findest Du die letzte belegte Zeile.
Wenn der letzte Wert (Zahl oder Text) ermittelt werden soll

=VERWEIS(2;1/(F2:F27<>"");F2:F27) 
Gruß

Bosko


  

Betrifft: AW: Was soll denn bspw hierbei herauskommen,... von: BoskoBiati
Geschrieben am: 21.12.2009 18:50:40

Hallo,

hier noch als Tabelle:

Tabelle1

 ABCDEFGH
1DatumEin-/Ausz.Verr.SummeZinsenZinssatzAbrechnungHilfsspalte
207.01.2009300      300,00 € 2,831031.12.200910
310.02.2009100      400,00 € 1,56  10
424.02.2009500      900,00 € 8,75  10
531.03.2009 v     913,14 € 17,317,5 7,5
630.06.2009 v     943,59 € 1,77  7,5
709.07.2009250   1.193,59 € 1,24  7,5
814.07.2009-750      443,59 € 4,815 5
930.09.2009100      543,59 € 4,00  5
1022.11.2009-350      193,59 € 1,05  5

Formeln der Tabelle
ZelleFormel
D2=WENN(ZEILE(A1)>ANZAHL(A:A;G$2); "";SUMME(D1;B2;WENN(C2="v";INDIREKT("E"&VERWEIS(9;1/(C$2:C2<>""))&":E"&ZEILE(A1)); 0)))
D3=WENN(ZEILE(A2)>ANZAHL(A:A;G$2); "";SUMME(D2;B3;WENN(C3="v";INDIREKT("E"&VERWEIS(9;1/(C$2:C3<>""))&":E"&ZEILE(A2)); 0)))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Gruß

Bosko


  

Betrifft: AW: Was soll denn bspw hierbei herauskommen,... von: ing.grohn
Geschrieben am: 21.12.2009 19:33:32

Hallo Bosko,
funktioniert super!!
Vielen Dank!
Albrecht

PS: hab mir heute Jeanie installiert.
Was muß ich denn machen, um nur eine oder zwei Formeln zu erhalten
und nicht für die ganze Tabelle?


  

Betrifft: Jeanie von: Beate Schmitz
Geschrieben am: 21.12.2009 20:17:57

Hallo Albrecht,

zu deiner Frage:
PS: hab mir heute Jeanie installiert. Was muß ich denn machen, um nur eine oder zwei Formeln zu erhalten
und nicht für die ganze Tabelle?

Dann musst du den Zellbereich in das Feld Analyse-Bereich eingeben. Du kannst auch einfach den Cursor in das Feld setzen und die betreffenden Zellen der Tabelle mit der Maus selektieren, die werden dann dort automatisch eingefügt.

Gruß,
Beate


  

Betrifft: AW: Jeanie von: ing.grohn
Geschrieben am: 21.12.2009 20:33:13

Hallo Beate,
vielen vielen Dank
Ich wünsche ein frohes Weihnachtsfest
Mit freundlichen Grüßen
Albrecht


  

Betrifft: AW: Was soll denn bspw hierbei herauskommen,... von: ing.grohn
Geschrieben am: 21.12.2009 19:05:32

Hallo Bosko, Hallo Luc,
wie gesagt, das Grundgerüst hab ich irgendwo gefunden! Allein wo?
Die Idee dahinter finde ich interessant!
Zinsen zu berechnen für einen bestimmten Zeitraum.
Zinsabrechnung (hier v) für einen bestimmten Zeitraum etc
find ich gut, brauch jeder! (oder vielleicht)
Die geänderte Formel von Boris scheint zu funktionieren!
Vielen Dank für die Hilfe


  

Betrifft: AW: Was soll denn bspw hierbei herauskommen,... von: BoskoBiati
Geschrieben am: 21.12.2009 19:25:06

Hallo,

leider hat sich noch ein kleiner Fehler eingeschlichen.
Hier die Korrektur:

Tabelle1

 ABCDEFGH
1DatumEin-/Ausz.Verr.SummeZinsenZinssatzAbrechnungHilfsspalte
207.01.2009300      300,00 € 2,831031.12.200910
310.02.2009100      400,00 € 1,56  10
424.02.2009500      900,00 € 8,75  10
531.03.2009 v     913,14 € 17,317,5 7,5
630.06.2009 v     930,45 € 1,74  7,5
709.07.2009250   1.180,45 € 1,23  7,5
814.07.2009-750      430,45 € 4,665 5
930.09.2009100      530,45 € 3,90  5
1022.11.2009-350      180,45 € 0,98  5

Formeln der Tabelle
ZelleFormel
D2=WENN(ZEILE(A1)>ANZAHL(A:A;G$2); "";SUMME(D1;B2;WENN(C2="v";INDIREKT("E"&VERWEIS(9;1/(C$1:C1<>""); ZEILE($C$1:C1))&":E"&ZEILE(A1)); 0)))
D3=WENN(ZEILE(A2)>ANZAHL(A:A;G$2); "";SUMME(D2;B3;WENN(C3="v";INDIREKT("E"&VERWEIS(9;1/(C$1:C2<>""); ZEILE($C$1:C2))&":E"&ZEILE(A2)); 0)))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Gruß

Bosko


  

Betrifft: ...von Bosko...! Gruß owT von: Luc:-?
Geschrieben am: 21.12.2009 19:33:08

:-?


  

Betrifft: Pardon, fehlplaziert! owT von: Luc:-?
Geschrieben am: 21.12.2009 19:34:39

:-?


  

Betrifft: AW: ...Nachfrage von Albrecht von: ing.grohn
Geschrieben am: 21.12.2009 19:44:37

Hallo Bosko, Hallo Luc,
was muß ich den ändern, wenn auf dem Gesamtbetrag nicht die gesamte Zahlung addiert werden soll,
sondern der ZAHLBETRAG-ZINSEN?
Mit freundlichen Grüßen
Albrecht


  

Betrifft: AW: ...Nachfrage von Albrecht von: BoskoBiati
Geschrieben am: 21.12.2009 20:08:38

Hallo Albrecht,

wenn ich Dich richtig verstehe, dann soll die Spalte B nicht mit addiert werden, oder wie?

Gruß

Bosko


  

Betrifft: AW: ...Nachfrage von Albrecht von: ing.grohn
Geschrieben am: 21.12.2009 20:29:51

Hallo Bosko,
was ich möchte ist folgendes:
1. gehen wir von einem Betrag von 3000 € aus.
2. nehmen wir Tabelle so wie sie ist:
3. geben wir einen Zahlungsbetrag ein, wird dieser komplett von der Ausgangssumme abgezogen.
4. ist der Zahlungsbetrag kleiner als der Zinsbetrag, erhöht sich der Grundwert!!
das darf aber nicht.

wenn ich jeden Wert einzeln behandele hab ich kein Problem.
Nur, wenn ich diese Ausgangstabelle benutze darf der Betrag in Spalte D nicht mehr 3008,33
sondern nach wie vor 3000 betragen, die 8,33 muß ich mir merken ist ja klar.
Also: wir gehen von 3000 aus der Zinssatz ist 10%, der Zeitraum wie vorgegeben, es ergeben sich Zinsen
von 28,33, ich zahle 20€, dann bleiben also 8,33 übrig, die nächste Verzinsung muß nun von 3000 ausgehen usw.
Mit freundlichen Grüßen
Albrecht


  

Betrifft: Boris? Bosko...! ;-) Gruß owT von: Luc:-?
Geschrieben am: 21.12.2009 19:36:45

:-?


  

Betrifft: So etwas schon geahnt, aber eben nicht ohne... von: Luc:-?
Geschrieben am: 21.12.2009 19:39:14

...die Klammern (u. mit C1), Bosko... ;-)
Gruß Luc :-?


  

Betrifft: Noch mal zur Klarstellung: Deine Fml ist zwar... von: Luc:-?
Geschrieben am: 22.12.2009 20:57:27

...richtig, Bosko,
aber die in der Tabelle war es nicht! Man kann die letzte belegte Zelle auf 2erlei Weise mit xlFmln finden, entweder mit INDIREKT und VERGLEICH oder mit VERWEIS, aber nicht mit einer „Kreuzung“ von beidem!

 ABCD
82Finden des Wertes der letzten belegten Zelle
83112 kann nicht gefunden wdn,
8421weil keine der Divisionen
8531diesen Wert ergibt. Deshalb
86 #DIV/0!wird d.letzte nächstniedri-
8741gere Zahlenwert gewählt u.
88 #DIV/0!dessen relative Position
8951bzw d.Wert gleicher Position
90 #DIV/0!des Zielvektors geliefert.
91Formeln: 55
92B83:B90: {=1/(A83:A90<>"")}
93C91: {=INDIREKT(ADRESSE(VERGLEICH(2;1/(A83:A90<>""))+
94          ZEILE(A83)-1;SPALTE(A83)))}Ist d.Bereich
95D91:=VERWEIS(2;1/(A83:A90<>"");A83:A90)leer, entsteht
96Fml-Längen: 75:35 Zeichend.Fehler #NV.


Fro'Wei'n! Gruß, Luc :-?


  

Betrifft: AW: Noch mal zur Klarstellung: Deine Fml ist zwar... von: BoskoBiati
Geschrieben am: 22.12.2009 22:33:18

Hallo Luc,

hier die Originalformel:

=WENN(ZEILE(A4)>ANZAHL(A$1:A$1048576;G$2);"";SUMME(D4;B5;WENN(C5="v";INDIREKT("E"&VERWEIS(2; 1/C$1:C4<>"");ZEILE(A$1:A$1048576)&":E"&ZEILE(A4));0))) 
dazu meine:
=WENN(ZEILE(A6)>ANZAHL(A:A;G$2);"";SUMME(D6;B7;WENN(C7="v";INDIREKT("E"&VERWEIS(9;1/(C$2:C7<>"") _
) &":E"&ZEILE(A6));0))
;ZEILE(A$1:A$1048576) war falsch.
Dein Kommentar bezog sich nur auf die Verweisformel:
VERWEIS(2;1/C$1:C4<>"") ?
Hier wird aufsteigende Sortierung angenommen. Aber das ist es evtl nicht mal (allein). C1 enthält den Text Verr., durch den sich 1 wohl kaum teilen lässt, die anderen Zellen sind leer, also 0. Auch, wenn du - wie du viell beabsichtigt hast 1/(C$1:C4<>"") schreiben würdest, hättest du noch 3x 0 als Ergebnis. Der andere Wert wäre 1. Was anderes als 0 oder 1 käme hier auch nie raus und damit würde 2 auch nie gefunden wdn, worauf VERWEIS mit #NV reagiert...

Gruß

Bosko


  

Betrifft: Ja, richtig! 2 wird nicht gefunden und 1/0,... von: Luc:-?
Geschrieben am: 24.12.2009 03:41:27

...weil alleinig vorhanden, führt zu #NV, Bosko... ;-)
Das 1/"Verr." wäre dabei irrelevant, wenn wenigstens 1 Zahlenwert eingetragen wäre. Und das Richtig bezog sich tatsächlich nur auf den VERWEIS-Teil deiner Fml. Alles andere habe ich nicht untersucht, weil ich dir durchaus eine richtige Gesamtlösung zutraue... ;-)
Gruß Luc :-?


  

Betrifft: AW: Ja, richtig! 2 wird nicht gefunden und 1/0,... von: BoskoBiati
Geschrieben am: 24.12.2009 06:16:40

Hallo Luc,

dann sieh Dir die beiden Tabellen an:
Tabelle2

 ABCDEFGH
1DatumEin-/Ausz.Verr.SummeZinsenZinssatzAbrechnungHilfsspalte
207.01.2009300 3002,831031.12.200910
310.02.2009100 4001,56 10
424.02.2009500 9008,75 10
531.03.2009 v913,1417,317,5 7,5
630.06.2009 v943,591,77 7,5
709.07.2009250 1193,591,24 7,5
814.07.2009-750 443,594,815 5
930.09.2009100 543,594 5
1022.11.2009-350 193,591,05 5

Formeln der Tabelle
ZelleFormel
D2=WENN(ZEILE(A1)>ANZAHL(A:A;G$2); "";SUMME(D1;B2;WENN(C2="v";INDIREKT("E"&VERGLEICH(VERWEIS(9;1/(C$1:C2<>""); $C$1:C2); $C$1:C2)-1 &":E2"); 0)))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Tabelle1

 AB
1x1
2ys
3 1
4 2
5r2
6 2
7 5
8 5
9t5
10 5
11 9
12 9
13s9

Formeln der Tabelle
ZelleFormel
B1=VERWEIS(2;1/($A$1:$A$13<>""))
B2=VERWEIS(2;1/($A$1:$A$13<>""); A1:A13)
B3=VERGLEICH(VERWEIS(2;1/($A$1:$A1<>""); $A$1:$A1); $A$1:$A1)
B4=VERGLEICH(VERWEIS(2;1/($A$1:$A2<>""); $A$1:$A2); $A$1:$A2)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Also ich finde hier nirgendwo #NV


  

Betrifft: Na und! Warum ist das hier so, wäre die... von: Luc:-?
Geschrieben am: 25.12.2009 01:31:57

...Frage, Bosko,
denn das es in meinem Bsp so ist wie ich beschrieben habe, ist 1. logisch und 2. leicht nachvollziehbar!
In der 1.Tab käme mit VERWEIS- Arg1=2 statt 9 wohl dasselbe heraus, denn es ergibt sich aus der Division stets nur 1 oder F-Wert. Wenn C1:C2 wirklich leer wäre, würde VERWEIS auch #NV liefern, aber C1 enthält ja den Spaltentitel, was in dieser (richtigen) Form der Fml stets 1 ergibt! Da dieser Wert von VERGLEICH nicht gefunden wird, wird der nächstniedrigere, also 0, gewählt. Diesen Wert hat hier quasi jede jeweils vorhergehenden Zelle, da alle leer sind! Somit ergibt sich stets die letzte Zelle aus dem angegebenen Bereich - egal ob leer oder belegt. Im Folgenden wdn dann alle die Zellen gleicher Position in E summiert. Da kann man doch auch gleich...
SUMME(D1;B2;WENN(C2="v";E1:E$2; 0))
...schreiben! Folglich scheint die ganze Fml suboptimal und/oder für einen komplexeren Zusammenhang bestimmt zu sein.
In deinem 2.Bsp enthält A nur Text. Hier ergibt sich aus der Division 1, weshalb B1 auch 1 ergibt. Bezogen auf Bsp1 heißt das, hier kommt auch immer 1 heraus, wenn alles außer dem miteinbezogenen Spaltentitel leer ist! Trotzdem hat der Fragesteller #NV erhalten, darauf bezog sich ja die Frage, denn seine Fml war schließlich falsch. Durch die Kombi mit VERGLEICH erhältst du nur die Position des mit VERWEIS gefundenen Wertes im Vektor. Das wäre in B3 die von x, denn Anderes kann in 1er, der 1., Zelle nicht gefunden wdn. In B4ff ist es nicht besser - das s aus B2 kann wegen des kürzeren Vektors nicht ermittelt wdn, sondern stets nur die Position der letzten belegten Zelle, was du hiermit ja viell auch demonstrieren wolltest. Bewiesen ist damit nur das und dass VERWEIS auch Texte findet, was in meinem Bsp wohl nicht so deutlich wurde. Trotzdem ist die Kombi von VERGLEICH und VERWEIS idR unnötig, da dann außerdem noch INDIREKT eingesetzt wdn muss, nur, um das zu finden, was auch VERWEIS allein, bei richtiger Anwendung, liefern könnte... Unökonomisch, gelle... ;-)
#NV erhältst du nur, wenn der ganze Bezugsvektor (Arg2) wirklich leer ist, weil die Division dann nur F-Werte liefert.
Gruß Luc :-?


Beiträge aus den Excel-Beispielen zum Thema "Fehlermeldung #NV"