Microsoft Excel

Herbers Excel/VBA-Archiv

SUMMENPRODUKT | Herbers Excel-Forum


Betrifft: SUMMENPRODUKT von: Peter
Geschrieben am: 28.01.2010 10:54:05

Guten Tag

Ich möchte mit SUMMENPRODUKT alle Zahlen oberhalb des Totals addieren, die vornean ein * haben und bei denen das Jahr nicht demjenigen entspricht, das in der Variable xJahr enthalten ist.

Im konkreten Fall ergäbe das Ergebnis 460.7. Leider habe ich das nicht geschafft. Kann mir jemand helfen?

Danke, Peter

Tabelle1

 ABCD
1  2004  341.30
2  *2004  (341.30)
3  2005  210.00
4  *2005  (210.00)
5  2006  (549.70)
6  *2006  555.00
7  2007  (35'515.85)
8  *2007  13.00
9  2008  (73'343.00)
10  *2008  444.00
11  2009  28'339.99
12  *2009  99'297.59
13       
14       
15Total    19'241.03
16       
17       
18Summe    460.7
19       
20VariablexJahr  2009

verwendete Formeln
Zelle Formel
D15 =SUMME(D1:D13)
D20 =xjahr

definierte Namen
Name Bezieht sich auf Tabelle Z1S1-Formel
xjahr=2009 =2009

Tabellendarstellung in Foren Version 4.31


  

Betrifft: Eine Möglichkeit mit Matrixfml u.SUMME,... von: Luc:-?
Geschrieben am: 28.01.2010 11:15:21

...Peter,
wäre...
{=SUMME(WENN(UND(LINKS(B1:B12)="*";--TEIL(B1:B12;2;4)=D20);D1:D12;0))}
Es gibt noch mehr und kürzere wie du sicher gleich/bald an weiteren AWn sehen wirst... ;-)
Gruß Luc :-?


  

Betrifft: AW: SUMMENPRODUKT von: Tino
Geschrieben am: 28.01.2010 11:23:10

Hallo,
müsste funktionieren.

=SUMMENPRODUKT((WECHSELN(B1:B12;"*";"")*1<>D20)*(LINKS(B1:B12;1)="*")*(D1:D12))
Gruß Tino


  

Betrifft: bei Leerzellen gibt's Murks von: WF
Geschrieben am: 28.01.2010 11:36:56

.


  

Betrifft: stimmt, dann geht Deine. :-) oT. von: Tino
Geschrieben am: 28.01.2010 11:47:35




  

Betrifft: gleich mal ungleich von: WF
Geschrieben am: 28.01.2010 11:29:54

Hi Peter,

=SUMMENPRODUKT((LINKS(B1:B14)="*")*(RECHTS(B1:B14;4)<>TEXT(D20;"####"))*D1:D14)

Salut WF


  

Betrifft: AW: SUMMENPRODUKT von: Peter
Geschrieben am: 28.01.2010 11:37:06

Hallo zusammen

Das ist alles beeindruckend, vielen Dank für alle Antworten!

Ich habe mich für die Variante von WF entschieden.

Gruss, Peter