Microsoft Excel

Herbers Excel/VBA-Archiv

Runden in Wenn-Befehl | Herbers Excel-Forum


Betrifft: Runden in Wenn-Befehl von: Franky
Geschrieben am: 08.01.2012 11:32:48

Hallo zusammen,

ich habe ein Problem, mit der Verschachteltung zweier Befehle:
a) Wenn()
b) Runden()

in der Zeile GB3 steht der Befehl zum Sortieren der Spalte (Werte beginnen ab GC60)
=WENN(GC3="";"";INDIREKT("GD"&VERGLEICH(GC3;GE:GE;)))

in der Zeile GC3 steht der Befehl zum Sortieren der Spalte:(Werte beginnen ab GC60)
=WENN(GC60="";"";KKLEINSTE(GE:GE;ZEILE(GC1)))

das Ergenis dieser Berechnung ist z.B. -23,99999999
weil in der Zwischenspalte (GE3) der Befehl:
=+GC60+ZEILE()/1000000000
berechnet wird.

Das Sortieren der Spalte funktioniert auch wunderbar: Jedoch soll das Ergebnis gleich gerundet werden:

Diese Formeln funktionieren leider NICHT!!!!
=WENN(GC60="";"";KKLEINSTE(GE:GE;ZEILE(GC1)));Runden(GC3;0)
=Runden(WENN(GC60="";"";KKLEINSTE(GE:GE;ZEILE(GC1)))GC3;0)

Habe ich keine Klammer falsch gesetzt oder kann man dieses Problem nur wieder mit einer Zwischenspalte lösen??

Vielen Dank für Eure Hilfe
Franky

  

Betrifft: AW: Runden in Wenn-Befehl von: Hajo_Zi
Geschrieben am: 08.01.2012 11:47:32

Hallo Frank,

in Deiner letzten Formel ist das wenn falsch es gibt nur dies oder das und nicht dies, oder das, oder jenes, oder ...
Ich baue die Datei nicht nach.

GrußformelHomepage


  

Betrifft: AW: Runden in Wenn-Befehl von: Franky
Geschrieben am: 08.01.2012 12:04:50

Hallo Hajo_Zi,

ich mache mal am besten eine kleine Beispiel-Datei fertig !! - Dann ist das alles besser verständlich.


  

Betrifft: Das ist ja auch kein Wunder, denn so wie du ... von: Luc:-?
Geschrieben am: 08.01.2012 12:48:51

…das versuchst, Franky,
muss ich bezweifeln, dass die Fmln von dir sind, was ja auch nicht verwunderlich wäre bei dem von dir angegebenem Level.
In der 1.Fml versuchst du das, was Hajo mit ”dies oder das oder jenes” meinte → d.h., du hast einfach ein Argument zuviel in der WENN-Fkt.
In der 2.Fml versuchst du, ggf auch einen Leertext zu runden!
Richtig wäre 3., nur hast du das gar nicht erst versucht …
=WENN(GC60="";"";Runden(KKLEINSTE(GE:GE;ZEILE(GC1));0))
Was da dann GC3 soll, erschließt sich mir allerdings auch nicht.
Gruß + schöSo, Luc :-?


  

Betrifft: AW: Das ist ja auch kein Wunder, denn so wie du ... von: Franky
Geschrieben am: 08.01.2012 13:56:16

Hallo Luc !
anbei vielen herzlichen Dank für Deine Lösung ! - Leider funktioniert der Befehl
=WENN(GC60="";"";Runden(KKLEINSTE(GE:GE;ZEILE(GC1));0)) nicht, obwohl er vom Syntax her richtig ist.

Ich bekomme in der Spalte: GB3 einen #NV - Fehler!

Um die Angelegenheit etwas besser deutlich zu machen, habe ich eine Beispiel-Datei hochgeladen:
https://www.herber.de/bbs/user/78297.xlsx

Die Beispiel-Datei ist eigentlich selbsterklärend: Die Werte von B22:B36 werden der Größe nach Sortiert.

Jetzt zur eigentlich Problematik:
Die Werte in der Spalte vom B3:B17 sollen automatisch gerundet werden, da diese Werte wieder Teil einer anderen Berechnung sind.

Vielen herzlichen Dank im voraus!
Franky


  

Betrifft: AW: Das ist ja auch kein Wunder, denn so wie du ... von: Andre´
Geschrieben am: 08.01.2012 15:42:32

Hallo Franky,


meinst Du so: https://www.herber.de/bbs/user/78301.xlsx


MFG Andre


  

Betrifft: AW: Das ist ja auch kein Wunder, denn so wie du ... von: Josef Ehrensberger
Geschrieben am: 08.01.2012 15:48:35


Hallo Franky,

Tabelle1

 ABCDEF
1ZahlenWerte    
2     Werte von Spalte B:
352120 2,000000000000000
42424 4,000000000000000
51512317 12,000000000000000
6413413 13,000000000000000
731752 17,000000000000000
8120644 20,000000000000000
9927745 27,000000000000000
101134850 34,000000000000000
11644927 44,000000000000000
127451059 45,000000000000000
138501134 50,000000000000000
1414551272 55,000000000000000
1510591383 59,000000000000000
1612721455 72,000000000000000
1713831512 83,000000000000000

Formeln der Tabelle
ZelleFormel
A3=WENN(B3="";"";INDEX(C:C;VERGLEICH(KKLEINSTE(D:D;ZEILE(B1)); D:D;0)))
B3=WENN(B22="";"";RUNDEN(KKLEINSTE(D:D;ZEILE(B1)); 0))
D3=+B22+ZEILE()/1000000000
F3=B3


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4






« Gruß Sepp »



  

Betrifft: AW: Das ist ja auch kein Wunder, denn so wie du ... von: Franky
Geschrieben am: 08.01.2012 16:14:23

Hallo Josef !

mal wieder schön von Dir zu hören ! - Deine Lösung ist perfekt ! - Vielen Dank

Franky


Beiträge aus den Excel-Beispielen zum Thema "Runden in Wenn-Befehl"