Microsoft Excel

Herbers Excel/VBA-Archiv

Verweis | Herbers Excel-Forum


Betrifft: Verweis von: Thorsten
Geschrieben am: 01.02.2012 07:49:43

Guten Morgen,

ich habe folgende Datei hochgeladen:

https://www.herber.de/bbs/user/78677.xls

Heirzu jetzt folgende Frage: Kann man die Angaben in Spalte A per Formel, passend zur Laufzeit ( B; C) für jede Zeile automatisch, also per Formel, eingeben lassen?

Vielen Dank und viele Grüße
Thorsten

  

Betrifft: =($B2<=E$1)*($C2>=E$1)*($A2) owT von: silex1
Geschrieben am: 01.02.2012 08:03:37

VG, Rene


  

Betrifft: KLASSE !!! von: Thorsten
Geschrieben am: 01.02.2012 08:11:40

Super - das funktioniert klasse

Danke Danke

Thorsten


  

Betrifft: Rückfrage von: Erich G.
Geschrieben am: 01.02.2012 08:04:06

Hi Thorsten,
deine Frage ist nicht so ganz klar.

Die Spalten A:C lassen sich komplett aus den Daten der Spalten E:AE berechnen - per Formeln.
Für Spalte A müsste man wohl noch voraussetzen, dass in einer Zeile von E:AE keine verschiedenen Werte vorkommen.
Ist das immer so?

Umgekehrt kann man - wenn A:C eingegeben wird - daraus die Belegung der Spalten E:AE berechnen.

Was genau möchtest du eingeben und was per Formeln berechnen?

Rückmeldung wäre nett! - Grüße aus Kamp-Lintfort von Erich


  

Betrifft: Antwort auf Rückfrage von: Thorsten
Geschrieben am: 01.02.2012 08:08:35

Hi Erich,

ich werde Daten in den Spalten A:C haben - diese sollten dann automatisch in E:AE ausgegeben werden.

Vielen Dank und viele Grüße

Thorsten


  

Betrifft: Vorschlag von: Erich G.
Geschrieben am: 01.02.2012 08:12:37

Hi Thorsten,
die Formel in E2 kannst du nach rechts und unten kopieren:

 ABCDEF
1QtyStartEnd 01.01.201202.01.2012
21001.01.201205.01.2012 1010
32001.01.201204.01.2012 2020
43002.01.201205.01.2012  30
54003.01.201204.01.2012   
65003.01.201206.01.2012   
76004.01.201207.01.2012   

Formeln der Tabelle
ZelleFormel
E2=WENN(($B2<=E$1)*(E$1<=$C2); $A2;"")
F2=WENN(($B2<=F$1)*(F$1<=$C2); $A2;"")
E3=WENN(($B3<=E$1)*(E$1<=$C3); $A3;"")
E4=WENN(($B4<=E$1)*(E$1<=$C4); $A4;"")

Rückmeldung wäre nett! - Grüße aus Kamp-Lintfort von Erich


Beiträge aus den Excel-Beispielen zum Thema "Verweis"