Microsoft Excel

Herbers Excel/VBA-Archiv

Summierung Zeilen



Excel-Version: Alle Versionen

Betrifft: Summierung Zeilen
von: Lars
Geschrieben am: 28.05.2002 - 13:12:10

Hallo Excel-Freunde,

ich versuche mich schon seit einiger Zeit an folgendem Problem:

In einer Tabelle mit 12.000 Zeilen sollen verschiedene Werte summiert werden ....
Bsp:

Wert1 Wert2 Wert3 Projektxxx-85439 Wert4
Wert1 Wert2 Wert3 Projektxxx-54738 Wert4
Wert1 Wert2 Wert3 Projektxxx-43436 Wert4
Wert1 Wert2 Wert3 Projektxxx-54347 Wert4

SummeWert1 SummeWert2 anhand des Inhaltes "Projektxxx-" Spalte 4

Wert1 Wert2 Wert3 Projektxyz-342 Wert4
Wert1 Wert2 Wert3 Projektxyz-255 Wert4

SummeWert1 SummeWert2 anhand des Inhaltes "Projektxyz-" Spalte 4


Wert1 Wert2 Wert3 Projektzzz Wert4
Wert1 Wert2 Wert3 Projektzzz Wert4
Wert1 Wert2 Wert3 Projektzzz Wert4
Wert1 Wert2 Wert3 Projektzzz Wert4
Wert1 Wert2 Wert3 Projektzzz Wert4
Wert1 Wert2 Wert3 Projektzzz Wert4

SummeWert1 SummeWert2 anhand des Inhaltes Spalte 4

Wie muss die Summierungsformel lauten ? Leider sind auch die Zeilen pro Projekt unterschiedlich ... Ich habe es schon mit
wenn,dann versucht, aber lauten dann die Wildcards ?


Freue mich über jeden Tipp

Grüße
Lars Höfener

  

Re: Summierung Zeilen
von: Arnim
Geschrieben am: 28.05.2002 - 17:43:33

Hallo Lars,

so ganz habe ich wohl den Aufbau der Tabelle, d.h. das von Dir gesteckte Ziel nicht durchschaut.
Ich gehe mal davon aus, daß Du eine Zusammenstellung machen willst.
Übrigens: Steht immer "Projektxxx" usw. in Spalte D (also "Spalte4") oder nur "xxx-Nr..." ?
Ich habe es wie folgt angenommen:
In SpalteF schreibe ab F2 die Projekt-Nummern, also z.B.xxx-85439 usw. untereinander bis Fx.
in G1 und H1 Überschriften Summe1 bzw. Summe2.
In G2 schreibe folgende Formel:
=SUMMENPRODUKT((TEIL(D$2:D$15000;1;3)=F2)*(A$2:A$15000))
und kopiere sie herunter.
Ebenso verfährst Du mit den 2. Summen aus Spalte B in H2.
Wenn Du jeweils "Projektxxy-..." stehen hast, muß in der Formel geändert werden: TEIL(D$2:D$15000;8;3)
Vielleicht hilft es Dir etwas weiter!

Gruß Arnim

  

Zusatz
von: Arnim
Geschrieben am: 28.05.2002 - 19:35:15


In Spalte F sollen die Projekt-Gruppen stehen und mit xxx, xyz usw. bezeichnet sein. Will man es anders haben, muß die Formel (TEIL) entsprechend abgeändert werden.

Gruß Arnim


  

Re: Zusatz
von: Lars
Geschrieben am: 29.05.2002 - 14:33:13

Hallo Arnim,

vielen Dank für die schnelle Hilfe. Ich habe jetzt eine summewenn - Verknüpfung mit einer linken Teilstring-Variante eingesetzt... Klappt auch ganz gut.

Wie kann ich verhindern, dass eine Sortierung die Formeln in der Summenzeile nicht ändert ?

Grüße

Lars Höfener


  

Re: Zusatz
von: Arnim
Geschrieben am: 29.05.2002 - 15:46:21

Hallo Lars,

lese erst jetzt die Frage; vorhin kam man nicht ins Forum rein.
Ganz verstehe ich es jetzt nicht. Welche Formel hast Du jetzt? Und wo stehen die Formeln? Innerhalb der Aufstellung als Zwischensummen oder extra aufgeführt, wie mein Vorschlag lautete?
Auf jeden Fall ist eine Sortierung dann möglich, wenn Du in "Daten" die Sortierung wählst. Es muß dann alles markiert sein und die entsprechende Spalte zur Sortierung ausgewählt sein.
Mehr kann ich dazu nicht sagen, da ich nicht die Tabelle vor mir habe.

Gruß Arnim


  

Re: Zusatz
von: Lars
Geschrieben am: 29.05.2002 - 16:30:44

Hallo Arnim,

diese Formeln setze ich jetzt ein:
=SUMMEWENN($G$5:G11565;B11566;$E$5:E11565)

und in B11566:
=VERKETTEN(LINKS(G11565;5);"*")

Das klappt ganz gut ... nur Sortieren darf ich jetzt nicht mehr - da werden die Formeln automatisch angepasst :-(

Danke für Deine Tipps

Grüße Lars

  

Re: Zusatz
von: Arnim
Geschrieben am: 29.05.2002 - 16:55:23

Hallo Lars,

hast Du eigentlich meinen Vorschlag mal ausprobiert? Er müßte problemlos klappen. Auch beim Sortieren! (Ich habe zwar nur ein paar Hundert Zellen genommen - aber trotzdem!).
Deine Lösung habe ich nicht nachvollzogen; wenn sie klappt, ist's ja gut! Zum Sortieren versuche mal die Zellbezüge in der Formel alle absolut zu setzen ($) und die Sortierung nach meinem letzten Beitrag vorzunehmen.

Gruß Arnim


 

Beiträge aus den Excel-Beispielen zum Thema "Summierung Zeilen"