Microsoft Excel

Herbers Excel/VBA-Archiv

Mittelwert ohne minus Werte

Betrifft: Mittelwert ohne minus Werte von: Snewi
Geschrieben am: 29.10.2012 10:34:09

Ich habe da noch was :-)

Wie kann ich aus einer Spalte den Mittelwert berechnen ohne das minus Werte berücksichtigt werden?? Alles ohne Hilfsspalte wenn möglich!

gruß

  

Betrifft: =MITTELWERTWENN(A1:A5;">0") o.w.T. von: AndreasG
Geschrieben am: 29.10.2012 10:38:18

.


  

Betrifft: AW: =MITTELWERTWENN(A1:A5;">0") o.w.T. von: Snewi
Geschrieben am: 29.10.2012 11:30:30

Supi geht!

Hab noch was anderes warum funktioniert hier meine Mittelwertwenn Formel nicht?
https://www.herber.de/bbs/user/82367.xlsx


gruß Snewi


  

Betrifft: Datum ungleich Text von: Erich G.
Geschrieben am: 29.10.2012 11:56:06

Hi Snewi,
die Formel funktioniert schon - und liefert auch das richtige Ergebnis, wenn auch nicht das gewünschte.

In Spalte A steht ein Datum, in F2 ein Text. die können nie gleich sein.

Hier Spalte A mal anders formatiert (aber mit denselben Werten):

 AB
24090902.01.2012 00:00
301.01.201202.01.2012 00:00
4Januar02.01.2012 00:00

Formeln der Tabelle
ZelleFormel
A2=GANZZAHL(B2-6/24)
A3=GANZZAHL(B3-6/24)
A4=B4-1

Tatsächlich steht in Spalte A Zahlen wie in A2 im Standardformat zu sehen. 40909 ist nie = "Januar".

Warum eigentlich GANZZAHL und -6/24, warum nicht einfach A2:= B2-1 ?

Rückmeldung wäre nett! - Grüße aus Kamp-Lintfort von Erich


  

Betrifft: AW: Datum ungleich Text von: Snewi
Geschrieben am: 29.10.2012 12:36:53

Bei uns geht ein Tag nich von 0:00 - 0:00 sondern von 06:00 - 06:00 :-)
Deshalb möchte ich die Monate ein bischen anders aufgeteilt! Die Formel aus A4 passt so dann nicht!

Was könnte ich sonst noch machen?

Gruß


  

Betrifft: schlechte Beispiele von: Erich G.
Geschrieben am: 29.10.2012 13:01:47

Hi Snewi,
dann passten deine Beispiele nicht so gut zur Realität...

Mit GAZZZAHL würde ich hier nicht arbeiten. Dezimalzuzahlen sind zwangsläufig ungenau.
Du kannst nicht sicher sein, ob 6/24 = 0,25 oder 0,249999... oder 0,25000000001 ist.
Da kann es passieren, dass GANZZAHL mal einen ganzen Tag klaut. GANZZAHL(3,999999..) ist 3, nicht 4.

Schau mal das:

 ABCDEF
1Monat (?)DatumDauer   
24090902.01.2012 05:0020627,1  Januar
302.01.201202.01.2012 06:0098,4  4,05
4Januar02.01.2012 00:0091,6 MittelwertWenn4,05
5Januar02.01.2012 05:00-61,701.01MittelwertWenns69,8
6Januar02.01.2012 06:0069,802.01  
7Januar02.01.2012 00:0057,9   

Formeln der Tabelle
ZelleFormel
A2=RUNDEN(B2-18/24;)
A3=RUNDEN(B3-18/24;)
F3=MITTELWERTWENN(A:C;F2;C:C)
A4=RUNDEN(B4-18/24;)
F4=MITTELWERTWENN(A:A;F2;C:C)
A5=TEXT(RUNDEN(B5-18/24;); "MMMM")
D5=TEXT(RUNDEN(B5-18/24;); "TT.MM")
F5=MITTELWERTWENNS(C:C;A:A;F2;C:C;">0")
A6=TEXT(RUNDEN(B6-18/24;); "MMMM")
D6=TEXT(RUNDEN(B6-18/24;); "TT.MM")
A7=RUNDEN(B7-18/24;)

Rückmeldung wäre nett! - Grüße aus Kamp-Lintfort von Erich


  

Betrifft: AW: schlechte Beispiele von: Snewi
Geschrieben am: 29.10.2012 13:39:21

Hallo,

ich nutze jetzt die Formel:

=TEXT(RUNDEN(XX-18/24;); "MMMM")
und dazu das Mittelwertwenn!

Das klappt soweit oder spricht was dagegen? Sollte ich es anders machen?
Was macht das Mittelwertwenns anders?

Gruß


  

Betrifft: MITTELWERTWENNS von: Erich G.
Geschrieben am: 29.10.2012 14:30:12

Hi Snewi,
MITTELWERTWENNS brauchst du vielleicht gar nicht. Es bietet die Möglichkeit, gleichzeitig mehrere Bedingungen
aufzustellen. Für dein Beispiel wäre das der Mittelwert aller Werte
- die größer als 0 sind und
- bei denen die Tage im Januar liegen.
(Das war aus deiner 1. Frage.)

Rückmeldung wäre nett! - Grüße aus Kamp-Lintfort von Erich


  

Betrifft: MITTELWERTWENNS von: Erich G.
Geschrieben am: 29.10.2012 12:44:33

Hi Snewi,
schau dir das mal an:

 ABCDEF
1Monat (?)DatumDauer   
24090902.01.2012 00:0020627,1  Januar
301.01.201202.01.2012 00:0098,4  4,05
4Januar02.01.2012 00:0091,6 MittelwertWenn4,05
5Januar02.01.2012 00:00-61,7 MittelwertWenns69,8
6Januar02.01.2012 00:0069,8   
7Januar02.01.2012 00:0057,9   

Formeln der Tabelle
ZelleFormel
A2=GANZZAHL(B2-6/24)
A3=GANZZAHL(B3-6/24)
F3=MITTELWERTWENN(A:C;F2;C:C)
A4=B4-1
F4=MITTELWERTWENN(A:A;F2;C:C)
A5=TEXT(B5-1;"MMMM")
F5=MITTELWERTWENNS(C:C;A:A;F2;C:C;">0")
A6=TEXT(B6-1;"MMMM")
A7=GANZZAHL(B7-6/24)

In Spalte A stehen Texte nur in den Zellen A1, A5 und A6.

Die Formel in F3 ist falsch (A:C statt A:A), die in F4 berücksichtigt noch nicht "größer 0".

Rückmeldung wäre nett! - Grüße aus Kamp-Lintfort von Erich


  

Betrifft: AW: Mittelwert ohne minus Werte von: Tino
Geschrieben am: 29.10.2012 10:41:31

Hallo,
vielleicht geht es so.

 ABC
1  Mittelwert
21 2,66666667
32  
4-3  
55  
6-5  

Formeln der Tabelle
ZelleFormel
C2=SUMMEWENN(A:A;">=0")/ZÄHLENWENN(A:A;">=0")


Gruß Tino


 

Beiträge aus den Excel-Beispielen zum Thema "Mittelwert ohne minus Werte"