Makro gesucht



Excel-Version: 10.0 (Office XP)
nach unten

Betrifft: Makro gesucht
von: Reto
Geschrieben am: 03.07.2002 - 21:27:11

Hallo
Ich bin wieder einmal auf einer Makrosuche für meinen lottozahlengenerator folgendermassen:

In den Zellen F4 bis K4 habe ich je eine Zahl. Also insgesamt sind ja dies 6 Zahlen.Und wenn ich die Taste F9 drücke, ändern diese Zahlen.
Nun mein Wunsch ist jetzt, dass die 6-er Reihe bei jeder Betätigung der Taste F9 in eine neue Zeile geschrieben wird. Und zwar sind dies F5:K5,F6:K6......bis..F15:K15.

Die Krönung wäre dann nur noch, dass wenn die Zeilen voll sind, dass eine Meldung erscheint, ob die bestehenden Kombinationen (F5:K5,F6:K6......bis..F15:K15) jetzt gelöscht werden sollen oder nicht.

Gruss und Dank Reto

nach oben   nach unten

Re: Makro gesucht
von: Zwea
Geschrieben am: 04.07.2002 - 05:01:10

Hallo Reto
Kannst du erstmal hier schreiben mit welche Makro du die moment deine generator starten?
dann können wir vielleicht ergänzen.....OK?
Gruß Zwea

nach oben   nach unten

Re: Makro gesucht
von: Reto
Geschrieben am: 04.07.2002 - 12:40:56

Hallo nur das habe ich

a4==GANZZAHL(45*ZUFALLSZAHL()+1)
b4==KKLEINSTE(A$4:A$9;ZEILE()-3)
c4==B4
a5==GANZZAHL(45*ZUFALLSZAHL()+1)
b5==KKLEINSTE(A$4:A$9;ZEILE()-3)
c5==WENN(B5<=C4;C4+1;B5)

danach habe ich runterkopiert A5:A9 B5:B9 C5:C9

F4=C4
G4=C5
H4=C6.....

Gruss Reto

nach oben   nach unten

Re: Makro gesucht
von: Zwea
Geschrieben am: 04.07.2002 - 13:50:33

Hallo Reto
Sub LottoZG()
Dim C As Range, d As Range, G As Range
Dim n%, TMP%, Co%
Set d = Range(" ") ' Hier deine Reihe
d.ClearContents
For Each C In d
TMP = Int((49 * Rnd)) + 1
Set G = d.Find(TMP, LookAt:=xlWhole)
While Not G Is Nothing
TMP = Int((49 * Rnd)) + 1
Set G = d.Find(TMP, LookAt:=xlWhole)
Wend
C = TMP
Next C
End Sub
Gruß Zwea
nach oben   nach unten

Re: Makro gesucht
von: Reto
Geschrieben am: 04.07.2002 - 17:37:30

Hallo Zwea
Ich brauch hier noch ne kleine Erklärung,bitte.
Also wo muss dieses Makro hin und bei meine reihe kommt dann die Reihe wo ich das Resultat will oder was? Bis jetzt geht noch gar nichts, egal was und wo ich das Makro ablege.
Bitte um Antwort. DANKE
GRUSS
RETO

nach oben   nach unten

Re: Makro gesucht
von: Zwea
Geschrieben am: 05.07.2002 - 09:38:28

Guten Morgen Reto
1.VBA-Projekt-Modul einfuge un die Code dort einfuge

Sub LottoZG()
Dim C As Range, d As Range, G As Range
Dim n%, TMP%, Co%
Set d = Range("A1:F1 ")
d.ClearContents
For Each C In d
TMP = Int((49 * Rnd)) + 1
Set G = d.Find(TMP, LookAt:=xlWhole)
While Not G Is Nothing
TMP = Int((49 * Rnd)) + 1
Set G = d.Find(TMP, LookAt:=xlWhole)
Wend
C = TMP
Next C
End Sub


2. zurück zum Tabelle- Schaltfläche und die Makro zuweissen
Eines muss ich dir nocht sagen das gehen nur für 6 Reihe, wenn du z.B.12 Reihe haben wills muß du noch ein Modul eimbau, aber geben anderes Name
Gruß Zwea
P.D.: wenn du das nichst schafen kann ich dir ein beispiel schicken


nach oben   nach unten

Danke alles klar (o.T.)
von: Reto
Geschrieben am: 05.07.2002 - 21:34:07


 nach oben

Beiträge aus den Excel-Beispielen zum Thema "Tabellenblattname überprüfen"