Microsoft Excel

Herbers Excel/VBA-Archiv

Formel

Betrifft: Formel von: Zimmer
Geschrieben am: 10.09.2014 11:31:29

Hi Alle,

ich habe ein "Problem" was ich aufgrund meiner wenigen Kenntnise nicht lösen kann.

Zum Ausgangspunkt.

Es gibt die Tabelle "Abfrage" dort werden viele Spalten automatisch per sql abfrage gefüllt. Unter anderem gibt es eine Spalte B (Dort ist eine Nummer die ich benötige) und eine Spalte N (Hier werden Textkonventionen gefüllt)
Dazu kommt noch eine weitere Tabelle "X" wo in der Spalte A etwas passieren soll.

Nun zum Problem:

Ich möchte das zu anfang 500 Zellen in Spalte A auf Tabelle "X" mit Formeln gefüllt sind die folgendes tun:

Suche in Tabelle "Abfrage" alle Zellen in N nach folgendem Inhalt "-mx-" (der gesuchte Inhalt ist nur ein Teilausschnitt des Zelleninhalts).. in den Zellen steht meist sowas wie 001-ver-mx-bb-00.xp zb.)

wenn du etwas mit -mx- findest in spalte N dann füge den inhalt aus der selben Zeile Spalte A in die Zelle mit der formel in tabelle "x" spalte A

ich habe das oben beschriebene mit einer array formel mit index und find bereits hinbekommen ABER..

wenn ich 500 Zellen mit der selben formel fülle dann füllen sich natürlich auch alle zellen mit dem gleichen inhalt. ich möchte aber.. wenn ein mal -mx- gefunden wurde und die entsprechnde nummer in spalte A überführt wurde nicht mehr gedoppelt wird..

endergebnis soll sein

Tabelle "Abfrage" (Inhalte vorhanden oder nicht)

Spalte A Zelle 15 : 123456 // Spalte N Zelle 15 001.777-mx-.aaa
Spalte A Zelle 19 : 789101 // Spalte N Zelle 19 001.488-mx-.aaa
Spalte A Zelle 28 : 555555 // Spalte N Zelle 28 001.666-mx-.aaa
usw.

Tabelle "x"

Spalte A Zelle 1 : 123456
Spalte A Zelle 2 : 789101
Spalte A Zelle 3 : 555555
usw.

  

Betrifft: AW: Formel von: Frank
Geschrieben am: 10.09.2014 12:12:02

Hi,

geht so m.E. nur mit VBA und ist mit XL-Basiskenntnissen nicht zu machen.
Vielleicht baut Dir jemand hier eine fertige Lösung. Dann aber sicher nur, wenn die Datei per Upload zur Verfügung gestellt wird.

Grüsse,
Frank


  

Betrifft: AW: Formel von: Jack_d
Geschrieben am: 10.09.2014 12:28:29

Hallo Zimmer

ich glaub du meinst sowas ..

http://www.excelformeln.de/formeln.html?welcher=194

Grüße


  

Betrifft: AW: Formel von: Zimmer
Geschrieben am: 10.09.2014 12:44:40

vielen DAnk für die bisheringen Antworten..

Die Datei kann ich leider nicht bereitstellen, da ich nicht der Autor bin und ich was dazupflegen soll.

Das mit der Extrahilfsspalte wäre ein Ansatz.. Allerdings habe ich dabei eine Problem entdeckt..

Meine Formel sieht so aus:

=WENN(ISTFEHLER(INDEX(Abfrage!B:B;MIN(WENN(ISTZAHL(FINDEN("-mx-";Abfrage!$N$1:$N$3001)); ZEILE($1:$3001)))));"";(INDEX(Abfrage!B:B;MIN(WENN(ISTZAHL(FINDEN("-mx-";Abfrage!$N$1:$N$3001)); ZEILE($1:$3001))))))

Wie weise ich denn an, dass wenn mehrere "-mx-" gefunden wurden auch in jeder Zelle ein anderes -mx- ausgegeben wird? Nach der jetzigen Formel sucht er nur ein -mx- und wenn gefunden sucht sich ja die nächste zelle mit der selben formel wieder nur das eine -mx-..


  

Betrifft: Also von: Jack_d
Geschrieben am: 10.09.2014 12:47:26

ich bau mir keine Mappe nach um die Formeln zu testen.

Entweder du machst es, oder ich bin raus. (So wie Hajo immer zu sagen pflegt)

Grüße


  

Betrifft: AW: Also von: Zimmer
Geschrieben am: 10.09.2014 14:06:57

Auf einen "Nachbau" bin ich gar nicht gekommen.. Klar hier kommt er! Danke

https://www.herber.de/bbs/user/92566.xlsx


  

Betrifft: Na Also :-D von: Jack_d
Geschrieben am: 10.09.2014 14:35:04

War doch gar nicht so schwer =)

ich hab mal ne Formel angepasst. für das sheet("mx")ab Zelle A3 und ff

=WENN(ZEILE()-3>SUMME(ISTZAHL(FINDEN("-mx-";Abfrage!M$1:M$100))*1);"";INDEX(Abfrage!B:B; KKLEINSTE(WENN(ISTZAHL(FINDEN("-mx-";Abfrage!M$1:M$100));ZEILE($1:$100));ZEILE(B1)))) 
Und das ganze als MAtrixformel abschliessen

Grüße


 

Beiträge aus den Excel-Beispielen zum Thema "Formel"