Microsoft Excel

Herbers Excel/VBA-Archiv

Transformation einer Tabelle

Betrifft: Transformation einer Tabelle von: Cello
Geschrieben am: 15.09.2014 16:48:17

Hallo zusammen,

ich habe eine Frage bezüglich der Transformation einer Tabelle in eine Binärtabelle.

In meiner Ausgangstabelle haben Unternehmen, die zu einem Verbund gehören, immer die selbe Verbundsnummer und dahinter jeweils eine spezifische Unternehmensnummer.

Nun möchte ich diese Tabelle transformieren. Die Unternehmen sollen einmal in einer Spalten stehen und dann transponiert in einer Zeilen stehen. Wenn zwei Unternehmen zu einem Verbund gehören, soll dies in der kreuzenden Zelle mit einer "1" beschrieben sein. Ansonsten bleibt die Zelle leer.

Anbei ein Beispiel:
https://www.herber.de/bbs/user/92646.xlsx

Ich danke vielmals

  

Betrifft: Erstellung Kreuztabelle von: Cello
Geschrieben am: 15.09.2014 19:38:34

Hallo zusammen,

ich habe das Beispiel noch einmal aktualiisert:

https://www.herber.de/bbs/user/92649.xlsx

Ich bin für jeden Tipp dankbar.

Viele Grüße


  

Betrifft: AW: Transformation einer Tabelle von: Daniel
Geschrieben am: 15.09.2014 19:50:01

Hi
Wenn du das unternehmenskürzel in die Spalten B und die Verbandsnummer in Spalten C, denn mit dieser Formel in H5:

=WENN($G5=H$4;"";WENN(SVERWEIS($G5;$B$5:$C$14;2;0)=SVERWEIS(H$4;$B$5:$C$14;2;0);1;""))

Ein Unternehmen darf aber nur einem Verband angehören, nicht mehreren.

Gruß Daniel


  

Betrifft: AW: Transformation einer Tabelle von: Cello
Geschrieben am: 15.09.2014 19:53:24

Hallo Daniel,

danke für deine Antwort.

Es ist so, dass die Unternehmen mehreren Verbänden angehören.

Hast du hierfür noch eine Idee?

Viele Grüße


  

Betrifft: AW: Transformation einer Tabelle von: Daniel
Geschrieben am: 15.09.2014 21:10:35

Hi

Klar, schau dir das mal an.
Die Diagonale (selbe Firma in Zeile und Spalte) wird nicht markiert, aber das ist eigentlich unnötig.

Hier die Formeln für deine neue Beispieldatei:
In der Liste Zelle C2 und nach unten kopieren:

 =" "&B2&" "&WENN(A2<>A3;"";C3)
In der Tabelle Zelle G2 und über die Tabelle ziehen:
=WENN(ODER(ZÄHLENWENN($C:$C;"*"&$F2&"*"&G$1&"*")>0;ZÄHLENWENN($C:$C;"*"&G$1&"*"&$F2&"*")>0);1;"") 
Gruß Daniel


  

Betrifft: AW: Transformation einer Tabelle von: Cello
Geschrieben am: 15.09.2014 22:30:22

Besten Dank!


 

Beiträge aus den Excel-Beispielen zum Thema "Transformation einer Tabelle"