Microsoft Excel

Herbers Excel/VBA-Archiv

Sortieren von Teilen mit Werten

Betrifft: Sortieren von Teilen mit Werten von: Bene
Geschrieben am: 18.11.2014 23:06:24

Hallo Zusammen,

ich hatte zwar schon einmal so ein ähnliches Problem, dennoch bekomme ich es nicht ganz hin. Anbei ein Beispiel-Datei die das Problem beschreibt.

https://www.herber.de/bbs/user/93857.xlsx

Ich danke für jede Hilfe :)

Grüße

  

Betrifft: sortiert aufstellen dann mit Formel zuordnen ... von: neopa C (paneo)
Geschrieben am: 19.11.2014 09:13:44

Hallo Bene,

... folgende Formeln nach unten kopieren. Dabei gehe ich davon aus, dass die Teiltabellen schon nach "Teil" sortiert sind , wenn die "Liste der "Teile aus ist1 und ist2 " sortiert sein soll.

Ich hab Dein Beispieldaten mal bewusst (gegen vorgenannte Regel) geändert (gelb markiert) um einmal aufzuzeigen, dass es der Formel egal wo welche "Teil"-Werte stehen aber nicht wie sie vor sortiert sind.

 BCDEFGHIJ
1Ist1 Ist2 Soll
2TeilWert TeilWert Teile aus Ist1 und Ist2Wert aus Ist1Wert aus Ist2
3A700 B500 A700600
4B1000 D400 B1000500
5C200 A600 C200100
6D600 C100 D600400
7G50 G20 G5020
8   F700 F 700
9   E800 E 800
10         

Formeln der Tabelle
ZelleFormel
H3{=WENN(E3="";"";WENN(B3="";INDEX(E:E;MIN(WENN(ISTNV(VERGLEICH(E$3:E$9;H2:H$3;)); ZEILE(A$3:A$9)))); B3))}
I3=WENNFEHLER(SVERWEIS(H3;B:C;2;); "")
J3=WENNFEHLER(SVERWEIS(H3;E:F;2;); "")
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Gruß Werner
.. , - ...


 

Beiträge aus den Excel-Beispielen zum Thema "Sortieren von Teilen mit Werten"