Liste ohne Leerzeilen

Bild

Betrifft: Liste ohne Leerzeilen
von: CS
Geschrieben am: 28.06.2015 16:22:36

Hallo,
habe im Archiv folgende Formel zur Darstellung von einer Tabellenspalte ohne Leerzeichen gefunden:
=WENNFEHLER(INDEX(A:A;KKLEINSTE(WENN(A$1:A$16<>0;ZEILE($1:$916));ZEILE()));"")
Zum einen muss ich zugeben, dass ich die Formel nicht ganz verstehe (würde ich aber gerne)
zum andren funktioniert sie bei mir nicht (nur in Zeile 1)
Hat jmd Zeit für eine Erklärung?
Danke!
CS

Bild

Betrifft: AW: Liste ohne Leerzeilen
von: Hajo_Zi
Geschrieben am: 28.06.2015 16:49:34
Du solltest die als Array Formel eingeben und ZEILE($1:$16)


Bild

Betrifft: AW: Liste ohne Leerzeilen
von: Herbert Grom
Geschrieben am: 28.06.2015 17:02:23
Hallo,
=WENNFEHLER(INDEX(A:A;KKLEINSTE(WENN(A$1:A$16<>0;ZEILE($1:$16));ZEILE(A1)));"")
Es kann sein, dass der "Zähler" fehlt. Aus A1 wird beim runterkopieren A2, A3 usw. Dies bringt Die dann die weiteren Ergebnisse aus den entsprechenden Zeilen.
Servus

Bild

Betrifft: AW: Liste ohne Leerzeilen
von: CS
Geschrieben am: 29.06.2015 11:35:23
Hallo,
danke für die Antworten - aber deine Ergänzung funktioniert leider auch nicht. Habe die "9" gestrichen und "A1" eingesetzt, so dass beim Kopieren A2, A3 usw. entsteht. Das Ergebnis ist eine "0" in der ersten Zeile....
LG
CS

Bild

Betrifft: das ist eine Matrixformel ...
von: der neopa C
Geschrieben am: 29.06.2015 11:52:43
Hallo,
.. die entsprechend einzugeben ist (siehe u.a. Hinweis von Hajo).
Doch offensichtlich hast Du noch nicht meinen Vorschlag getestet. Dies kommt auch ohne die spez. Eingabe aus.
Gruß Werner
.. , - ...

Bild

Betrifft: AW: das ist eine Matrixformel ...
von: CS
Geschrieben am: 29.06.2015 12:05:36
Hi,
habe auch deine Formel mit aggregat... probiert (was ist das? ;) ) - aber die klappt auch nicht.
Also für Spalte A klappt sie schon - nur die Anpassung an mein konkretes Beispiel läuft nicht.
Meine Spalte ist F und ich beginne in Zeile 2, entsprechend habe ich die Formel so angepasst:
=WENNFEHLER(INDEX(F:F;AGGREGAT(15;6;ZEILE(F$1:F$99)/(F$1:F$16<>0);ZEILE(A2)));"")
ud runterkopiert - dann bleiben die Leerzellen aber erhalten.
(Was bedeuten die 15 und die 6 zu Beginn des Aggregatbefehls?)
LG
CS

Bild

Betrifft: dann hast Du keine Leerzellen ...
von: der neopa C
Geschrieben am: 29.06.2015 12:12:42
Hallo CS,
... sondern offensichtlich Zellen die entweder (nicht sichtbare Zeichen) wie z.B Leerzeichen enthalten oder Formeln mit einem Ergebnis ="". Das ist dann keine Leerzelle und auch keine die einen 0-Wert haben.
In dem Fall sollte zum Ziel führen: =WENNFEHLER(INDEX(F:F;AGGREGAT(15;6;ZEILE(F$1:F$99)/(F$1:F$16<>"");ZEILE(A2)));"")
Anderenfalls lade den relevanten Teil Deiner Tabelle hier als Datei (nicht als Bild) mal hoch.
Die Argumente zur Funktion AGGREGAT() sind in in der Onlinehilfe aufgeführt.
Gruß Werner
.. , - ...

Bild

Betrifft: AW: dann hast Du keine Leerzellen ...
von: CS
Geschrieben am: 29.06.2015 12:16:54
Hi,
vielen Dank - funktioniert! Gut, dass du das gleich erkannt hast - ja die Zellen sind nicht leer, sondern enthalten Formeln.
LG
CS

Bild

Betrifft: AW: das ist eine Matrixformel ...
von: Herbert Grom
Geschrieben am: 29.06.2015 12:18:33
Das einzige, was an Deiner Formel anders ist, ist "Zeile(A2)" anstatt "A1". Aber nur, wenn es sich um die Formel in der ersten Zeile handelt. Ansonsten MUSS sie funktionieren!
Die Formeleingabe musst Du nicht wie normal mit einem einfachen Return oder Enter abschließen, sondern die Tasten STRG & ALT halten und erst dann Enter drücken. Dann werden die beiden geschweiften Klammern von Excel erzeugt und diese Formel wird als Array-Formel gekennzeichnet.
Servus

Bild

Betrifft: MATRIXformel verlangt gleiche Bereichsangabe ...
von: der neopa C
Geschrieben am: 28.06.2015 17:40:26
Hallo CS,
... Du hast in der Formel ZEILE($1:$916) angeben untersuchst jedoch nur A1:A16. Herbert hat das in seiner Formel bereits korrigiert. Doch effektiver als ZEILE($1:$16) ist es ZEILE(Z$1:Z$16)) zu schreiben.
Alternativ als nicht MATRIXformel mit AGGREGAT() spielt das keine Rolle. Dann z.B. so:

=WENNFEHLER(INDEX(A:A;AGGREGAT(15;6;ZEILE(A$1:A$99)/(A$1:A$16<>0);ZEILE(A1)));"")

Gruß Werner
.. , - ...

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Liste ohne Leerzeilen"