Urlaubsberechnung

Bild

Betrifft: Urlaubsberechnung
von: Mnemonic
Geschrieben am: 29.08.2015 15:42:51

Hallo zusammen,
ein Problem was mich gerade etwas in den Wahnsinn treibt (Urlaubstage) folgende Tabelle liegt zu Grunde:


B25 = Überschrift = Tag = Formel =DATUM(GeschäftsJahr;1;1)
C25 = Überschrift = Kommt 
D25 = Überschrift = Geht
E25 = Überschrift = Stunden = Formel =WENN($C25>0;$D25-$C25;"")
M25 = Überschrift = Pause
N25 = Überschrift = Gesamt = Formel =WENN($C25>0;($E25-$M25)*24;"")
Über die bedingte Formatierung färbe ich die Wochenenden sowie Feiertage der Tabelle ein, soweit so gut.
Beispieleintrag:
C25 = 08:00
D25 = 17:00
Ergebnis Stunden:
E25 = 09:00
Pause:
0:45
Gesamt-Stunden:
N25 = 8,25
Es werden 09:00 Stunden berechnet davon gehen nun 0:45 Minuten Pause ab bleiben Gesamt in Zelle N25 dann 8,25 Stunden,
Das Problem ist hauptsächlich die Berechnung des Urlaubstages zu automatisieren für die Zelle N25 = gesamt.
Da folgende Vorraussetzungen existieren:
Mo - Do = Pausenzeit = 0:45 Minuten (dies trage ich zur Zeit manuell ein in M25) = 8,25 Arbeitsstunden
Fr. = Pausenzeiten = 0:00 Minuten = 6:00 Arbeitsstunden
Wenn in C25 ein U für den Urlaub eingetragen wird, müsste ja vermutlich geprüft werden ob es sich um einen Freitag handelt, sollte dies der Fall sein müssten ja bei N25 6:00 Stunden dazu (0:00 + 6:00 Stunden) addiert werden.
Wenn es sich um einen Tag zwischen Montag bis Donnerstag handelt, dann sollten (0:00 + 8,25) Stunden addiert werden.
Ich verliere da völlig den Überblick die Formel in N25 diesbezüglich anzupassen.
Vielleicht kann mir da mal jemand helfen, vielen Dank für die Aufmerksamkeit.

Bild

Betrifft: AW: Urlaubsberechnung
von: Matthias L
Geschrieben am: 29.08.2015 16:00:25
Hallo
Zitat
Wenn in C25 ein U für den Urlaub eingetragen wird, müsste ja vermutlich geprüft werden ob es sich um einen Freitag handelt, sollte dies der Fall sein müssten ja bei N25 6:00 Stunden dazu (0:00 + 6:00 Stunden) addiert werden.
Wenn in C25 ein U steht bekommst Du den Fehler: #WERT!
Denn dort wird eine Uhrzeit für "Kommt" erwartet.

 BCDEMN
24TagKommtGehtStundenPauseGesamt
2501.01.2015U17:00#WERT!00:45#WERT!

Formeln der Tabelle
ZelleFormel
B25=DATUM(Geschäftsjahr;1;1)
E25=WENN($C25>0;$D25-$C25;"")
N25=WENN($C25>0;($E25-$M25)*24;"")


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4


Ansonsten benutze wie in der bedingten Formatierung die Formel um den Wochentag festzustellen.
Dies kannst Du dann nach Deinen Wünschen auswerten.
Gruß Matthias

Bild

Betrifft: AW: Urlaubsberechnung
von: Mnemonic
Geschrieben am: 29.08.2015 18:37:26
Hallo Matthias,
vielen Dank für Deine Antwort.
Mein Hauptsächliches Problem besteht eigentlich darin, eine Formel mit Mehrfachprüfungen zu erstellen.
Ich mache mal ein Beispiel:
In der Zeile E25 in der die Stunden (Kommt, Geht) zusammengerechnet werden, müsste die Prüfung meiner Meinung nach wie folgt aussehen (ich schreibe das mal in Worten, wie ich mir das vorgestellt habe)
Wenn in Zelle C25 anstelle von z.B. 08:00 ein “U“ steht, dann nächste Prüfung,
Wenn der Wochentag ein Montag,Dienstag,Mittwoch oder Donnerstag ist dann 9 Stunden ansonsten
Wenn es sich um einen Freitag handelt, dann 6 Stunden.
Ansonsten wenn in C25 kein “U“ dann berechne Geht(D25) - Kommt(C25) sonst leer ““
Ich denke zu wissen, was ich tun muss ich weiß leider nur nicht genau wie ich das ganze in einer Formel mit all den erwähnten Prüfungen unterbringen kann.
Viele Grüße

Bild

Betrifft: AW: prüfen auf "U" ...
von: ... neopa C
Geschrieben am: 30.08.2015 09:05:05
Hallo,,
... in E25 z.B. so:

=WENN(ANZAHL(C25:D25)=2;$D25-$C25;WENN(C25="U";(REST(B25;7)>1)*((REST(B25;7)<>6)/8+1/4);""))
Gruß Werner
.. , - ...

Bild

Betrifft: AW: prüfen auf "U" ...
von: Mnemonic
Geschrieben am: 30.08.2015 12:59:32
Halllo Werner,
vielen Dank funktioniert prima!
Vor allem sieht das ganze nach einer sehr cleveren Lösung aus, mein Gedanke war ein ganz anderer ich hatte versucht mit "Wenn" und "Wochentag" das ganze zusammenzubauen allerdings, hatte ich immer Probleme damit wo hört eine Formel auf und fängt die andere an (muss erst mal verstehen wie Excel das erwartet)
Viele Grüße

Bild

Betrifft: AW: zum "verstehen" ...
von: ... neopa C
Geschrieben am: 30.08.2015 17:02:00
Hallo,
... kann ich Dir u.a auch folgende Seite empfehlen: http://www.online-excel.de/
Gruß Werner
.. , - ...

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Listbox (VBA) ColumnHeads"