SUMMENPRODUKT anpassen

Bild

Betrifft: SUMMENPRODUKT anpassen
von: erichm
Geschrieben am: 24.10.2015 08:26:40

Hallo,
was ist denn an der Formel SUMMENPRODUKT falsch, dass beim Vergleich die "0" immer gezählt wird??
Es wird die Tabelle 2 mit der Tabelle 3 verglichen und gezählt wenn beim jeweiligen Datum die Zahlen übereinstimmen - siehe Tabelle1 = Ergebnis.
Tabelle2

 AB
301.01.20152
402.01.20153
503.01.20151
604.01.20150
705.01.20156
806.01.20154
907.01.20155
1008.01.20155


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
Tabelle3

 AB
301.01.20151
402.01.20152
503.01.20153
604.01.20154
705.01.20155
806.01.20150
907.01.20157
1008.01.20156


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
Tabelle1

 ABCDEFGHIJ
1Nummer 12345678
2 Datum01.01.201502.01.201503.01.201504.01.201505.01.201506.01.201507.01.201508.01.2015
3101.01.201501000000
4202.01.201500100000
5303.01.201510000000
6404.01.20151212121212131212
7505.01.201500000001
8606.01.201500010000
9707.01.201500001000
10808.01.201500001000

Formeln der Tabelle
ZelleFormel
C3=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$B3:$B3;Tabelle3!$B$3:$B$15*(Tabelle3!$A$3:$A100=C$2)))
D3=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$B3:$B3;Tabelle3!$B$3:$B$15*(Tabelle3!$A$3:$A100=D$2)))
E3=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$B3:$B3;Tabelle3!$B$3:$B$15*(Tabelle3!$A$3:$A100=E$2)))
F3=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$B3:$B3;Tabelle3!$B$3:$B$15*(Tabelle3!$A$3:$A100=F$2)))
G3=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$B3:$B3;Tabelle3!$B$3:$B$15*(Tabelle3!$A$3:$A100=G$2)))
H3=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$B3:$B3;Tabelle3!$B$3:$B$15*(Tabelle3!$A$3:$A100=H$2)))
I3=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$B3:$B3;Tabelle3!$B$3:$B$15*(Tabelle3!$A$3:$A100=I$2)))
J3=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$B3:$B3;Tabelle3!$B$3:$B$15*(Tabelle3!$A$3:$A100=J$2)))
C4=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$B4:$B4;Tabelle3!$B$3:$B$15*(Tabelle3!$A$3:$A101=C$2)))
D4=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$B4:$B4;Tabelle3!$B$3:$B$15*(Tabelle3!$A$3:$A101=D$2)))
E4=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$B4:$B4;Tabelle3!$B$3:$B$15*(Tabelle3!$A$3:$A101=E$2)))
F4=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$B4:$B4;Tabelle3!$B$3:$B$15*(Tabelle3!$A$3:$A101=F$2)))
G4=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$B4:$B4;Tabelle3!$B$3:$B$15*(Tabelle3!$A$3:$A101=G$2)))
H4=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$B4:$B4;Tabelle3!$B$3:$B$15*(Tabelle3!$A$3:$A101=H$2)))
I4=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$B4:$B4;Tabelle3!$B$3:$B$15*(Tabelle3!$A$3:$A101=I$2)))
J4=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$B4:$B4;Tabelle3!$B$3:$B$15*(Tabelle3!$A$3:$A101=J$2)))
C5=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$B5:$B5;Tabelle3!$B$3:$B$15*(Tabelle3!$A$3:$A102=C$2)))
D5=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$B5:$B5;Tabelle3!$B$3:$B$15*(Tabelle3!$A$3:$A102=D$2)))
E5=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$B5:$B5;Tabelle3!$B$3:$B$15*(Tabelle3!$A$3:$A102=E$2)))
F5=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$B5:$B5;Tabelle3!$B$3:$B$15*(Tabelle3!$A$3:$A102=F$2)))
G5=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$B5:$B5;Tabelle3!$B$3:$B$15*(Tabelle3!$A$3:$A102=G$2)))
H5=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$B5:$B5;Tabelle3!$B$3:$B$15*(Tabelle3!$A$3:$A102=H$2)))
I5=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$B5:$B5;Tabelle3!$B$3:$B$15*(Tabelle3!$A$3:$A102=I$2)))
J5=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$B5:$B5;Tabelle3!$B$3:$B$15*(Tabelle3!$A$3:$A102=J$2)))
C6=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$B6:$B6;Tabelle3!$B$3:$B$15*(Tabelle3!$A$3:$A103=C$2)))
D6=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$B6:$B6;Tabelle3!$B$3:$B$15*(Tabelle3!$A$3:$A103=D$2)))
E6=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$B6:$B6;Tabelle3!$B$3:$B$15*(Tabelle3!$A$3:$A103=E$2)))
F6=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$B6:$B6;Tabelle3!$B$3:$B$15*(Tabelle3!$A$3:$A103=F$2)))
G6=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$B6:$B6;Tabelle3!$B$3:$B$15*(Tabelle3!$A$3:$A103=G$2)))
H6=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$B6:$B6;Tabelle3!$B$3:$B$15*(Tabelle3!$A$3:$A103=H$2)))
I6=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$B6:$B6;Tabelle3!$B$3:$B$15*(Tabelle3!$A$3:$A103=I$2)))
J6=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$B6:$B6;Tabelle3!$B$3:$B$15*(Tabelle3!$A$3:$A103=J$2)))
C7=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$B7:$B7;Tabelle3!$B$3:$B$15*(Tabelle3!$A$3:$A104=C$2)))
D7=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$B7:$B7;Tabelle3!$B$3:$B$15*(Tabelle3!$A$3:$A104=D$2)))
E7=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$B7:$B7;Tabelle3!$B$3:$B$15*(Tabelle3!$A$3:$A104=E$2)))
F7=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$B7:$B7;Tabelle3!$B$3:$B$15*(Tabelle3!$A$3:$A104=F$2)))
G7=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$B7:$B7;Tabelle3!$B$3:$B$15*(Tabelle3!$A$3:$A104=G$2)))
H7=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$B7:$B7;Tabelle3!$B$3:$B$15*(Tabelle3!$A$3:$A104=H$2)))
I7=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$B7:$B7;Tabelle3!$B$3:$B$15*(Tabelle3!$A$3:$A104=I$2)))
J7=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$B7:$B7;Tabelle3!$B$3:$B$15*(Tabelle3!$A$3:$A104=J$2)))
C8=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$B8:$B8;Tabelle3!$B$3:$B$15*(Tabelle3!$A$3:$A105=C$2)))
D8=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$B8:$B8;Tabelle3!$B$3:$B$15*(Tabelle3!$A$3:$A105=D$2)))
E8=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$B8:$B8;Tabelle3!$B$3:$B$15*(Tabelle3!$A$3:$A105=E$2)))
F8=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$B8:$B8;Tabelle3!$B$3:$B$15*(Tabelle3!$A$3:$A105=F$2)))
G8=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$B8:$B8;Tabelle3!$B$3:$B$15*(Tabelle3!$A$3:$A105=G$2)))
H8=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$B8:$B8;Tabelle3!$B$3:$B$15*(Tabelle3!$A$3:$A105=H$2)))
I8=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$B8:$B8;Tabelle3!$B$3:$B$15*(Tabelle3!$A$3:$A105=I$2)))
J8=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$B8:$B8;Tabelle3!$B$3:$B$15*(Tabelle3!$A$3:$A105=J$2)))
C9=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$B9:$B9;Tabelle3!$B$3:$B$15*(Tabelle3!$A$3:$A106=C$2)))
D9=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$B9:$B9;Tabelle3!$B$3:$B$15*(Tabelle3!$A$3:$A106=D$2)))
E9=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$B9:$B9;Tabelle3!$B$3:$B$15*(Tabelle3!$A$3:$A106=E$2)))
F9=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$B9:$B9;Tabelle3!$B$3:$B$15*(Tabelle3!$A$3:$A106=F$2)))
G9=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$B9:$B9;Tabelle3!$B$3:$B$15*(Tabelle3!$A$3:$A106=G$2)))
H9=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$B9:$B9;Tabelle3!$B$3:$B$15*(Tabelle3!$A$3:$A106=H$2)))
I9=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$B9:$B9;Tabelle3!$B$3:$B$15*(Tabelle3!$A$3:$A106=I$2)))
J9=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$B9:$B9;Tabelle3!$B$3:$B$15*(Tabelle3!$A$3:$A106=J$2)))
C10=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$B10:$B10;Tabelle3!$B$3:$B$15*(Tabelle3!$A$3:$A107=C$2)))
D10=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$B10:$B10;Tabelle3!$B$3:$B$15*(Tabelle3!$A$3:$A107=D$2)))
E10=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$B10:$B10;Tabelle3!$B$3:$B$15*(Tabelle3!$A$3:$A107=E$2)))
F10=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$B10:$B10;Tabelle3!$B$3:$B$15*(Tabelle3!$A$3:$A107=F$2)))
G10=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$B10:$B10;Tabelle3!$B$3:$B$15*(Tabelle3!$A$3:$A107=G$2)))
H10=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$B10:$B10;Tabelle3!$B$3:$B$15*(Tabelle3!$A$3:$A107=H$2)))
I10=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$B10:$B10;Tabelle3!$B$3:$B$15*(Tabelle3!$A$3:$A107=I$2)))
J10=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$B10:$B10;Tabelle3!$B$3:$B$15*(Tabelle3!$A$3:$A107=J$2)))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
Warum erscheint in der Zeile 6 immer die 12 (bzw. die 13 wenn dort eine 1 stehen soll), während die anderen Ergebnisse alle stimmen!!??
Besten Dank für eine Hilfe.
mfg

Bild

Betrifft: AW: SUMMENPRODUKT anpassen / NACHTRAG
von: erichm
Geschrieben am: 24.10.2015 09:59:31
zur ergänzenden Info; die Formel ist von dieser Formel aus dem Forum hier abgeleitet:
Tabelle1

 ABCDEFGHIJ
1Nummer 12345678
2 Datum01.01.201502.01.201503.01.201504.01.201505.01.201506.01.201507.01.201508.01.2015
3101.01.201501000000
4202.01.201524200000
5303.01.201510000000
6404.01.201510001110
7505.01.201510001002
8606.01.201510011011
9707.01.201510011001
10808.01.201510111001

Formeln der Tabelle
ZelleFormel
C3=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A3:$I3;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A100=C$2)))
D3=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A3:$I3;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A100=D$2)))
E3=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A3:$I3;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A100=E$2)))
F3=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A3:$I3;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A100=F$2)))
G3=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A3:$I3;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A100=G$2)))
H3=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A3:$I3;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A100=H$2)))
I3=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A3:$I3;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A100=I$2)))
J3=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A3:$I3;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A100=J$2)))
C4=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A4:$I4;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A101=C$2)))
D4=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A4:$I4;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A101=D$2)))
E4=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A4:$I4;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A101=E$2)))
F4=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A4:$I4;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A101=F$2)))
G4=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A4:$I4;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A101=G$2)))
H4=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A4:$I4;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A101=H$2)))
I4=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A4:$I4;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A101=I$2)))
J4=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A4:$I4;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A101=J$2)))
C5=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A5:$I5;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A102=C$2)))
D5=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A5:$I5;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A102=D$2)))
E5=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A5:$I5;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A102=E$2)))
F5=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A5:$I5;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A102=F$2)))
G5=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A5:$I5;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A102=G$2)))
H5=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A5:$I5;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A102=H$2)))
I5=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A5:$I5;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A102=I$2)))
J5=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A5:$I5;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A102=J$2)))
C6=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A6:$I6;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A103=C$2)))
D6=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A6:$I6;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A103=D$2)))
E6=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A6:$I6;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A103=E$2)))
F6=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A6:$I6;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A103=F$2)))
G6=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A6:$I6;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A103=G$2)))
H6=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A6:$I6;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A103=H$2)))
I6=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A6:$I6;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A103=I$2)))
J6=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A6:$I6;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A103=J$2)))
C7=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A7:$I7;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A104=C$2)))
D7=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A7:$I7;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A104=D$2)))
E7=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A7:$I7;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A104=E$2)))
F7=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A7:$I7;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A104=F$2)))
G7=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A7:$I7;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A104=G$2)))
H7=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A7:$I7;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A104=H$2)))
I7=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A7:$I7;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A104=I$2)))
J7=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A7:$I7;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A104=J$2)))
C8=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A8:$I8;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A105=C$2)))
D8=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A8:$I8;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A105=D$2)))
E8=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A8:$I8;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A105=E$2)))
F8=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A8:$I8;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A105=F$2)))
G8=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A8:$I8;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A105=G$2)))
H8=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A8:$I8;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A105=H$2)))
I8=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A8:$I8;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A105=I$2)))
J8=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A8:$I8;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A105=J$2)))
C9=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A9:$I9;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A106=C$2)))
D9=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A9:$I9;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A106=D$2)))
E9=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A9:$I9;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A106=E$2)))
F9=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A9:$I9;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A106=F$2)))
G9=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A9:$I9;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A106=G$2)))
H9=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A9:$I9;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A106=H$2)))
I9=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A9:$I9;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A106=I$2)))
J9=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A9:$I9;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A106=J$2)))
C10=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A10:$I10;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A107=C$2)))
D10=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A10:$I10;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A107=D$2)))
E10=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A10:$I10;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A107=E$2)))
F10=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A10:$I10;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A107=F$2)))
G10=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A10:$I10;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A107=G$2)))
H10=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A10:$I10;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A107=H$2)))
I10=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A10:$I10;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A107=I$2)))
J10=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A10:$I10;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A107=J$2)))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
Dort sind die Spaltenbereiche in den Tabellen 2 und 3 jeweils mehr als eine Spalte.
Da ist es aber genauso, wenn in Tabelle 2 eine 0 enthalten ist, dass dann mehrfach gezählt wird:
Tabelle2

 ABCDEFGHI
301.01.20152192845574389870175945
402.01.20153909197507527200930402
503.01.2015198142372794795041863
604.01.2015061175303590918234191
705.01.20156202187758609576565
806.01.201543905760950525383413
907.01.201553329875358933480773
1008.01.201553527660565412891875


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
Tabelle1

 ABCDEFGHIJ
1Nummer 12345678
2 Datum01.01.201502.01.201503.01.201504.01.201505.01.201506.01.201507.01.201508.01.2015
3101.01.201501000000
4202.01.201524200000
5303.01.201510000000
6404.01.2015210210210210212212210210
7505.01.201510001002
8606.01.201510011011
9707.01.201510011001
10808.01.201510111001

Formeln der Tabelle
ZelleFormel
C3=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A3:$I3;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A100=C$2)))
D3=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A3:$I3;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A100=D$2)))
E3=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A3:$I3;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A100=E$2)))
F3=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A3:$I3;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A100=F$2)))
G3=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A3:$I3;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A100=G$2)))
H3=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A3:$I3;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A100=H$2)))
I3=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A3:$I3;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A100=I$2)))
J3=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A3:$I3;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A100=J$2)))
C4=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A4:$I4;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A101=C$2)))
D4=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A4:$I4;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A101=D$2)))
E4=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A4:$I4;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A101=E$2)))
F4=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A4:$I4;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A101=F$2)))
G4=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A4:$I4;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A101=G$2)))
H4=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A4:$I4;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A101=H$2)))
I4=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A4:$I4;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A101=I$2)))
J4=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A4:$I4;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A101=J$2)))
C5=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A5:$I5;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A102=C$2)))
D5=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A5:$I5;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A102=D$2)))
E5=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A5:$I5;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A102=E$2)))
F5=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A5:$I5;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A102=F$2)))
G5=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A5:$I5;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A102=G$2)))
H5=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A5:$I5;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A102=H$2)))
I5=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A5:$I5;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A102=I$2)))
J5=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A5:$I5;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A102=J$2)))
C6=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A6:$I6;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A103=C$2)))
D6=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A6:$I6;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A103=D$2)))
E6=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A6:$I6;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A103=E$2)))
F6=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A6:$I6;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A103=F$2)))
G6=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A6:$I6;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A103=G$2)))
H6=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A6:$I6;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A103=H$2)))
I6=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A6:$I6;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A103=I$2)))
J6=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A6:$I6;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A103=J$2)))
C7=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A7:$I7;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A104=C$2)))
D7=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A7:$I7;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A104=D$2)))
E7=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A7:$I7;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A104=E$2)))
F7=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A7:$I7;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A104=F$2)))
G7=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A7:$I7;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A104=G$2)))
H7=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A7:$I7;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A104=H$2)))
I7=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A7:$I7;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A104=I$2)))
J7=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A7:$I7;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A104=J$2)))
C8=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A8:$I8;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A105=C$2)))
D8=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A8:$I8;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A105=D$2)))
E8=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A8:$I8;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A105=E$2)))
F8=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A8:$I8;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A105=F$2)))
G8=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A8:$I8;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A105=G$2)))
H8=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A8:$I8;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A105=H$2)))
I8=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A8:$I8;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A105=I$2)))
J8=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A8:$I8;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A105=J$2)))
C9=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A9:$I9;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A106=C$2)))
D9=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A9:$I9;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A106=D$2)))
E9=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A9:$I9;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A106=E$2)))
F9=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A9:$I9;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A106=F$2)))
G9=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A9:$I9;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A106=G$2)))
H9=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A9:$I9;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A106=H$2)))
I9=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A9:$I9;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A106=I$2)))
J9=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A9:$I9;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A106=J$2)))
C10=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A10:$I10;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A107=C$2)))
D10=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A10:$I10;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A107=D$2)))
E10=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A10:$I10;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A107=E$2)))
F10=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A10:$I10;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A107=F$2)))
G10=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A10:$I10;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A107=G$2)))
H10=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A10:$I10;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A107=H$2)))
I10=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A10:$I10;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A107=I$2)))
J10=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$A10:$I10;Tabelle3!$B$3:$AE$10*(Tabelle3!$A$3:$A107=J$2)))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
Jetzt habe ich schon alles mögliche probiert, aber bei einer 0 in Tabelle2 funktioniert die Formel nicht. In der Praxis ist es aber so, dass eine 0 immer wieder mal vorkommen kann.
Besten Dank für eine Idee.
mfg

Bild

Betrifft: AW: diie "Crux" der Leerzellen bei Zellbezug ...
von: ... neopa C
Geschrieben am: 25.10.2015 11:22:12
Hallo Erich,
... wenn Du mit einem normalen Zellbezug auf leere Zellen zugreifst, ist das Standardergebnis eine 0 und nicht leer oder ="". Letzteres muss man erst erzeugen oder die Leerzellen z.B. mit ISTLEER() prüfen und das dann in die Auswertung einbeziehen.
Ich hab mich für Ersteres entschieden und damit die Formel angepasst. Hier hab ich auch gleich einen Widerspruch in der von Dir aufgezeigten Formel eliminiert. Zum einen steht in Deiner Formel mit ... Tabelle3!$B$3:$B$15 ... ein absolut fixierter Bereich und zum andern hältst Du das Ende des Bereiches mit ...(Tabelle3!$A$3:$A100=C... offen.
Auch bedarf es in Deinem Beispiel nicht ...Tabelle2!$B5:$B5... sondern da reicht einfach: ...Tabelle2!$B3 ...
Nachfolgende Formel kannst Du sowohl nach unten wie ober und rechts ziehend kopieren.

 ABCH
1Nummer 16
2 Datum01.01.201506.01.2015
5303.01.201510
6404.01.201501

Formeln der Tabelle
ZelleFormel
C5=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!$B5;Tabelle3!$B$3:$B101*(Tabelle3!$A$3:$A101=C$2))-(Tabelle2!$B5=0)*((Tabelle3!$B$3:$B101<>0)+(Tabelle3!$B$3:$B101&""="")))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß Werner
.. , - ...

Bild

Betrifft: AW: diie "Crux" der Leerzellen bei Zellbezug ...
von: erichm
Geschrieben am: 25.10.2015 14:31:00
Hallo Werner,
das ist ja SUPER!
Das Problem hatte ich noch nie und auf die Lösung wäre auch nie gekommen. Hatte schon alle möglichen google- und youtube-Recherchen angestellt.
Allerbesten DANK!
mfg

Bild

Betrifft: AW: gern getan owT
von: ... neopa C
Geschrieben am: 25.10.2015 15:16:40
Gruß Werner
.. , - ...

 Bild

Beiträge aus den Excel-Beispielen zum Thema "SUMMENPRODUKT anpassen"