Code erst ab 3. Zeile?

Bild

Betrifft: Code erst ab 3. Zeile?
von: Peter
Geschrieben am: 27.11.2015 08:35:01

Hallo zusammen
Ich habe diesen Code vom Internet, dieser erstellt eine Teilstring von Links bis zum ersten Leerzeichen. Jedoch möchte ich erst ab 3. Zeile (ab A3) beginnen und dann ab B3 einfügen. Und könnte man noch zuvor Zeile B (auch ab B3) löschen.
Wie müsste ich den Code anpassen?

Sub TeilenLinks() ' In Spalte A die Adressen reinkopieren
Dim x As Integer, tmp_pos As Integer, string_a As String
x = 1
Do Until Range("A" & x).Value = ""
tmp_pos = InStr(1, (Range("A" & x).Value), " ")
string_a = Mid(Range("A" & x).Value, 1, tmp_pos - 1)
' Spalte B der erste Teil
Range("B" & x).Value = string_a
x = x + 1
Loop
End Sub
Bin dankbar für jede Hilfe
Viele Grüsse,
Peter

Bild

Betrifft: vielleicht mit x = 3 ... owT
von: Matthias L
Geschrieben am: 27.11.2015 08:40:44


Bild

Betrifft: Fehlerbehandlung notwendig!
von: Matthias L
Geschrieben am: 27.11.2015 08:59:00
Hallo
Desweiteren bricht der Code ab wenn es einen String in Spalte(A) gibt der kein! Leerzeichen enthält.
Deshalb On Error Resume Next zu Beginn oder eben einfach auch per Formel
Tabelle1

 AC
2StringFormel
3OhneLeerzeichen 
4Das ist ein TextDas
5Auch hier steht etwasAuch
6Immerhin steht hier auch wasImmerhin

Formeln der Tabelle
ZelleFormel
C3=WENNFEHLER(LINKS(A3;FINDEN(" ";A3)-1);"")
C4=WENNFEHLER(LINKS(A4;FINDEN(" ";A4)-1);"")
C5=WENNFEHLER(LINKS(A5;FINDEN(" ";A5)-1);"")
C6=WENNFEHLER(LINKS(A6;FINDEN(" ";A6)-1);"")


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß Matthias

Bild

Betrifft: AW: Fehlerbehandlung notwendig!
von: Peter
Geschrieben am: 30.11.2015 14:05:18
Hallo Matthis
Danke für Deine wertvolle Info, das ist gut zu wissen.
Viele Grüsse,
Peter

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Code erst ab 3. Zeile?"