Microsoft Excel

Herbers Excel/VBA-Archiv

Informationen und Beispiele zum Thema RefEdit
BildScreenshot zu RefEdit RefEdit-Seite mit Beispielarbeitsmappe aufrufen

Zellen in Bereich prüfen


Betrifft: Zellen in Bereich prüfen von: Peter
Geschrieben am: 18.07.2018 11:13:42

Hallo ihr Excelspezialisten,

ich habe wieder einmal ein Problem. Bitte helft mir dieses zu lösen:

in einer Spalte BI2:BI5 habe ich Werte. Diese Werte müssten alle gleich sein.
Wenn nun ein Wert falsch geschrieben wurde, soll dieser den richtigen Wert erhalten.

Beispiel:
Fehlerhaft:
aWert_Test_
Wert_Testb_
Wert_Test_
Wert_Test_

berichtigt:

Wert_Test_
Wert_Test_
Wert_Test_
Wert_Test_

Wie kann ich dies bitte lösen - entweder per Formel oder per Makro

Besten Dank für eure Hilfe.

Gruss
Peter

  

Betrifft: AW: Zellen in Bereich prüfen von: SF
Geschrieben am: 18.07.2018 11:18:10

Hola,

woher weiß man denn, welches der richtige Wert ist?

Gruß,
steve1da


  

Betrifft: AW: Zellen in Bereich prüfen von: Peter
Geschrieben am: 18.07.2018 11:24:01

Hallo Steve,

ja das ist eine berechtigte Frage.

Es handelt sich dabei um Dateinamen eingegeben von einem User. Diese Namen sollen alle gleich sein.
Er gibt diese Namen selbst vor. Ich dachte mir - da normalerweise ein Name nur versehentlich falsch
geschrieben wird, dass der Name richtig sein soll, welcher am häufigsten vorhanden ist. Sind alle Namen falsch geschrieben ist der verständlichste Name! für alle zu benutzen.

Ich weiss leider nicht, wie ich dies anders formulieren kann.

Ich hoffe Du kannst damit etwas anfangen.

Besten Dank

Gruss Peter


  

Betrifft: AW: Zellen in Bereich prüfen von: SF
Geschrieben am: 18.07.2018 11:30:43

Hola,

http://www.excelformeln.de/formeln.html?welcher=66

Hier wird beschrieben, wie man den häufigsten Wert einer Liste ermittelt.
Mit einer Wenn-Formel kannst du dann prüfen, ob die Einträge diesem Wert entsprechen.

Gruß,
steve1da


  

Betrifft: AW: Zellen in Bereich prüfen - gelöst von: Peter
Geschrieben am: 18.07.2018 11:55:17

Hallo Steve,

besten Dank für die schnelle Hilfe. Das funktioniert einwandfrei.

Wünsche Dir noch einen schönen Tag.

Gruss Peter


  

Betrifft: AW: Zellen in Bereich prüfen von: UweD
Geschrieben am: 18.07.2018 11:23:59

Hallo


so???

Tabelle1

 ABCDEF
1Fehlerhaft: berichtigt Normal:Wert_Test
2aWert_Test_ Wert_Test_   
3Wert_Testb_ Wert_Test_   
4Wert_Test_ Wert_Test_   
5Wert_Test_ Wert_Test_   
6Wert_Was anderes_ Wert_Was anderes_   
7Wert_Test_ Wert_Test_   

verwendete Formeln
Zelle Formel Bereich N/A
C2:C7=WENN(ISTZAHL(FINDEN($F$1;A2));$F$1&"_";A2)  
http://excel-inn.de/dateien/vba_beispiele/tabellenanzeige_in_html_addin.zip
http://Hajo-Excel.de/tools.htm
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 25.14 einschl. 64 Bit




LG UweD


  

Betrifft: AW: Zellen in Bereich prüfen von: Peter
Geschrieben am: 18.07.2018 11:33:15

Hallo Uwe,

besten Dank für Deine Hilfe.
Das ganze ist, sofern der richtige Begriff bekannt ist, völlig richtig.

Da aber das Programm den richtigen Wert von vornherein nicht kennt, wird es problematisch.

Der richtige Begriff ist der, welcher am häufigsten gleich geschrieben vorkommt.

Gruss Peter


Beiträge aus dem Excel-Forum zum Thema "Zellen in Bereich prüfen"