Herbers Excel-Forum - das Archiv

Mehrere Argumente

Bild

Betrifft: Mehrere Argumente
von: Klaus
Geschrieben am: 24.09.2003 18:38:18
Hallo Profis!

Ich hab da eine Mappe in der 40 Leute stehen. Diese 40 Leute haben 3 unterschiedliche Qualifikationen. Sagen wir mal Qualifikation A, B und C. Ich verteile über Excel die Personen auf Fahrzeuge wobei immer 2 Personen zusammen sind. Nun gibt es Fahrzeuge da muss immer mindestens einer mit der Qualifikation A drauf sein. Die 2. Person kann a, B oder C sein. Im anderen Fall muss mindestens einer die Qualifikation A oder B erfüllen. Die 2. Person kann A, B oder C sein.
In einem Monatsdienstplan sind nun Farzeuge zu besetzen. Ich möchte jetzt, je nach Fahrzeug, von Excel errechnet haben, ob ich in jedem der Fahrzeuge das richtige Personal habe und ob alle Fahrzeuge auch besetzt sind. Ich habe täglich 10 Fahrzeuge zu besetzen.
Ich hoffe ich habe es einigermassen gut erklärt.

Nun meine Frage:
Wie kann ich dieses Problem (möglichst ohne VBA)lösen???

Ich sage schon mal Vielen Dank im Voraus!!!!

Klaus

Bild

Betrifft: AW: Mehrere Argumente
von: andre
Geschrieben am: 24.09.2003 19:16:03
hallo klaus,
vom ansatz her über hilfsspalten und sverweis. wenn du z.b. deine namen alle links hast, und oben die fahrzeuge dann in etwa so:
voraussetzung:
namensdaten sortiert! können auch wo anders / in anderer tabelle stehen.
die quali-daten in den hilfsspalten werden mit formel ermittelt.
~tablea~
Name Quali auto1 quali auto2 quali
franz 3 willi x 1 x 1
gerda 2 gerda x 2
kurt 1 kurt
willi 1 franz x 3
quali1 1 1
quali2 1 0
quali3 0 1
~tablez~

Formel1 (in g2):=WENN(F2="x";SVERWEIS($C2;$A$2:$B$5;2);"")
Formel2 (in g6):=ZÄHLENWENN(G$2:G$5;"1")

die formeln in die anderen zellen kopieren und 1/2/3 anpassen.
es müsste auch ohne hilfsspalten gehen, dann mit summenprodukt oder summewenn ...

gruss andre
 Bild
Excel-Beispiele zum Thema " Mehrere Argumente"
Suche über mehrere Tabellen Mehrere Schaltflächen für ein Makro
Suchbegriff über mehrere Tabellenblätter suchen. Benutzerdefinierte SVERWEIS-Funktion über mehrere Bereiche
Druck aus mehreren Tabellenblättern auf eine Druckseite AutoFilter über mehrere Arbeitsblätter setzen
Daten von mehreren Blättern auf ein Druckblatt Prozentuale Erhöhung über mehrere Arbeitsblätter hinweg
Werte in mehreren Spalten sortieren Textreihe auf mehrere Spalten mit fester Seitenlänge verteilen