Herbers Excel-Forum - das Archiv

sverweis?

    Bild

    Betrifft: sverweis?
    von: Michael
    Geschrieben am: 01.10.2003 14:46:54
    Hallo zusammen
    habe folgendes Problem:
    In Tabelle "Daten" Spalte A7 erfolgt eine Eingabe z.B. D38KD-
    in gleicher Tabelle K7 steht die Formel: =SVERWEIS(A7,Supplier!B1:F58,4).
    In Tabelle "Supplier" stehen folgende Daten:
    Spalte A - DE durchgehend von 1 - 58
    Spalte B - die jeweiligen Supplier z.B. D0REE, A426C und D38KD
    Spalte C - PLZ
    Spalte D - 6Q
    Spalte E - km Werte wie z.b 281 - nur Zahlen
    Spalte F - durchgehend N
    Problem: wenn Eingabe eines Suppliers in Tabelle A, soll in Tabelle B der
    entsprechende Wert (Supplier)gesucht werden und die km-Angabe in Tabelle A
    Feld K7 geschrieben werden.
    Wie geht´s?

    Bild

    Betrifft: AW: sverweis?
    von: Stefan
    Geschrieben am: 01.10.2003 14:59:07
    Hi Michael,

    im Prinzip ist die Formel Richtig. Dh. die Formel müsste funktionieren.
    Vielleicht versuchst du es mal so:
    =SVERWEIS(A7;Supplier!B1:E58;4;FALSCH)

    noch besser ist (wenn z.B. die Eingabe falsch ist oder kein Wert gefunden ist, die Fehlermeldung individuell zu gestalten.
    Dazu diese Formel verwenden:
    =wenn(istnv(=SVERWEIS(A7;supplier!B1:E12;4;FALSCH));"NO DATA";=SVERWEIS(A7;supplier!B1:E12;4;FALSCH))

    NO DATA kannst du ja noch anpassen

    gruß

    stefan
    Bild

    Betrifft: AW: sverweis?
    von: Michael
    Geschrieben am: 01.10.2003 15:48:52
    Vielen Dank Stefan

    klappt nicht ganz - im Feld steht "FALSCH"

    ich habe ja schon einiges gelesen im Forum-
    ich nehme an es liegt daran daß es sich um Buchstaben
    und Zahlen handelt- kann das sein, daß deshalb nicht gefunden wird?
    Bild

    Betrifft: AW: sverweis?
    von: Armin B.
    Geschrieben am: 01.10.2003 16:03:30
    Hallo Michael

    da deine km Werte Zahlen sind könntest du es auch mit
    der "SUMMEWENN" Fuktion lösen
    Bsp. für Zelle K7: =SUMMEWENN(Supplier!$B1:$B34;A7;Supplier!$E$1:$E$31)

    Gruß Armin
    Bild

    Betrifft: AW: sverweis?
    von: Michael
    Geschrieben am: 02.10.2003 10:20:49
    Hallo Arnim

    so geht´s - vielen Dank für Deine Hilfe-

    Das andere Problem würde mich trotzdem interessieren
    wenn Zahlen und Buchstaben als Suchkriterium gelten, scheint
    Excel wohl Probleme zu haben-
    gibt es da eine generelle Lösung?!
    Bild

    Betrifft: AW: sverweis?
    von: Armin B.
    Geschrieben am: 02.10.2003 16:51:49
    Hallo Michael

    auch wenn ich die Formel, "=SVERWEIS(A7;Supplier!B1:E58;4;FALSCH)"
    die Stefan in seiner Antwort schreibt benutze, bekomme ich die km angezeigt.

    Also auch dann wenn Buchstaben und Zahlen gemischt "A426C" als Suchkriterium gelten.
    Bei mir in Excel funktionierts zumindest.

    Gruß Armin
     Bild
    Excel-Beispiele zum Thema " sverweis?"
    SVERWEIS auf geschlossene Arbeitsmappe aus Makro aufrufen Benutzerdefinierte SVERWEIS-Funktion über mehrere Bereiche
    Arbeitszeittabelle und SVERWEIS-Formel Zugriff über SVERWEIS() auf eine Artikelliste
    SVERWEIS-Formel über mehrere Fundstellen SVERWEIS-, WVERWEIS- und Matrixformel-Beispiele
    SVERWEIS, WVERWEIS, INDEX, VERGLEICH und Zielwertsuche Zweidimensionale Matrix mit der SVERWEIS-Funktion durchsuchen
    Hyperlinks zu SVERWEIS-Bezugstabellen anlegen SVERWEIS als Ereignisprozedur