doppelte Einträge in Spalte verhindern

Bild

Betrifft: doppelte Einträge in Spalte verhindern
von: Markus
Geschrieben am: 12.11.2003 17:41:01

ich habe eine excelliste in der ich in einer spalte Namen eingebe die eindeutig sein müssen:

xxxname1
xxxname2
xxxname3

die Eingabelänge ist über Gültigkeit definiert (max 8 Zeichen)

Wie kann ich verhindern dass Namen doppelt eingegeben werden?
Ok wäre popup fenster oder so...
Gibt es innerhalb Excel eine Möglichkeit oder über ein Makro?

Für Hilfe Danke im voraus,

Gruß
Markus

Bild


Betrifft: AW: doppelte Einträge in Spalte verhindern
von: Hajo_Zi
Geschrieben am: 12.11.2003 17:51:56

Hallo Markus

Doppelte Einträge
Annahme: Deine Werte stehen in A1 bis Axx
A2 anwählen, Format, Bedingte Formatierung (bei bedingter Formatierung soll es eine Grenze von 2050 Zeilen geben, mal selber Testen)
• „Formel ist“ auswählen NICHT „Zellwert ist“
Bei der Formel eingeben =ZÄHLENWENN(A$1:A1;A2)>=1
Bei Format dann z.B. Musterfarbe rot auswählen mit OK beenden.
Die Formatierung auf Die Zellen A3 bis Axx kopieren. Fertig
Dann werden Doppelt farblich gekennzeichnet
oder
kann man auch die Doppeleingabe selber verhindern:
z.B. unter Daten, Gültigkeit, benutzerdefiniert
Formel
=ZÄHLENWENN(A:A;A1)=1
nach unten kopieren.
Von Ulrich Schneider


Bitte keine Mail, Probleme sollten im Forum gelöst werden.

Microsoft MVP für Excel

Das Forum lebt auch von den Rückmeldungen.
Betriebssystem XP Pro und Excel Version XP Pro




Bild


Betrifft: AW: doppelte Einträge in Spalte verhindern
von: ChrisL
Geschrieben am: 12.11.2003 18:01:53

Hi Markus

Ähnlicher Ansatz wie von Hajo...

=IF(OR(COUNTIF(A:A,A1)>1,LEN(A1)>8),FALSE,TRUE)
=WENN(ODER(ZÄHLENWENN(A:A;A1)>1;LÄNGE(A1)>8);FALSCH;WAHR)

Gruss
Chris


Bild

Beiträge aus den Excel-Beispielen zum Thema " doppelte Einträge in Spalte verhindern"