Microsoft Excel

Herbers Excel/VBA-Archiv

Anzahl der ganzen Werte ermitteln

Betrifft: Anzahl der ganzen Werte ermitteln von: Anne
Geschrieben am: 07.09.2004 19:18:08

Liebe Excel-Fans,

wer hat eine Idee, mit welcher Funktion man aus Hunderten von Werten, z.B.
0,5 - 1,2 - 2 - 2,5 - 14 - 18 - 19,02 - 21 - 27
nur die Anzahl der ganzen Werte ermitteln lassen kann. (Hier also 5)
Danke im voraus für die Mühe.
Anne

  


Betrifft: AW: Anzahl der ganzen Werte ermitteln von: Frank
Geschrieben am: 07.09.2004 19:21:30

Hi
eine Möglichkeit:
=SUMMENPRODUKT(--(KÜRZEN(A1:A100)=A1:A100))

Frank


  


Betrifft: AW: Anzahl der ganzen Werte ermitteln von: FP
Geschrieben am: 07.09.2004 19:26:30

Hi grosser Meister Frank,

ein paar Fragen hätte ich zu Deiner Formel ;-)

a) was ist mit leeren Zellen
b) ist Null eine Ganzzahl ?

Tabelle1
 AB
10,198
214
32 
43 
51,1 
60 
Formeln der Tabelle
B1 : =SUMMENPRODUKT(--(KÜRZEN(A1:A100)=A1:A100))
B2 : =SUMMENPRODUKT((A1:A100<>"")*(REST(A1:A100;1)=0))
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  



Servus aus dem Salzkammergut
Franz


  


Betrifft: AW: Anzahl der ganzen Werte ermitteln von: Anne
Geschrieben am: 07.09.2004 19:38:26

Hallo Franz,
Deine Variante klappt supergut - danke sehr!
Die Null wurde auch mitgezählt. Mir wäre es aber lieber,
wenn die Null rausgelassen würde. Wie macht man das?
Gruss
Anne


  


Betrifft: AW: Anzahl der ganzen Werte ermitteln von: FP
Geschrieben am: 07.09.2004 19:49:28

Hi Anne,

ersetze <>"" durch <>0

Tabelle1
 AB
10,198
213
32 
43 
51,1 
60 
Formeln der Tabelle
B1 : =SUMMENPRODUKT(--(KÜRZEN(A1:A100)=A1:A100))
B2 : =SUMMENPRODUKT((A1:A100<>0)*(REST(A1:A100;1)=0))
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  


Servus aus dem Salzkammergut
Franz


  


Betrifft: AW: Anzahl der ganzen Werte ermitteln von: Anne
Geschrieben am: 07.09.2004 20:05:55

Hallo Franz,
superschnell und supergut. Thanks very much
Herzliche Grüße ins schöne Salzkammergut.
Anne


  


Betrifft: AW: Anzahl der ganzen Werte ermitteln von: Frank
Geschrieben am: 07.09.2004 20:14:30

Hi Franz
Über 0 ann man trefflich streiten. Mal als alternative:
=SUMMENPRODUKT(--(KÜRZEN(A1:A100)=A1:A100);--(N(A1:A100)<>0))

Frank


 

Beiträge aus den Excel-Beispielen zum Thema "Anzahl der ganzen Werte ermitteln"