Microsoft Excel

Herbers Excel/VBA-Archiv

Kein Wert

Betrifft: Kein Wert von: Payne
Geschrieben am: 20.09.2004 15:32:06

Hallo,
ich habe folgende SUMMEWENN Formel:

=SUMME(WENN(('Tabelle'!$H$8:$I$258="R")*('Tabelle'!$A$8:$A$258='Kosten'!$A$22);Tabelle'!$K$8:$L$258))

Diese Formel steht auf dem Datenblatt 'Kosten'. Die Zelle 'Kosten'!$A$22 stellt eine leere Zelle dar, in die ein Datum eingefügt werden soll. Auf dem Datenblatt 'Tabelle' habe ich in der ersten Reihe das jeweilige Datum stehen.
Ich will nun, dass wenn ich in die Zelle 'Kosten'!$A$22 ein Datum eingebe, mir die Summe der Werte dieses Datums des Datenblattes 'Tabelle' ausgeben wird.
Allerdings kann ich eingeben, was ich will, es erscheint immer 0. Es sei denn, dass ich das Datum vom Datenblatt 'Tabelle' kopiere und in die Zelle 'Kosten'!$A$22 einfüge.
Wie schaffe ich es nur mit der einfachen Eingabe eines Datums die Summe zu erhalten?

  


Betrifft: AW: Kein Wert von: Dieter.K
Geschrieben am: 20.09.2004 15:36:04

Hallo Payne,

kannst Du mal ein Beispiel hochladen?

Gruß
Dieter.K


  


Betrifft: AW: Kein Wert von: Dieter Maj
Geschrieben am: 20.09.2004 16:04:20

Hallo Payne
gib die Formel als ARRAY-Formel ein , d.h.
Formel nochmals aktivieren:
Cursor drauf und F2 drücken
dann
abschliessen mit Strg,Umschalt,Enter
Gruß Dieter