Indirekte Adressierung in einer Summe

Bild

Betrifft: Indirekte Adressierung in einer Summe von: heriL
Geschrieben am: 04.02.2005 22:04:24

Hallo,
hat jemand eine Idee, wie ich mein folgendes Problem lösen kann ?

Tabelle1:
Felder C1 - L1:

Tabelle2:
Feld A1: eine Zahl von 1-10
Feld B1: Summe(Tabelle1!C1:?)

die Summe in Feld B1 soll soviele Summanden, wie in A1 genannt enthalten
also: wenn A1=1 dann B1 = Summe(Tabelle1!C1:C1)
wenn A1=2 dann B1 = Summe(Tabelle1!C1:D1)
wenn A1=4 dann B1 = Summe(Tabelle1!C1:F1)
usw.

danke, heriL

Bild


Betrifft: AW: Indirekte Adressierung in einer Summe von: Hübi
Geschrieben am: 04.02.2005 22:13:52

Hi Heri,

versuche das einmal
Tabelle2
 ABCDEFG
14 12345
210      
Formeln der Tabelle
A2 : =SUMME(INDIREKT("C1:"&ADRESSE(1;A1+2)))
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  



Gruß Hübi


Bild


Betrifft: AW: Indirekte Adressierung in einer Summe von: heriL
Geschrieben am: 05.02.2005 18:27:36

Hallo Hübi,

danke für die Formel, funktioniert aber leider nur innerhalb einer Tabelle und ich habe es nicht geschafft einen Tabellennamen fehlerfrei unterzubringen. (Die Daten, die ich aufaddieren will, liegen in derselben Datei aber in einer anderen Tabelle.)
Ich habe jetzt zwar eine Lösung gefunden mit "Summewenn" und 2 Hilfszeilen, aber wenn du noch weißt, wie einen Tabellennamen unterbringen kann wäre deine Lösung wesentlich eleganter.

Gruß
Heri


Bild


Betrifft: AW: Indirekte Adressierung in einer Summe von: Hübi
Geschrieben am: 05.02.2005 21:52:53

Hi Heri,

dann nehme diese Formel
A2: =SUMME(INDIREKT("Tabellenname!C1:"&ADRESSE(1;A1+2)))

Tabellenname muss der Name deiner Tabelle sein

Gruß Hübi


 Bild

Beiträge aus den Excel-Beispielen zum Thema "Kontextmenü bei Objekt Picture erweitern"