Tabelle Updaten mit SVerweis?

Bild

Betrifft: Tabelle Updaten mit SVerweis? von: Ralph T.
Geschrieben am: 12.02.2005 15:52:16

Hallo Excelfreunde,
ich hoffe Ihr könnt mir helfen:
Habe eine Liste "A" mit Artikelnummern und alten Preisen.
Daneben habe ich Sheet "B", welches ein teilweiser Auszug aus Liste "A" ist. In "B" stehen aber für einige Artikel neuere Preise.

Meine Aufgabe ist nun, nur die neuen Preise aus "B" in die Liste "A" zu übernehmen.
Ich würde das ja gerne manuell machen, aber bei 16000 Daten ist das irgendwie Wahnsinn. Kennt Ihr eine Lösung?..evtl Sverweis?

Danke für Eure Hilfe

Bild


Betrifft: AW: Tabelle Updaten mit SVerweis? von: Josef Ehrensberger
Geschrieben am: 12.02.2005 16:13:12

Hallo Ralph!

Zum Beispiel so.
Sheet A
 ABC
1ArtikelPreis altPreis neu
21100125
32100100
43100100
54100125
65100100
76100100
87100100
98100100
109100100
1110100125
1211100125
Formeln der Tabelle
C2 : =WENN(ISTFEHLER(SVERWEIS(A2;'Sheet B'!$A$1:$B$20000;2;0));B2;SVERWEIS(A2;'Sheet B'!$A$1:$B$20000;2;0))
C3 : =WENN(ISTFEHLER(SVERWEIS(A3;'Sheet B'!$A$1:$B$20000;2;0));B3;SVERWEIS(A3;'Sheet B'!$A$1:$B$20000;2;0))
C4 : =WENN(ISTFEHLER(SVERWEIS(A4;'Sheet B'!$A$1:$B$20000;2;0));B4;SVERWEIS(A4;'Sheet B'!$A$1:$B$20000;2;0))
C5 : =WENN(ISTFEHLER(SVERWEIS(A5;'Sheet B'!$A$1:$B$20000;2;0));B5;SVERWEIS(A5;'Sheet B'!$A$1:$B$20000;2;0))
C6 : =WENN(ISTFEHLER(SVERWEIS(A6;'Sheet B'!$A$1:$B$20000;2;0));B6;SVERWEIS(A6;'Sheet B'!$A$1:$B$20000;2;0))
C7 : =WENN(ISTFEHLER(SVERWEIS(A7;'Sheet B'!$A$1:$B$20000;2;0));B7;SVERWEIS(A7;'Sheet B'!$A$1:$B$20000;2;0))
C8 : =WENN(ISTFEHLER(SVERWEIS(A8;'Sheet B'!$A$1:$B$20000;2;0));B8;SVERWEIS(A8;'Sheet B'!$A$1:$B$20000;2;0))
C9 : =WENN(ISTFEHLER(SVERWEIS(A9;'Sheet B'!$A$1:$B$20000;2;0));B9;SVERWEIS(A9;'Sheet B'!$A$1:$B$20000;2;0))
C10 : =WENN(ISTFEHLER(SVERWEIS(A10;'Sheet B'!$A$1:$B$20000;2;0));B10;SVERWEIS(A10;'Sheet B'!$A$1:$B$20000;2;0))
C11 : =WENN(ISTFEHLER(SVERWEIS(A11;'Sheet B'!$A$1:$B$20000;2;0));B11;SVERWEIS(A11;'Sheet B'!$A$1:$B$20000;2;0))
C12 : =WENN(ISTFEHLER(SVERWEIS(A12;'Sheet B'!$A$1:$B$20000;2;0));B12;SVERWEIS(A12;'Sheet B'!$A$1:$B$20000;2;0))
 
Sheet B
 AB
1ArtikelPreis
21125
34125
410125
511125
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  



Wobei man die Splate "C" durch kopieren > Inhalte Einfügen > Werte
zu Fixwerten umwandeln kann, und Spalte "B" löscht.


Oder per Makro!


Gruß Sepp

P.S.: Rückmeldung nicht vergessen!


Bild


Betrifft: Geht nicht, ich krieg das immernoch nicht hin von: Ralph T.
Geschrieben am: 12.02.2005 16:52:25

Hallo,
danke für den Tip, aber ich krieg das immer nóch nicht hin..anbei mein Beispiel


https://www.herber.de/bbs/user/17931.xls

danke!!


Bild


Betrifft: AW: Geht nicht, ich krieg das immernoch nicht hin von: Josef Ehrensberger
Geschrieben am: 12.02.2005 17:03:46

Hallo Palph!

Erstens musst du mit "ISRFEHLER()" arbeiten, weil ja nicht alle Artikel
in der zweiten Liste vorhanden sind.
Zweitens must du bei "Spaltenindex" die Spalte, also 2, angeben und nicht
die Matrix!

A
 ABC
1Liste A  
2ArtikelPreis alt 
386469,699,69
486479,699,69
Formeln der Tabelle
C3 : =WENN(ISTFEHLER(SVERWEIS(A3;$I$6:$J$11;2;FALSCH));B3;SVERWEIS(A3;$I$6:$J$11;2;FALSCH))
C4 : =WENN(ISTFEHLER(SVERWEIS(A4;$I$6:$J$11;2;FALSCH));B4;SVERWEIS(A4;$I$6:$J$11;2;FALSCH))
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  




Gruß Sepp

P.S.: Rückmeldung nicht vergessen!


Bild


Betrifft: DANKE!!!!!!!!!!!!!!!! es klappt von: Ralph T.
Geschrieben am: 12.02.2005 19:28:34

Hallo Sepp,
sorry für die späte Antwort..aber ich mußte erstmal einwenig abschalten..sonst hätte der PC das nicht überlebt..aber jetzt klappts. DAnke nochmal!
gruss
Ralph


 Bild

Beiträge aus den Excel-Beispielen zum Thema "Tabelle Updaten mit SVerweis?"