Formeln zusammenfassen?

Bild

Betrifft: Formeln zusammenfassen?
von: Hans
Geschrieben am: 24.02.2005 13:05:52
hi leute,
ich möchte gern folgende formeln zusammen fassen, damit nur eine summe gebildet wird:
{=SUMME((Kom=360000)*(JAHR(Datum)=JAHR($A$1))*(MONAT(Datum)=MONAT($A$1))*Std)}
{=SUMME((Kom=370000)*(JAHR(Datum)=JAHR($A$1))*(MONAT(Datum)=MONAT($A$1))*Std)}
{=SUMME((Kom=380000)*(JAHR(Datum)=JAHR($A$1))*(MONAT(Datum)=MONAT($A$1))*Std)}
geht das? wenn ja, wie? :-)
gruß
Hans

Bild

Betrifft: SUMME mit UND und ODER-Bedingung
von: Boris
Geschrieben am: 24.02.2005 13:41:56
Hi Hans,
wenn deine Werte vertikal (also in Spalten) angeordnet sind (da du Namen verwendest, kann ich das nicht sehen - ich geh aber einfach mal davon aus), sollte es so gehen (ungetestet):
{=SUMME((Kom={360000.37000.38000})*(JAHR(Datum)=JAHR($A$1))*(MONAT(Datum)=MONAT($A$1))*Std)}
Oder ohne Array mit SUMMENPRODUKT:
=SUMMENPRODUKT((Kom={360000.37000.38000})*(JAHR(Datum)=JAHR($A$1))*(MONAT(Datum)=MONAT($A$1))*Std)
Grüße Boris
Bild

Betrifft: AW: SUMME mit UND und ODER-Bedingung
von: Hans
Geschrieben am: 24.02.2005 13:56:47
hi boris,
vielen danke hat alle funktioniert. vielleicht kannst du mir auch bei der letzten formel helfen, die ich noch benötige! :-)
und zwar brauch ich eine formel die genau so funktioniert:
{=SUMME((Kom={36****.37****.38****})*(JAHR(Datum)=JAHR($A$1))*(MONAT(Datum)=MONAT($A$1))*Std)}
die * stehen für alle zahlen also z.b. 360025 oder 380156 oder 370568.
vielen dank im voraus.
gruß
Hans
Bild

Betrifft: AW: SUMME mit UND und ODER-Bedingung
von: Boris
Geschrieben am: 24.02.2005 14:06:49
Hi Hans,
aus der Hand:
{=SUMME((LINKS(Kom;2)={"36"."37"."38"})*(JAHR(Datum)=JAHR($A$1))*(MONAT(Datum)=MONAT($A$1))*Std)}
oder aber
{=SUMME((Kom>=360000)*(Kom<=380000)*(JAHR(Datum)=JAHR($A$1))*(MONAT(Datum)=MONAT($A$1))*Std)}
Grüße Boris
Bild

Betrifft: AW: SUMME mit UND und ODER-Bedingung
von: Hans
Geschrieben am: 24.02.2005 14:19:21
hi boris,
erstmal danke für deine hilfe, aber die zwei genannten formeln geben immer einen falschen wert raus, weil ja auch die 380000 und 370000 und 360000 mitgezählt werden. kann das sein? wenn ich falsch liegen hab ich nix gesagt. :-)
gruß
Hans
Bild

Betrifft: Sollte doch so sein? Oder nicht?
von: Boris
Geschrieben am: 24.02.2005 14:29:25
Hi Hans,
genau so hab ich deine Beschreibung verstanden: Alles zwischen 360000 und 380000...
Was stimmt nicht?
Grüße Boris
Bild

Betrifft: AW: Sollte doch so sein? Oder nicht?
von: Hans
Geschrieben am: 24.02.2005 14:38:22
hi boris,
dann hab ich mich falsch ausgedrückt. :-( SORRY. ich wollte alle zahlen haben die zwischen 360001 bis 369999 + 370001 bis 379999 + 380001 bis 389999.
also nicht die stunden die z.b. auf eine 370000 380000 und 390000 laufen.
gruß
Hans
Bild

Betrifft: Dann subtrahier sie einfach wieder...
von: Boris
Geschrieben am: 24.02.2005 15:07:07
Hi Hans,
diese Formel einfach als Subtraktion anfügen:
{=SUMME((Kom={360000.370000.380000})*(JAHR(Datum)=JAHR($A$1))*(MONAT(Datum)=MONAT($A$1))*Std)}
Oder aber so (ungetestet):
{=SUMME((Kom>=360000)*(Kom<=380000)*(Kom<>{360000.370000.380000})*(JAHR(Datum)=JAHR($A$1))*(MONAT(Datum)=MONAT($A$1))*Std)}
Grüße Boris
Bild

Betrifft: AW: Dann subtrahier sie einfach wieder...
von: Hans
Geschrieben am: 24.02.2005 15:52:07
hi Boris,
vielen vielen dank, das mit der subtraktion hat funktioniert. :-)
gruß
Hans
 Bild

Beiträge aus den Excel-Beispielen zum Thema "Formeln zusammenfassen?"