Herbers Excel-Forum - das Archiv

Stundenberechnung

Bild

Betrifft: Stundenberechnung
von: ottgunter@t-online.de

Geschrieben am: 16.12.2006 12:49:48
Hallo
wer kann helfen?
Ich möchte in der Tabelle die Arbeitszeit errechnet haben.
Dabei ist von Montag bis Freitag a 8 Stunden
also Wochenende und Feiertage nicht mitberechnen
https://www.herber.de/bbs/user/39043.xls
Bild

Betrifft: AW: Stundenberechnung
von: ottgunter@t-online.de
Geschrieben am: 16.12.2006 13:22:42
Das ist die falsche mappe
hier die richtige
https://www.herber.de/bbs/user/39044.xls
Bild

Betrifft: AW: Stundenberechnung
von: Uwe

Geschrieben am: 16.12.2006 13:53:59
Hallo,
ich kann dir nur mit einer Hilfskrücke helfen, indem du in Spalte C folgende Formel einfügst und herunterziehst:
=SUMME(ZÄHLENWENN(Feiertage!B:B;A7))
Anschließend färbt dir das folgende Makro die Zeilen grün
Public
Sub FT_faerben()
Dim lZeile  As Long
For lZeile = 7 To Range("A65536").End(xlUp).Row
If Range("C" & lZeile) = 1 Then
Range("A" & lZeile & ":B" & lZeile).Interior.ColorIndex = 43
End If
Next lZeile
End Sub

Gruß
Uwe
Bild

Betrifft: AW: Stundenberechnung
von: ottgunter@t-online.de
Geschrieben am: 16.12.2006 14:12:13
Hallo Uwe
Ich habe in meiner fragestellung der Stundenberechnung eine falsche tabelle eingefügt
die feiertagsmarkierung ist gelöst
trotzdem danke
es geht mir dabei um die monatsarbeitsstunden
die richtige tabelle ist in der zweiten anfrage
Bild

Betrifft: AW: Stundenberechnung
von: jockel

Geschrieben am: 16.12.2006 19:39:48
hi meinst du so: (ich habe - dein einverständnis vorausgesetzt - deine datei einwenig verändert; noch dynamischer gemacht...
guckst du hier: https://www.herber.de/bbs/user/39050.xls
Januar
 ABC
520062006Soll (Std.)
6Mai5160
701.05.2006Mo0
801.05.2006Mo0
902.05.2006Di8
1003.05.2006Mi8
1104.05.2006Do8
1205.05.2006Fr8
1306.05.2006Sa0
1407.05.2006So0
1508.05.2006Mo8
1609.05.2006Di8
1710.05.2006Mi8
1811.05.2006Do8
1912.05.2006Fr8
2013.05.2006Sa0
2114.05.2006So0
2215.05.2006Mo8
2316.05.2006Di8
2417.05.2006Mi8
2518.05.2006Do8
2619.05.2006Fr8
2720.05.2006Sa0
2821.05.2006So0
2922.05.2006Mo8
3023.05.2006Di8
3124.05.2006Mi8
3225.05.2006Do0
3326.05.2006Fr8
3427.05.2006Sa0
3528.05.2006So0
3629.05.2006Mo8
3730.05.2006Di8
3831.05.2006Mi8
Formeln der Tabelle
A5 : =B5
A6 : =TEXT(A7;"MMMM")
C6 : =SUMME(C7:C37)
A7 : =DATUM($A$5;$B$6;ZEILE(A1))
B7 : =A7
C7 : =WENN(A7="";"";WENN(UND(WOCHENTAG(A7;2)<=5;ISTNV(VERGLEICH(A7;Feiertage!$B$3:$B$27;0)));8;0))
A8 : =WENN(A5="";"";WENN(TEXT(DATUM($A$5;$B$6;ZEILE(A1));"MMMM")=$A$6;DATUM($A$5;$B$6;ZEILE(A1));""))
B8 : =A8
C8 : =WENN(A8="";"";WENN(UND(WOCHENTAG(A8;2)<=5;ISTNV(VERGLEICH(A8;Feiertage!$B$3:$B$27;0)));8;0))
A9 : =WENN(A6="";"";WENN(TEXT(DATUM($A$5;$B$6;ZEILE(A2));"MMMM")=$A$6;DATUM($A$5;$B$6;ZEILE(A2));""))
B9 : =A9
C9 : =WENN(A9="";"";WENN(UND(WOCHENTAG(A9;2)<=5;ISTNV(VERGLEICH(A9;Feiertage!$B$3:$B$27;0)));8;0))
A10 : =WENN(A7="";"";WENN(TEXT(DATUM($A$5;$B$6;ZEILE(A3));"MMMM")=$A$6;DATUM($A$5;$B$6;ZEILE(A3));""))
B10 : =A10
C10 : =WENN(A10="";"";WENN(UND(WOCHENTAG(A10;2)<=5;ISTNV(VERGLEICH(A10;Feiertage!$B$3:$B$27;0)));8;0))
A11 : =WENN(A8="";"";WENN(TEXT(DATUM($A$5;$B$6;ZEILE(A4));"MMMM")=$A$6;DATUM($A$5;$B$6;ZEILE(A4));""))
B11 : =A11
C11 : =WENN(A11="";"";WENN(UND(WOCHENTAG(A11;2)<=5;ISTNV(VERGLEICH(A11;Feiertage!$B$3:$B$27;0)));8;0))
A12 : =WENN(A9="";"";WENN(TEXT(DATUM($A$5;$B$6;ZEILE(A5));"MMMM")=$A$6;DATUM($A$5;$B$6;ZEILE(A5));""))
B12 : =A12
C12 : =WENN(A12="";"";WENN(UND(WOCHENTAG(A12;2)<=5;ISTNV(VERGLEICH(A12;Feiertage!$B$3:$B$27;0)));8;0))
A13 : =WENN(A10="";"";WENN(TEXT(DATUM($A$5;$B$6;ZEILE(A6));"MMMM")=$A$6;DATUM($A$5;$B$6;ZEILE(A6));""))
B13 : =A13
C13 : =WENN(A13="";"";WENN(UND(WOCHENTAG(A13;2)<=5;ISTNV(VERGLEICH(A13;Feiertage!$B$3:$B$27;0)));8;0))
A14 : =WENN(A11="";"";WENN(TEXT(DATUM($A$5;$B$6;ZEILE(A7));"MMMM")=$A$6;DATUM($A$5;$B$6;ZEILE(A7));""))
B14 : =A14
C14 : =WENN(A14="";"";WENN(UND(WOCHENTAG(A14;2)<=5;ISTNV(VERGLEICH(A14;Feiertage!$B$3:$B$27;0)));8;0))
A15 : =WENN(A12="";"";WENN(TEXT(DATUM($A$5;$B$6;ZEILE(A8));"MMMM")=$A$6;DATUM($A$5;$B$6;ZEILE(A8));""))
B15 : =A15
C15 : =WENN(A15="";"";WENN(UND(WOCHENTAG(A15;2)<=5;ISTNV(VERGLEICH(A15;Feiertage!$B$3:$B$27;0)));8;0))
A16 : =WENN(A13="";"";WENN(TEXT(DATUM($A$5;$B$6;ZEILE(A9));"MMMM")=$A$6;DATUM($A$5;$B$6;ZEILE(A9));""))
B16 : =A16
C16 : =WENN(A16="";"";WENN(UND(WOCHENTAG(A16;2)<=5;ISTNV(VERGLEICH(A16;Feiertage!$B$3:$B$27;0)));8;0))
A17 : =WENN(A14="";"";WENN(TEXT(DATUM($A$5;$B$6;ZEILE(A10));"MMMM")=$A$6;DATUM($A$5;$B$6;ZEILE(A10));""))
B17 : =A17
C17 : =WENN(A17="";"";WENN(UND(WOCHENTAG(A17;2)<=5;ISTNV(VERGLEICH(A17;Feiertage!$B$3:$B$27;0)));8;0))
A18 : =WENN(A15="";"";WENN(TEXT(DATUM($A$5;$B$6;ZEILE(A11));"MMMM")=$A$6;DATUM($A$5;$B$6;ZEILE(A11));""))
B18 : =A18
C18 : =WENN(A18="";"";WENN(UND(WOCHENTAG(A18;2)<=5;ISTNV(VERGLEICH(A18;Feiertage!$B$3:$B$27;0)));8;0))
A19 : =WENN(A16="";"";WENN(TEXT(DATUM($A$5;$B$6;ZEILE(A12));"MMMM")=$A$6;DATUM($A$5;$B$6;ZEILE(A12));""))
B19 : =A19
C19 : =WENN(A19="";"";WENN(UND(WOCHENTAG(A19;2)<=5;ISTNV(VERGLEICH(A19;Feiertage!$B$3:$B$27;0)));8;0))
A20 : =WENN(A17="";"";WENN(TEXT(DATUM($A$5;$B$6;ZEILE(A13));"MMMM")=$A$6;DATUM($A$5;$B$6;ZEILE(A13));""))
B20 : =A20
C20 : =WENN(A20="";"";WENN(UND(WOCHENTAG(A20;2)<=5;ISTNV(VERGLEICH(A20;Feiertage!$B$3:$B$27;0)));8;0))
A21 : =WENN(A18="";"";WENN(TEXT(DATUM($A$5;$B$6;ZEILE(A14));"MMMM")=$A$6;DATUM($A$5;$B$6;ZEILE(A14));""))
B21 : =A21
C21 : =WENN(A21="";"";WENN(UND(WOCHENTAG(A21;2)<=5;ISTNV(VERGLEICH(A21;Feiertage!$B$3:$B$27;0)));8;0))
A22 : =WENN(A19="";"";WENN(TEXT(DATUM($A$5;$B$6;ZEILE(A15));"MMMM")=$A$6;DATUM($A$5;$B$6;ZEILE(A15));""))
B22 : =A22
C22 : =WENN(A22="";"";WENN(UND(WOCHENTAG(A22;2)<=5;ISTNV(VERGLEICH(A22;Feiertage!$B$3:$B$27;0)));8;0))
A23 : =WENN(A20="";"";WENN(TEXT(DATUM($A$5;$B$6;ZEILE(A16));"MMMM")=$A$6;DATUM($A$5;$B$6;ZEILE(A16));""))
B23 : =A23
C23 : =WENN(A23="";"";WENN(UND(WOCHENTAG(A23;2)<=5;ISTNV(VERGLEICH(A23;Feiertage!$B$3:$B$27;0)));8;0))
A24 : =WENN(A21="";"";WENN(TEXT(DATUM($A$5;$B$6;ZEILE(A17));"MMMM")=$A$6;DATUM($A$5;$B$6;ZEILE(A17));""))
B24 : =A24
C24 : =WENN(A24="";"";WENN(UND(WOCHENTAG(A24;2)<=5;ISTNV(VERGLEICH(A24;Feiertage!$B$3:$B$27;0)));8;0))
A25 : =WENN(A22="";"";WENN(TEXT(DATUM($A$5;$B$6;ZEILE(A18));"MMMM")=$A$6;DATUM($A$5;$B$6;ZEILE(A18));""))
B25 : =A25
C25 : =WENN(A25="";"";WENN(UND(WOCHENTAG(A25;2)<=5;ISTNV(VERGLEICH(A25;Feiertage!$B$3:$B$27;0)));8;0))
A26 : =WENN(A23="";"";WENN(TEXT(DATUM($A$5;$B$6;ZEILE(A19));"MMMM")=$A$6;DATUM($A$5;$B$6;ZEILE(A19));""))
B26 : =A26
C26 : =WENN(A26="";"";WENN(UND(WOCHENTAG(A26;2)<=5;ISTNV(VERGLEICH(A26;Feiertage!$B$3:$B$27;0)));8;0))
A27 : =WENN(A24="";"";WENN(TEXT(DATUM($A$5;$B$6;ZEILE(A20));"MMMM")=$A$6;DATUM($A$5;$B$6;ZEILE(A20));""))
B27 : =A27
C27 : =WENN(A27="";"";WENN(UND(WOCHENTAG(A27;2)<=5;ISTNV(VERGLEICH(A27;Feiertage!$B$3:$B$27;0)));8;0))
A28 : =WENN(A25="";"";WENN(TEXT(DATUM($A$5;$B$6;ZEILE(A21));"MMMM")=$A$6;DATUM($A$5;$B$6;ZEILE(A21));""))
B28 : =A28
C28 : =WENN(A28="";"";WENN(UND(WOCHENTAG(A28;2)<=5;ISTNV(VERGLEICH(A28;Feiertage!$B$3:$B$27;0)));8;0))
A29 : =WENN(A26="";"";WENN(TEXT(DATUM($A$5;$B$6;ZEILE(A22));"MMMM")=$A$6;DATUM($A$5;$B$6;ZEILE(A22));""))
B29 : =A29
C29 : =WENN(A29="";"";WENN(UND(WOCHENTAG(A29;2)<=5;ISTNV(VERGLEICH(A29;Feiertage!$B$3:$B$27;0)));8;0))
A30 : =WENN(A27="";"";WENN(TEXT(DATUM($A$5;$B$6;ZEILE(A23));"MMMM")=$A$6;DATUM($A$5;$B$6;ZEILE(A23));""))
B30 : =A30
C30 : =WENN(A30="";"";WENN(UND(WOCHENTAG(A30;2)<=5;ISTNV(VERGLEICH(A30;Feiertage!$B$3:$B$27;0)));8;0))
A31 : =WENN(A28="";"";WENN(TEXT(DATUM($A$5;$B$6;ZEILE(A24));"MMMM")=$A$6;DATUM($A$5;$B$6;ZEILE(A24));""))
B31 : =A31
C31 : =WENN(A31="";"";WENN(UND(WOCHENTAG(A31;2)<=5;ISTNV(VERGLEICH(A31;Feiertage!$B$3:$B$27;0)));8;0))
A32 : =WENN(A29="";"";WENN(TEXT(DATUM($A$5;$B$6;ZEILE(A25));"MMMM")=$A$6;DATUM($A$5;$B$6;ZEILE(A25));""))
B32 : =A32
C32 : =WENN(A32="";"";WENN(UND(WOCHENTAG(A32;2)<=5;ISTNV(VERGLEICH(A32;Feiertage!$B$3:$B$27;0)));8;0))
A33 : =WENN(A30="";"";WENN(TEXT(DATUM($A$5;$B$6;ZEILE(A26));"MMMM")=$A$6;DATUM($A$5;$B$6;ZEILE(A26));""))
B33 : =A33
C33 : =WENN(A33="";"";WENN(UND(WOCHENTAG(A33;2)<=5;ISTNV(VERGLEICH(A33;Feiertage!$B$3:$B$27;0)));8;0))
A34 : =WENN(A31="";"";WENN(TEXT(DATUM($A$5;$B$6;ZEILE(A27));"MMMM")=$A$6;DATUM($A$5;$B$6;ZEILE(A27));""))
B34 : =A34
C34 : =WENN(A34="";"";WENN(UND(WOCHENTAG(A34;2)<=5;ISTNV(VERGLEICH(A34;Feiertage!$B$3:$B$27;0)));8;0))
A35 : =WENN(A32="";"";WENN(TEXT(DATUM($A$5;$B$6;ZEILE(A28));"MMMM")=$A$6;DATUM($A$5;$B$6;ZEILE(A28));""))
B35 : =A35
C35 : =WENN(A35="";"";WENN(UND(WOCHENTAG(A35;2)<=5;ISTNV(VERGLEICH(A35;Feiertage!$B$3:$B$27;0)));8;0))
A36 : =WENN(A33="";"";WENN(TEXT(DATUM($A$5;$B$6;ZEILE(A29));"MMMM")=$A$6;DATUM($A$5;$B$6;ZEILE(A29));""))
B36 : =A36
C36 : =WENN(A36="";"";WENN(UND(WOCHENTAG(A36;2)<=5;ISTNV(VERGLEICH(A36;Feiertage!$B$3:$B$27;0)));8;0))
A37 : =WENN(A34="";"";WENN(TEXT(DATUM($A$5;$B$6;ZEILE(A30));"MMMM")=$A$6;DATUM($A$5;$B$6;ZEILE(A30));""))
B37 : =A37
C37 : =WENN(A37="";"";WENN(UND(WOCHENTAG(A37;2)<=5;ISTNV(VERGLEICH(A37;Feiertage!$B$3:$B$27;0)));8;0))
A38 : =WENN(A35="";"";WENN(TEXT(DATUM($A$5;$B$6;ZEILE(A31));"MMMM")=$A$6;DATUM($A$5;$B$6;ZEILE(A31));""))
B38 : =A38
C38 : =WENN(A38="";"";WENN(UND(WOCHENTAG(A38;2)<=5;ISTNV(VERGLEICH(A38;Feiertage!$B$3:$B$27;0)));8;0))
Bedingte Formatierungen der Tabelle
ZelleNr.: / BedingungFormat
A71. / Formel ist =WOCHENTAG($A7;2)=6Abc
A72. / Formel ist =WOCHENTAG($A7;2)=7Abc
A73. / Formel ist =VERGLEICH($A7;Feiertage;0)>0Abc
B71. / Formel ist =WOCHENTAG($A7;2)=6Abc
B72. / Formel ist =WOCHENTAG($A7;2)=7Abc
B73. / Formel ist =VERGLEICH($A7;Feiertage;0)>0Abc
C71. / Formel ist =WOCHENTAG($A7;2)=6Abc
C72. / Formel ist =WOCHENTAG($A7;2)=7Abc
C73. / Formel ist =VERGLEICH($A7;Feiertage;0)>0Abc
A81. / Formel ist =WOCHENTAG($A8;2)=6Abc
A82. / Formel ist =WOCHENTAG($A8;2)=7Abc
A83. / Formel ist =VERGLEICH($A8;Feiertage;0)>0Abc
B81. / Formel ist =WOCHENTAG($A8;2)=6Abc
B82. / Formel ist =WOCHENTAG($A8;2)=7Abc
B83. / Formel ist =VERGLEICH($A8;Feiertage;0)>0Abc
C81. / Formel ist =WOCHENTAG($A8;2)=6Abc
C82. / Formel ist =WOCHENTAG($A8;2)=7Abc
C83. / Formel ist =VERGLEICH($A8;Feiertage;0)>0Abc
A91. / Formel ist =WOCHENTAG($A9;2)=6Abc
A92. / Formel ist =WOCHENTAG($A9;2)=7Abc
A93. / Formel ist =VERGLEICH($A9;Feiertage;0)>0Abc
B91. / Formel ist =WOCHENTAG($A9;2)=6Abc
B92. / Formel ist =WOCHENTAG($A9;2)=7Abc
B93. / Formel ist =VERGLEICH($A9;Feiertage;0)>0Abc
C91. / Formel ist =WOCHENTAG($A9;2)=6Abc
C92. / Formel ist =WOCHENTAG($A9;2)=7Abc
C93. / Formel ist =VERGLEICH($A9;Feiertage;0)>0Abc
A101. / Formel ist =WOCHENTAG($A10;2)=6Abc
A102. / Formel ist =WOCHENTAG($A10;2)=7Abc
A103. / Formel ist =VERGLEICH($A10;Feiertage;0)>0Abc
B101. / Formel ist =WOCHENTAG($A10;2)=6Abc
B102. / Formel ist =WOCHENTAG($A10;2)=7Abc
B103. / Formel ist =VERGLEICH($A10;Feiertage;0)>0Abc
C101. / Formel ist =WOCHENTAG($A10;2)=6Abc
C102. / Formel ist =WOCHENTAG($A10;2)=7Abc
C103. / Formel ist =VERGLEICH($A10;Feiertage;0)>0Abc
A111. / Formel ist =WOCHENTAG($A11;2)=6Abc
A112. / Formel ist =WOCHENTAG($A11;2)=7Abc
A113. / Formel ist =VERGLEICH($A11;Feiertage;0)>0Abc
B111. / Formel ist =WOCHENTAG($A11;2)=6Abc
B112. / Formel ist =WOCHENTAG($A11;2)=7Abc
B113. / Formel ist =VERGLEICH($A11;Feiertage;0)>0Abc
C111. / Formel ist =WOCHENTAG($A11;2)=6Abc
C112. / Formel ist =WOCHENTAG($A11;2)=7Abc
C113. / Formel ist =VERGLEICH($A11;Feiertage;0)>0Abc
A121. / Formel ist =WOCHENTAG($A12;2)=6Abc
A122. / Formel ist =WOCHENTAG($A12;2)=7Abc
A123. / Formel ist =VERGLEICH($A12;Feiertage;0)>0Abc
B121. / Formel ist =WOCHENTAG($A12;2)=6Abc
B122. / Formel ist =WOCHENTAG($A12;2)=7Abc
B123. / Formel ist =VERGLEICH($A12;Feiertage;0)>0Abc
C121. / Formel ist =WOCHENTAG($A12;2)=6Abc
C122. / Formel ist =WOCHENTAG($A12;2)=7Abc
C123. / Formel ist =VERGLEICH($A12;Feiertage;0)>0Abc
A131. / Formel ist =WOCHENTAG($A13;2)=6Abc
A132. / Formel ist =WOCHENTAG($A13;2)=7Abc
A133. / Formel ist =VERGLEICH($A13;Feiertage;0)>0Abc
B131. / Formel ist =WOCHENTAG($A13;2)=6Abc
B132. / Formel ist =WOCHENTAG($A13;2)=7Abc
B133. / Formel ist =VERGLEICH($A13;Feiertage;0)>0Abc
C131. / Formel ist =WOCHENTAG($A13;2)=6Abc
C132. / Formel ist =WOCHENTAG($A13;2)=7Abc
C133. / Formel ist =VERGLEICH($A13;Feiertage;0)>0Abc
A141. / Formel ist =WOCHENTAG($A14;2)=6Abc
A142. / Formel ist =WOCHENTAG($A14;2)=7Abc
A143. / Formel ist =VERGLEICH($A14;Feiertage;0)>0Abc
B141. / Formel ist =WOCHENTAG($A14;2)=6Abc
B142. / Formel ist =WOCHENTAG($A14;2)=7Abc
B143. / Formel ist =VERGLEICH($A14;Feiertage;0)>0Abc
C141. / Formel ist =WOCHENTAG($A14;2)=6Abc
C142. / Formel ist =WOCHENTAG($A14;2)=7Abc
C143. / Formel ist =VERGLEICH($A14;Feiertage;0)>0Abc
A151. / Formel ist =WOCHENTAG($A15;2)=6Abc
A152. / Formel ist =WOCHENTAG($A15;2)=7Abc
A153. / Formel ist =VERGLEICH($A15;Feiertage;0)>0Abc
B151. / Formel ist =WOCHENTAG($A15;2)=6Abc
B152. / Formel ist =WOCHENTAG($A15;2)=7Abc
B153. / Formel ist =VERGLEICH($A15;Feiertage;0)>0Abc
C151. / Formel ist =WOCHENTAG($A15;2)=6Abc
C152. / Formel ist =WOCHENTAG($A15;2)=7Abc
C153. / Formel ist =VERGLEICH($A15;Feiertage;0)>0Abc
A161. / Formel ist =WOCHENTAG($A16;2)=6Abc
A162. / Formel ist =WOCHENTAG($A16;2)=7Abc
A163. / Formel ist =VERGLEICH($A16;Feiertage;0)>0Abc
B161. / Formel ist =WOCHENTAG($A16;2)=6Abc
B162. / Formel ist =WOCHENTAG($A16;2)=7Abc
B163. / Formel ist =VERGLEICH($A16;Feiertage;0)>0Abc
C161. / Formel ist =WOCHENTAG($A16;2)=6Abc
C162. / Formel ist =WOCHENTAG($A16;2)=7Abc
C163. / Formel ist =VERGLEICH($A16;Feiertage;0)>0Abc
A171. / Formel ist =WOCHENTAG($A17;2)=6Abc
A172. / Formel ist =WOCHENTAG($A17;2)=7Abc
A173. / Formel ist =VERGLEICH($A17;Feiertage;0)>0Abc
B171. / Formel ist =WOCHENTAG($A17;2)=6Abc
B172. / Formel ist =WOCHENTAG($A17;2)=7Abc
B173. / Formel ist =VERGLEICH($A17;Feiertage;0)>0Abc
C171. / Formel ist =WOCHENTAG($A17;2)=6Abc
C172. / Formel ist =WOCHENTAG($A17;2)=7Abc
C173. / Formel ist =VERGLEICH($A17;Feiertage;0)>0Abc
A181. / Formel ist =WOCHENTAG($A18;2)=6Abc
A182. / Formel ist =WOCHENTAG($A18;2)=7Abc
A183. / Formel ist =VERGLEICH($A18;Feiertage;0)>0Abc
B181. / Formel ist =WOCHENTAG($A18;2)=6Abc
B182. / Formel ist =WOCHENTAG($A18;2)=7Abc
B183. / Formel ist =VERGLEICH($A18;Feiertage;0)>0Abc
C181. / Formel ist =WOCHENTAG($A18;2)=6Abc
C182. / Formel ist =WOCHENTAG($A18;2)=7Abc
C183. / Formel ist =VERGLEICH($A18;Feiertage;0)>0Abc
A191. / Formel ist =WOCHENTAG($A19;2)=6Abc
A192. / Formel ist =WOCHENTAG($A19;2)=7Abc
A193. / Formel ist =VERGLEICH($A19;Feiertage;0)>0Abc
B191. / Formel ist =WOCHENTAG($A19;2)=6Abc
B192. / Formel ist =WOCHENTAG($A19;2)=7Abc
B193. / Formel ist =VERGLEICH($A19;Feiertage;0)>0Abc
C191. / Formel ist =WOCHENTAG($A19;2)=6Abc
C192. / Formel ist =WOCHENTAG($A19;2)=7Abc
C193. / Formel ist =VERGLEICH($A19;Feiertage;0)>0Abc
A201. / Formel ist =WOCHENTAG($A20;2)=6Abc
A202. / Formel ist =WOCHENTAG($A20;2)=7Abc
A203. / Formel ist =VERGLEICH($A20;Feiertage;0)>0Abc
B201. / Formel ist =WOCHENTAG($A20;2)=6Abc
B202. / Formel ist =WOCHENTAG($A20;2)=7Abc
B203. / Formel ist =VERGLEICH($A20;Feiertage;0)>0Abc
C201. / Formel ist =WOCHENTAG($A20;2)=6Abc
C202. / Formel ist =WOCHENTAG($A20;2)=7Abc
C203. / Formel ist =VERGLEICH($A20;Feiertage;0)>0Abc
A211. / Formel ist =WOCHENTAG($A21;2)=6Abc
A212. / Formel ist =WOCHENTAG($A21;2)=7Abc
A213. / Formel ist =VERGLEICH($A21;Feiertage;0)>0Abc
B211. / Formel ist =WOCHENTAG($A21;2)=6Abc
B212. / Formel ist =WOCHENTAG($A21;2)=7Abc
B213. / Formel ist =VERGLEICH($A21;Feiertage;0)>0Abc
C211. / Formel ist =WOCHENTAG($A21;2)=6Abc
C212. / Formel ist =WOCHENTAG($A21;2)=7Abc
C213. / Formel ist =VERGLEICH($A21;Feiertage;0)>0Abc
A221. / Formel ist =WOCHENTAG($A22;2)=6Abc
A222. / Formel ist =WOCHENTAG($A22;2)=7Abc
A223. / Formel ist =VERGLEICH($A22;Feiertage;0)>0Abc
B221. / Formel ist =WOCHENTAG($A22;2)=6Abc
B222. / Formel ist =WOCHENTAG($A22;2)=7Abc
B223. / Formel ist =VERGLEICH($A22;Feiertage;0)>0Abc
C221. / Formel ist =WOCHENTAG($A22;2)=6Abc
C222. / Formel ist =WOCHENTAG($A22;2)=7Abc
C223. / Formel ist =VERGLEICH($A22;Feiertage;0)>0Abc
A231. / Formel ist =WOCHENTAG($A23;2)=6Abc
A232. / Formel ist =WOCHENTAG($A23;2)=7Abc
A233. / Formel ist =VERGLEICH($A23;Feiertage;0)>0Abc
B231. / Formel ist =WOCHENTAG($A23;2)=6Abc
B232. / Formel ist =WOCHENTAG($A23;2)=7Abc
B233. / Formel ist =VERGLEICH($A23;Feiertage;0)>0Abc
C231. / Formel ist =WOCHENTAG($A23;2)=6Abc
C232. / Formel ist =WOCHENTAG($A23;2)=7Abc
C233. / Formel ist =VERGLEICH($A23;Feiertage;0)>0Abc
A241. / Formel ist =WOCHENTAG($A24;2)=6Abc
A242. / Formel ist =WOCHENTAG($A24;2)=7Abc
A243. / Formel ist =VERGLEICH($A24;Feiertage;0)>0Abc
B241. / Formel ist =WOCHENTAG($A24;2)=6Abc
B242. / Formel ist =WOCHENTAG($A24;2)=7Abc
B243. / Formel ist =VERGLEICH($A24;Feiertage;0)>0Abc
C241. / Formel ist =WOCHENTAG($A24;2)=6Abc
C242. / Formel ist =WOCHENTAG($A24;2)=7Abc
C243. / Formel ist =VERGLEICH($A24;Feiertage;0)>0Abc
A251. / Formel ist =WOCHENTAG($A25;2)=6Abc
A252. / Formel ist =WOCHENTAG($A25;2)=7Abc
A253. / Formel ist =VERGLEICH($A25;Feiertage;0)>0Abc
B251. / Formel ist =WOCHENTAG($A25;2)=6Abc
B252. / Formel ist =WOCHENTAG($A25;2)=7Abc
B253. / Formel ist =VERGLEICH($A25;Feiertage;0)>0Abc
C251. / Formel ist =WOCHENTAG($A25;2)=6Abc
C252. / Formel ist =WOCHENTAG($A25;2)=7Abc
C253. / Formel ist =VERGLEICH($A25;Feiertage;0)>0Abc
A261. / Formel ist =WOCHENTAG($A26;2)=6Abc
A262. / Formel ist =WOCHENTAG($A26;2)=7Abc
A263. / Formel ist =VERGLEICH($A26;Feiertage;0)>0Abc
B261. / Formel ist =WOCHENTAG($A26;2)=6Abc
B262. / Formel ist =WOCHENTAG($A26;2)=7Abc
B263. / Formel ist =VERGLEICH($A26;Feiertage;0)>0Abc
C261. / Formel ist =WOCHENTAG($A26;2)=6Abc
C262. / Formel ist =WOCHENTAG($A26;2)=7Abc
C263. / Formel ist =VERGLEICH($A26;Feiertage;0)>0Abc
A271. / Formel ist =WOCHENTAG($A27;2)=6Abc
A272. / Formel ist =WOCHENTAG($A27;2)=7Abc
A273. / Formel ist =VERGLEICH($A27;Feiertage;0)>0Abc
B271. / Formel ist =WOCHENTAG($A27;2)=6Abc
B272. / Formel ist =WOCHENTAG($A27;2)=7Abc
B273. / Formel ist =VERGLEICH($A27;Feiertage;0)>0Abc
C271. / Formel ist =WOCHENTAG($A27;2)=6Abc
C272. / Formel ist =WOCHENTAG($A27;2)=7Abc
C273. / Formel ist =VERGLEICH($A27;Feiertage;0)>0Abc
A281. / Formel ist =WOCHENTAG($A28;2)=6Abc
A282. / Formel ist =WOCHENTAG($A28;2)=7Abc
A283. / Formel ist =VERGLEICH($A28;Feiertage;0)>0Abc
B281. / Formel ist =WOCHENTAG($A28;2)=6Abc
B282. / Formel ist =WOCHENTAG($A28;2)=7Abc
B283. / Formel ist =VERGLEICH($A28;Feiertage;0)>0Abc
C281. / Formel ist =WOCHENTAG($A28;2)=6Abc
C282. / Formel ist =WOCHENTAG($A28;2)=7Abc
C283. / Formel ist =VERGLEICH($A28;Feiertage;0)>0Abc
A291. / Formel ist =WOCHENTAG($A29;2)=6Abc
A292. / Formel ist =WOCHENTAG($A29;2)=7Abc
A293. / Formel ist =VERGLEICH($A29;Feiertage;0)>0Abc
B291. / Formel ist =WOCHENTAG($A29;2)=6Abc
B292. / Formel ist =WOCHENTAG($A29;2)=7Abc
B293. / Formel ist =VERGLEICH($A29;Feiertage;0)>0Abc
C291. / Formel ist =WOCHENTAG($A29;2)=6Abc
C292. / Formel ist =WOCHENTAG($A29;2)=7Abc
C293. / Formel ist =VERGLEICH($A29;Feiertage;0)>0Abc
A301. / Formel ist =WOCHENTAG($A30;2)=6Abc
A302. / Formel ist =WOCHENTAG($A30;2)=7Abc
A303. / Formel ist =VERGLEICH($A30;Feiertage;0)>0Abc
B301. / Formel ist =WOCHENTAG($A30;2)=6Abc
B302. / Formel ist =WOCHENTAG($A30;2)=7Abc
B303. / Formel ist =VERGLEICH($A30;Feiertage;0)>0Abc
C301. / Formel ist =WOCHENTAG($A30;2)=6Abc
C302. / Formel ist =WOCHENTAG($A30;2)=7Abc
C303. / Formel ist =VERGLEICH($A30;Feiertage;0)>0Abc
A311. / Formel ist =WOCHENTAG($A31;2)=6Abc
A312. / Formel ist =WOCHENTAG($A31;2)=7Abc
A313. / Formel ist =VERGLEICH($A31;Feiertage;0)>0Abc
B311. / Formel ist =WOCHENTAG($A31;2)=6Abc
B312. / Formel ist =WOCHENTAG($A31;2)=7Abc
B313. / Formel ist =VERGLEICH($A31;Feiertage;0)>0Abc
C311. / Formel ist =WOCHENTAG($A31;2)=6Abc
C312. / Formel ist =WOCHENTAG($A31;2)=7Abc
C313. / Formel ist =VERGLEICH($A31;Feiertage;0)>0Abc
A321. / Formel ist =WOCHENTAG($A32;2)=6Abc
A322. / Formel ist =WOCHENTAG($A32;2)=7Abc
A323. / Formel ist =VERGLEICH($A32;Feiertage;0)>0Abc
B321. / Formel ist =WOCHENTAG($A32;2)=6Abc
B322. / Formel ist =WOCHENTAG($A32;2)=7Abc
B323. / Formel ist =VERGLEICH($A32;Feiertage;0)>0Abc
C321. / Formel ist =WOCHENTAG($A32;2)=6Abc
C322. / Formel ist =WOCHENTAG($A32;2)=7Abc
C323. / Formel ist =VERGLEICH($A32;Feiertage;0)>0Abc
A331. / Formel ist =WOCHENTAG($A33;2)=6Abc
A332. / Formel ist =WOCHENTAG($A33;2)=7Abc
A333. / Formel ist =VERGLEICH($A33;Feiertage;0)>0Abc
B331. / Formel ist =WOCHENTAG($A33;2)=6Abc
B332. / Formel ist =WOCHENTAG($A33;2)=7Abc
B333. / Formel ist =VERGLEICH($A33;Feiertage;0)>0Abc
C331. / Formel ist =WOCHENTAG($A33;2)=6Abc
C332. / Formel ist =WOCHENTAG($A33;2)=7Abc
C333. / Formel ist =VERGLEICH($A33;Feiertage;0)>0Abc
A341. / Formel ist =WOCHENTAG($A34;2)=6Abc
A342. / Formel ist =WOCHENTAG($A34;2)=7Abc
A343. / Formel ist =VERGLEICH($A34;Feiertage;0)>0Abc
B341. / Formel ist =WOCHENTAG($A34;2)=6Abc
B342. / Formel ist =WOCHENTAG($A34;2)=7Abc
B343. / Formel ist =VERGLEICH($A34;Feiertage;0)>0Abc
C341. / Formel ist =WOCHENTAG($A34;2)=6Abc
C342. / Formel ist =WOCHENTAG($A34;2)=7Abc
C343. / Formel ist =VERGLEICH($A34;Feiertage;0)>0Abc
A351. / Formel ist =WOCHENTAG($A35;2)=6Abc
A352. / Formel ist =WOCHENTAG($A35;2)=7Abc
A353. / Formel ist =VERGLEICH($A35;Feiertage;0)>0Abc
B351. / Formel ist =WOCHENTAG($A35;2)=6Abc
B352. / Formel ist =WOCHENTAG($A35;2)=7Abc
B353. / Formel ist =VERGLEICH($A35;Feiertage;0)>0Abc
C351. / Formel ist =WOCHENTAG($A35;2)=6Abc
C352. / Formel ist =WOCHENTAG($A35;2)=7Abc
C353. / Formel ist =VERGLEICH($A35;Feiertage;0)>0Abc
A361. / Formel ist =WOCHENTAG($A36;2)=6Abc
A362. / Formel ist =WOCHENTAG($A36;2)=7Abc
A363. / Formel ist =VERGLEICH($A36;Feiertage;0)>0Abc
B361. / Formel ist =WOCHENTAG($A36;2)=6Abc
B362. / Formel ist =WOCHENTAG($A36;2)=7Abc
B363. / Formel ist =VERGLEICH($A36;Feiertage;0)>0Abc
C361. / Formel ist =WOCHENTAG($A36;2)=6Abc
C362. / Formel ist =WOCHENTAG($A36;2)=7Abc
C363. / Formel ist =VERGLEICH($A36;Feiertage;0)>0Abc
A371. / Formel ist =WOCHENTAG($A37;2)=6Abc
A372. / Formel ist =WOCHENTAG($A37;2)=7Abc
A373. / Formel ist =VERGLEICH($A37;Feiertage;0)>0Abc
B371. / Formel ist =WOCHENTAG($A37;2)=6Abc
B372. / Formel ist =WOCHENTAG($A37;2)=7Abc
B373. / Formel ist =VERGLEICH($A37;Feiertage;0)>0Abc
C371. / Formel ist =WOCHENTAG($A37;2)=6Abc
C372. / Formel ist =WOCHENTAG($A37;2)=7Abc
C373. / Formel ist =VERGLEICH($A37;Feiertage;0)>0Abc
A381. / Formel ist =WOCHENTAG($A38;2)=6Abc
A382. / Formel ist =WOCHENTAG($A38;2)=7Abc
A383. / Formel ist =VERGLEICH($A38;Feiertage;0)>0Abc
B381. / Formel ist =WOCHENTAG($A38;2)=6Abc
B382. / Formel ist =WOCHENTAG($A38;2)=7Abc
B383. / Formel ist =VERGLEICH($A38;Feiertage;0)>0Abc
C381. / Formel ist =WOCHENTAG($A38;2)=6Abc
C382. / Formel ist =WOCHENTAG($A38;2)=7Abc
C383. / Formel ist =VERGLEICH($A38;Feiertage;0)>0Abc
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  
cu jörg
Bild

Betrifft: korrektur
von: jockel
Geschrieben am: 16.12.2006 19:43:58
hi, sorry. ich habe gerade noch einen kleinen flüchtigkeitsfehler entdeckt: in A8 stand eine falsche formel... richtig muss es heißen =WENN(A5="";"";WENN(TEXT(DATUM($A$5;$B$6;ZEILE(A2));"MMMM")=$A$6;DATUM($A$5;$B$6;ZEILE(A2));"")) cu jörg
Bild

Betrifft: AW: korrektur zur korrektur...
von: jockel

Geschrieben am: 16.12.2006 19:50:23
... jetzt aber: ganz korrekt muss es heißen (in A8) =WENN(A7="";"";WENN(TEXT(DATUM($A$5;$B$6;ZEILE(A2));"MMMM")=$A$6;DATUM($A$5;$B$6;ZEILE(A2));""))
schau mal was passiert im februar bei schaltjahren... nun wird der (und nur der) jeweilige monat angezeigt. nicht ein tag mehr...
grüße an ALIBA aus dem excel-center.de
cu jörg
Bild

Betrifft: AW: Stundenberechnung
von: EtoPHG

Geschrieben am: 16.12.2006 22:24:44
Hallo Gunter,
Hier ist nun auch Dein neuester Wunsch erledigt und ...
zusätzlich der Flüchtigkeitsfehler (aus dem letzten Upload) mit den Wochentagen (Ab 2tem Tag stimmt Wochentag nicht mehr!) korrigiert.
https://www.herber.de/bbs/user/39053.xls
Kleine Frage nebenbei: Machst Du an der Datei auch mal was selber, oder lässt Du Dir hier im Forum so langsam einen eigenen Zeitplaner entwickeln ??
Gruss Hansueli
Bild

Betrifft: @Hansueli
von: jockel

Geschrieben am: 16.12.2006 22:39:54
hi Hansueli, ist das nicht letztlich egal? wenn Gunter, dabei was lernen kann, ist's doch okay! mal 'ne frage nebenbei: ist das beabsichtigt, dass z.b. im monat februar auch tage aus dem märz angezeigt werden? hatte ich gar nicht gelesen... siehe zellen A35:C37
cu jörg
Januar
 ABC
520062006Soll h
6Februar2160:00
701.02.2006Mi8:00
802.02.2006Do8:00
903.02.2006Fr8:00
1004.02.2006Sa0:00
1105.02.2006So0:00
1206.02.2006Mo8:00
1307.02.2006Di8:00
1408.02.2006Mi8:00
1509.02.2006Do8:00
1610.02.2006Fr8:00
1711.02.2006Sa0:00
1812.02.2006So0:00
1913.02.2006Mo8:00
2014.02.2006Di8:00
2115.02.2006Mi8:00
2216.02.2006Do8:00
2317.02.2006Fr8:00
2418.02.2006Sa0:00
2519.02.2006So0:00
2620.02.2006Mo8:00
2721.02.2006Di8:00
2822.02.2006Mi8:00
2923.02.2006Do8:00
3024.02.2006Fr8:00
3125.02.2006Sa0:00
3226.02.2006So0:00
3327.02.2006Mo8:00
3428.02.2006Di8:00
3501.03.2006Mi0:00
3602.03.2006Do0:00
3703.03.2006Fr0:00
Formeln der Tabelle
A5 : =B5
A6 : =DATUM(A5;B6;1)
C6 : =SUMME(C7:C37)
A7 : =DATUM(A5;B6;1)
B7 : =A7
C7 : =WENN(UND(WOCHENTAG( A7;2)<6;WENN(ISTFEHLER(VERGLEICH($A7;Feiertage;0));WAHR;FALSCH());MONAT(A7)=B$6);1/3;0)
A8 : =A7+1
B8 : =A8
C8 : =WENN(UND(WOCHENTAG( A8;2)<6;WENN(ISTFEHLER(VERGLEICH($A8;Feiertage;0));WAHR;FALSCH());MONAT(A8)=B$6);1/3;0)
A9 : =A8+1
B9 : =A9
C9 : =WENN(UND(WOCHENTAG( A9;2)<6;WENN(ISTFEHLER(VERGLEICH($A9;Feiertage;0));WAHR;FALSCH());MONAT(A9)=B$6);1/3;0)
A10 : =A9+1
B10 : =A10
C10 : =WENN(UND(WOCHENTAG( A10;2)<6;WENN(ISTFEHLER(VERGLEICH($A10;Feiertage;0));WAHR;FALSCH());MONAT(A10)=B$6);1/3;0)
A11 : =A10+1
B11 : =A11
C11 : =WENN(UND(WOCHENTAG( A11;2)<6;WENN(ISTFEHLER(VERGLEICH($A11;Feiertage;0));WAHR;FALSCH());MONAT(A11)=B$6);1/3;0)
A12 : =A11+1
B12 : =A12
C12 : =WENN(UND(WOCHENTAG( A12;2)<6;WENN(ISTFEHLER(VERGLEICH($A12;Feiertage;0));WAHR;FALSCH());MONAT(A12)=B$6);1/3;0)
A13 : =A12+1
B13 : =A13
C13 : =WENN(UND(WOCHENTAG( A13;2)<6;WENN(ISTFEHLER(VERGLEICH($A13;Feiertage;0));WAHR;FALSCH());MONAT(A13)=B$6);1/3;0)
A14 : =A13+1
B14 : =A14
C14 : =WENN(UND(WOCHENTAG( A14;2)<6;WENN(ISTFEHLER(VERGLEICH($A14;Feiertage;0));WAHR;FALSCH());MONAT(A14)=B$6);1/3;0)
A15 : =A14+1
B15 : =A15
C15 : =WENN(UND(WOCHENTAG( A15;2)<6;WENN(ISTFEHLER(VERGLEICH($A15;Feiertage;0));WAHR;FALSCH());MONAT(A15)=B$6);1/3;0)
A16 : =A15+1
B16 : =A16
C16 : =WENN(UND(WOCHENTAG( A16;2)<6;WENN(ISTFEHLER(VERGLEICH($A16;Feiertage;0));WAHR;FALSCH());MONAT(A16)=B$6);1/3;0)
A17 : =A16+1
B17 : =A17
C17 : =WENN(UND(WOCHENTAG( A17;2)<6;WENN(ISTFEHLER(VERGLEICH($A17;Feiertage;0));WAHR;FALSCH());MONAT(A17)=B$6);1/3;0)
A18 : =A17+1
B18 : =A18
C18 : =WENN(UND(WOCHENTAG( A18;2)<6;WENN(ISTFEHLER(VERGLEICH($A18;Feiertage;0));WAHR;FALSCH());MONAT(A18)=B$6);1/3;0)
A19 : =A18+1
B19 : =A19
C19 : =WENN(UND(WOCHENTAG( A19;2)<6;WENN(ISTFEHLER(VERGLEICH($A19;Feiertage;0));WAHR;FALSCH());MONAT(A19)=B$6);1/3;0)
A20 : =A19+1
B20 : =A20
C20 : =WENN(UND(WOCHENTAG( A20;2)<6;WENN(ISTFEHLER(VERGLEICH($A20;Feiertage;0));WAHR;FALSCH());MONAT(A20)=B$6);1/3;0)
A21 : =A20+1
B21 : =A21
C21 : =WENN(UND(WOCHENTAG( A21;2)<6;WENN(ISTFEHLER(VERGLEICH($A21;Feiertage;0));WAHR;FALSCH());MONAT(A21)=B$6);1/3;0)
A22 : =A21+1
B22 : =A22
C22 : =WENN(UND(WOCHENTAG( A22;2)<6;WENN(ISTFEHLER(VERGLEICH($A22;Feiertage;0));WAHR;FALSCH());MONAT(A22)=B$6);1/3;0)
A23 : =A22+1
B23 : =A23
C23 : =WENN(UND(WOCHENTAG( A23;2)<6;WENN(ISTFEHLER(VERGLEICH($A23;Feiertage;0));WAHR;FALSCH());MONAT(A23)=B$6);1/3;0)
A24 : =A23+1
B24 : =A24
C24 : =WENN(UND(WOCHENTAG( A24;2)<6;WENN(ISTFEHLER(VERGLEICH($A24;Feiertage;0));WAHR;FALSCH());MONAT(A24)=B$6);1/3;0)
A25 : =A24+1
B25 : =A25
C25 : =WENN(UND(WOCHENTAG( A25;2)<6;WENN(ISTFEHLER(VERGLEICH($A25;Feiertage;0));WAHR;FALSCH());MONAT(A25)=B$6);1/3;0)
A26 : =A25+1
B26 : =A26
C26 : =WENN(UND(WOCHENTAG( A26;2)<6;WENN(ISTFEHLER(VERGLEICH($A26;Feiertage;0));WAHR;FALSCH());MONAT(A26)=B$6);1/3;0)
A27 : =A26+1
B27 : =A27
C27 : =WENN(UND(WOCHENTAG( A27;2)<6;WENN(ISTFEHLER(VERGLEICH($A27;Feiertage;0));WAHR;FALSCH());MONAT(A27)=B$6);1/3;0)
A28 : =A27+1
B28 : =A28
C28 : =WENN(UND(WOCHENTAG( A28;2)<6;WENN(ISTFEHLER(VERGLEICH($A28;Feiertage;0));WAHR;FALSCH());MONAT(A28)=B$6);1/3;0)
A29 : =A28+1
B29 : =A29
C29 : =WENN(UND(WOCHENTAG( A29;2)<6;WENN(ISTFEHLER(VERGLEICH($A29;Feiertage;0));WAHR;FALSCH());MONAT(A29)=B$6);1/3;0)
A30 : =A29+1
B30 : =A30
C30 : =WENN(UND(WOCHENTAG( A30;2)<6;WENN(ISTFEHLER(VERGLEICH($A30;Feiertage;0));WAHR;FALSCH());MONAT(A30)=B$6);1/3;0)
A31 : =A30+1
B31 : =A31
C31 : =WENN(UND(WOCHENTAG( A31;2)<6;WENN(ISTFEHLER(VERGLEICH($A31;Feiertage;0));WAHR;FALSCH());MONAT(A31)=B$6);1/3;0)
A32 : =A31+1
B32 : =A32
C32 : =WENN(UND(WOCHENTAG( A32;2)<6;WENN(ISTFEHLER(VERGLEICH($A32;Feiertage;0));WAHR;FALSCH());MONAT(A32)=B$6);1/3;0)
A33 : =A32+1
B33 : =A33
C33 : =WENN(UND(WOCHENTAG( A33;2)<6;WENN(ISTFEHLER(VERGLEICH($A33;Feiertage;0));WAHR;FALSCH());MONAT(A33)=B$6);1/3;0)
A34 : =A33+1
B34 : =A34
C34 : =WENN(UND(WOCHENTAG( A34;2)<6;WENN(ISTFEHLER(VERGLEICH($A34;Feiertage;0));WAHR;FALSCH());MONAT(A34)=B$6);1/3;0)
A35 : =A34+1
B35 : =A35
C35 : =WENN(UND(WOCHENTAG( A35;2)<6;WENN(ISTFEHLER(VERGLEICH($A35;Feiertage;0));WAHR;FALSCH());MONAT(A35)=B$6);1/3;0)
A36 : =A35+1
B36 : =A36
C36 : =WENN(UND(WOCHENTAG( A36;2)<6;WENN(ISTFEHLER(VERGLEICH($A36;Feiertage;0));WAHR;FALSCH());MONAT(A36)=B$6);1/3;0)
A37 : =A36+1
B37 : =A37
C37 : =WENN(UND(WOCHENTAG( A37;2)<6;WENN(ISTFEHLER(VERGLEICH($A37;Feiertage;0));WAHR;FALSCH());MONAT(A37)=B$6);1/3;0)
Bedingte Formatierungen der Tabelle
ZelleNr.: / BedingungFormat
A71. / Formel ist =WOCHENTAG($A7;2)=6Abc
A72. / Formel ist =WOCHENTAG($A7;2)=7Abc
A73. / Formel ist =VERGLEICH($A7;Feiertage;0)>0Abc
B71. / Formel ist =WOCHENTAG($A7;2)=6Abc
B72. / Formel ist =WOCHENTAG($A7;2)=7Abc
B73. / Formel ist =VERGLEICH($A7;Feiertage;0)>0Abc
A81. / Formel ist =WOCHENTAG($A8;2)=6Abc
A82. / Formel ist =WOCHENTAG($A8;2)=7Abc
A83. / Formel ist =VERGLEICH($A8;Feiertage;0)>0Abc
B81. / Formel ist =WOCHENTAG($A8;2)=6Abc
B82. / Formel ist =WOCHENTAG($A8;2)=7Abc
B83. / Formel ist =VERGLEICH($A8;Feiertage;0)>0Abc
A91. / Formel ist =WOCHENTAG($A9;2)=6Abc
A92. / Formel ist =WOCHENTAG($A9;2)=7Abc
A93. / Formel ist =VERGLEICH($A9;Feiertage;0)>0Abc
B91. / Formel ist =WOCHENTAG($A9;2)=6Abc
B92. / Formel ist =WOCHENTAG($A9;2)=7Abc
B93. / Formel ist =VERGLEICH($A9;Feiertage;0)>0Abc
A101. / Formel ist =WOCHENTAG($A10;2)=6Abc
A102. / Formel ist =WOCHENTAG($A10;2)=7Abc
A103. / Formel ist =VERGLEICH($A10;Feiertage;0)>0Abc
B101. / Formel ist =WOCHENTAG($A10;2)=6Abc
B102. / Formel ist =WOCHENTAG($A10;2)=7Abc
B103. / Formel ist =VERGLEICH($A10;Feiertage;0)>0Abc
A111. / Formel ist =WOCHENTAG($A11;2)=6Abc
A112. / Formel ist =WOCHENTAG($A11;2)=7Abc
A113. / Formel ist =VERGLEICH($A11;Feiertage;0)>0Abc
B111. / Formel ist =WOCHENTAG($A11;2)=6Abc
B112. / Formel ist =WOCHENTAG($A11;2)=7Abc
B113. / Formel ist =VERGLEICH($A11;Feiertage;0)>0Abc
A121. / Formel ist =WOCHENTAG($A12;2)=6Abc
A122. / Formel ist =WOCHENTAG($A12;2)=7Abc
A123. / Formel ist =VERGLEICH($A12;Feiertage;0)>0Abc
B121. / Formel ist =WOCHENTAG($A12;2)=6Abc
B122. / Formel ist =WOCHENTAG($A12;2)=7Abc
B123. / Formel ist =VERGLEICH($A12;Feiertage;0)>0Abc
A131. / Formel ist =WOCHENTAG($A13;2)=6Abc
A132. / Formel ist =WOCHENTAG($A13;2)=7Abc
A133. / Formel ist =VERGLEICH($A13;Feiertage;0)>0Abc
B131. / Formel ist =WOCHENTAG($A13;2)=6Abc
B132. / Formel ist =WOCHENTAG($A13;2)=7Abc
B133. / Formel ist =VERGLEICH($A13;Feiertage;0)>0Abc
A141. / Formel ist =WOCHENTAG($A14;2)=6Abc
A142. / Formel ist =WOCHENTAG($A14;2)=7Abc
A143. / Formel ist =VERGLEICH($A14;Feiertage;0)>0Abc
B141. / Formel ist =WOCHENTAG($A14;2)=6Abc
B142. / Formel ist =WOCHENTAG($A14;2)=7Abc
B143. / Formel ist =VERGLEICH($A14;Feiertage;0)>0Abc
A151. / Formel ist =WOCHENTAG($A15;2)=6Abc
A152. / Formel ist =WOCHENTAG($A15;2)=7Abc
A153. / Formel ist =VERGLEICH($A15;Feiertage;0)>0Abc
B151. / Formel ist =WOCHENTAG($A15;2)=6Abc
B152. / Formel ist =WOCHENTAG($A15;2)=7Abc
B153. / Formel ist =VERGLEICH($A15;Feiertage;0)>0Abc
A161. / Formel ist =WOCHENTAG($A16;2)=6Abc
A162. / Formel ist =WOCHENTAG($A16;2)=7Abc
A163. / Formel ist =VERGLEICH($A16;Feiertage;0)>0Abc
B161. / Formel ist =WOCHENTAG($A16;2)=6Abc
B162. / Formel ist =WOCHENTAG($A16;2)=7Abc
B163. / Formel ist =VERGLEICH($A16;Feiertage;0)>0Abc
A171. / Formel ist =WOCHENTAG($A17;2)=6Abc
A172. / Formel ist =WOCHENTAG($A17;2)=7Abc
A173. / Formel ist =VERGLEICH($A17;Feiertage;0)>0Abc
B171. / Formel ist =WOCHENTAG($A17;2)=6Abc
B172. / Formel ist =WOCHENTAG($A17;2)=7Abc
B173. / Formel ist =VERGLEICH($A17;Feiertage;0)>0Abc
A181. / Formel ist =WOCHENTAG($A18;2)=6Abc
A182. / Formel ist =WOCHENTAG($A18;2)=7Abc
A183. / Formel ist =VERGLEICH($A18;Feiertage;0)>0Abc
B181. / Formel ist =WOCHENTAG($A18;2)=6Abc
B182. / Formel ist =WOCHENTAG($A18;2)=7Abc
B183. / Formel ist =VERGLEICH($A18;Feiertage;0)>0Abc
A191. / Formel ist =WOCHENTAG($A19;2)=6Abc
A192. / Formel ist =WOCHENTAG($A19;2)=7Abc
A193. / Formel ist =VERGLEICH($A19;Feiertage;0)>0Abc
B191. / Formel ist =WOCHENTAG($A19;2)=6Abc
B192. / Formel ist =WOCHENTAG($A19;2)=7Abc
B193. / Formel ist =VERGLEICH($A19;Feiertage;0)>0Abc
A201. / Formel ist =WOCHENTAG($A20;2)=6Abc
A202. / Formel ist =WOCHENTAG($A20;2)=7Abc
A203. / Formel ist =VERGLEICH($A20;Feiertage;0)>0Abc
B201. / Formel ist =WOCHENTAG($A20;2)=6Abc
B202. / Formel ist =WOCHENTAG($A20;2)=7Abc
B203. / Formel ist =VERGLEICH($A20;Feiertage;0)>0Abc
A211. / Formel ist =WOCHENTAG($A21;2)=6Abc
A212. / Formel ist =WOCHENTAG($A21;2)=7Abc
A213. / Formel ist =VERGLEICH($A21;Feiertage;0)>0Abc
B211. / Formel ist =WOCHENTAG($A21;2)=6Abc
B212. / Formel ist =WOCHENTAG($A21;2)=7Abc
B213. / Formel ist =VERGLEICH($A21;Feiertage;0)>0Abc
A221. / Formel ist =WOCHENTAG($A22;2)=6Abc
A222. / Formel ist =WOCHENTAG($A22;2)=7Abc
A223. / Formel ist =VERGLEICH($A22;Feiertage;0)>0Abc
B221. / Formel ist =WOCHENTAG($A22;2)=6Abc
B222. / Formel ist =WOCHENTAG($A22;2)=7Abc
B223. / Formel ist =VERGLEICH($A22;Feiertage;0)>0Abc
A231. / Formel ist =WOCHENTAG($A23;2)=6Abc
A232. / Formel ist =WOCHENTAG($A23;2)=7Abc
A233. / Formel ist =VERGLEICH($A23;Feiertage;0)>0Abc
B231. / Formel ist =WOCHENTAG($A23;2)=6Abc
B232. / Formel ist =WOCHENTAG($A23;2)=7Abc
B233. / Formel ist =VERGLEICH($A23;Feiertage;0)>0Abc
A241. / Formel ist =WOCHENTAG($A24;2)=6Abc
A242. / Formel ist =WOCHENTAG($A24;2)=7Abc
A243. / Formel ist =VERGLEICH($A24;Feiertage;0)>0Abc
B241. / Formel ist =WOCHENTAG($A24;2)=6Abc
B242. / Formel ist =WOCHENTAG($A24;2)=7Abc
B243. / Formel ist =VERGLEICH($A24;Feiertage;0)>0Abc
A251. / Formel ist =WOCHENTAG($A25;2)=6Abc
A252. / Formel ist =WOCHENTAG($A25;2)=7Abc
A253. / Formel ist =VERGLEICH($A25;Feiertage;0)>0Abc
B251. / Formel ist =WOCHENTAG($A25;2)=6Abc
B252. / Formel ist =WOCHENTAG($A25;2)=7Abc
B253. / Formel ist =VERGLEICH($A25;Feiertage;0)>0Abc
A261. / Formel ist =WOCHENTAG($A26;2)=6Abc
A262. / Formel ist =WOCHENTAG($A26;2)=7Abc
A263. / Formel ist =VERGLEICH($A26;Feiertage;0)>0Abc
B261. / Formel ist =WOCHENTAG($A26;2)=6Abc
B262. / Formel ist =WOCHENTAG($A26;2)=7Abc
B263. / Formel ist =VERGLEICH($A26;Feiertage;0)>0Abc
A271. / Formel ist =WOCHENTAG($A27;2)=6Abc
A272. / Formel ist =WOCHENTAG($A27;2)=7Abc
A273. / Formel ist =VERGLEICH($A27;Feiertage;0)>0Abc
B271. / Formel ist =WOCHENTAG($A27;2)=6Abc
B272. / Formel ist =WOCHENTAG($A27;2)=7Abc
B273. / Formel ist =VERGLEICH($A27;Feiertage;0)>0Abc
A281. / Formel ist =WOCHENTAG($A28;2)=6Abc
A282. / Formel ist =WOCHENTAG($A28;2)=7Abc
A283. / Formel ist =VERGLEICH($A28;Feiertage;0)>0Abc
B281. / Formel ist =WOCHENTAG($A28;2)=6Abc
B282. / Formel ist =WOCHENTAG($A28;2)=7Abc
B283. / Formel ist =VERGLEICH($A28;Feiertage;0)>0Abc
A291. / Formel ist =WOCHENTAG($A29;2)=6Abc
A292. / Formel ist =WOCHENTAG($A29;2)=7Abc
A293. / Formel ist =VERGLEICH($A29;Feiertage;0)>0Abc
B291. / Formel ist =WOCHENTAG($A29;2)=6Abc
B292. / Formel ist =WOCHENTAG($A29;2)=7Abc
B293. / Formel ist =VERGLEICH($A29;Feiertage;0)>0Abc
A301. / Formel ist =WOCHENTAG($A30;2)=6Abc
A302. / Formel ist =WOCHENTAG($A30;2)=7Abc
A303. / Formel ist =VERGLEICH($A30;Feiertage;0)>0Abc
B301. / Formel ist =WOCHENTAG($A30;2)=6Abc
B302. / Formel ist =WOCHENTAG($A30;2)=7Abc
B303. / Formel ist =VERGLEICH($A30;Feiertage;0)>0Abc
A311. / Formel ist =WOCHENTAG($A31;2)=6Abc
A312. / Formel ist =WOCHENTAG($A31;2)=7Abc
A313. / Formel ist =VERGLEICH($A31;Feiertage;0)>0Abc
B311. / Formel ist =WOCHENTAG($A31;2)=6Abc
B312. / Formel ist =WOCHENTAG($A31;2)=7Abc
B313. / Formel ist =VERGLEICH($A31;Feiertage;0)>0Abc
A321. / Formel ist =WOCHENTAG($A32;2)=6Abc
A322. / Formel ist =WOCHENTAG($A32;2)=7Abc
A323. / Formel ist =VERGLEICH($A32;Feiertage;0)>0Abc
B321. / Formel ist =WOCHENTAG($A32;2)=6Abc
B322. / Formel ist =WOCHENTAG($A32;2)=7Abc
B323. / Formel ist =VERGLEICH($A32;Feiertage;0)>0Abc
A331. / Formel ist =WOCHENTAG($A33;2)=6Abc
A332. / Formel ist =WOCHENTAG($A33;2)=7Abc
A333. / Formel ist =VERGLEICH($A33;Feiertage;0)>0Abc
B331. / Formel ist =WOCHENTAG($A33;2)=6Abc
B332. / Formel ist =WOCHENTAG($A33;2)=7Abc
B333. / Formel ist =VERGLEICH($A33;Feiertage;0)>0Abc
A341. / Formel ist =WOCHENTAG($A34;2)=6Abc
A342. / Formel ist =WOCHENTAG($A34;2)=7Abc
A343. / Formel ist =VERGLEICH($A34;Feiertage;0)>0Abc
B341. / Formel ist =WOCHENTAG($A34;2)=6Abc
B342. / Formel ist =WOCHENTAG($A34;2)=7Abc
B343. / Formel ist =VERGLEICH($A34;Feiertage;0)>0Abc
A351. / Formel ist =WOCHENTAG($A35;2)=6Abc
A352. / Formel ist =WOCHENTAG($A35;2)=7Abc
A353. / Formel ist =VERGLEICH($A35;Feiertage;0)>0Abc
B351. / Formel ist =WOCHENTAG($A35;2)=6Abc
B352. / Formel ist =WOCHENTAG($A35;2)=7Abc
B353. / Formel ist =VERGLEICH($A35;Feiertage;0)>0Abc
A361. / Formel ist =WOCHENTAG($A36;2)=6Abc
A362. / Formel ist =WOCHENTAG($A36;2)=7Abc
A363. / Formel ist =VERGLEICH($A36;Feiertage;0)>0Abc
B361. / Formel ist =WOCHENTAG($A36;2)=6Abc
B362. / Formel ist =WOCHENTAG($A36;2)=7Abc
B363. / Formel ist =VERGLEICH($A36;Feiertage;0)>0Abc
A371. / Formel ist =WOCHENTAG($A37;2)=6Abc
A372. / Formel ist =WOCHENTAG($A37;2)=7Abc
A373. / Formel ist =VERGLEICH($A37;Feiertage;0)>0Abc
B371. / Formel ist =WOCHENTAG($A37;2)=6Abc
B372. / Formel ist =WOCHENTAG($A37;2)=7Abc
B373. / Formel ist =VERGLEICH($A37;Feiertage;0)>0Abc
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  
Bild

Betrifft: AW: @Jörg
von: EtoPHG

Geschrieben am: 16.12.2006 23:29:06
Hallo Jörg,
Na, ja so egal find ich das nicht. Learning by doing ziehe ich eben Learning by downloading vor.
Immerhin bezeichnet sich Gunter mit Excel gut. Da dürfte man doch erwarten, das von einem zum andern mal auch mal eine Formel oder sowas angepasst wird. Bis jetzt habe ich aber nur das Wechseln von Farben mitbekommen...
Siehste, genau Deine Frage ist doch so ein Problemchen, das man mit ein bisschen probieren und experimentieren leicht lösen kann...
Gruss Hansueli
Bild

Betrifft: AW: @Hansueli
von: jockel
Geschrieben am: 16.12.2006 23:35:58
hi Hansueli, ich schaue hier nur sporadisch rein, sodass ich mir da kein rechtes bild machen kann. aber nimm' meine meinung nicht gar persönlich, okay? dir und allen anderen morgen noch einen schönen dritten advent. cu jörg
Bild

Betrifft: AW: @Jörg
von: EtoPHG
Geschrieben am: 16.12.2006 23:50:25
Jörg,
Kein Problem damit...
Gruss Hansueli
Bild

Betrifft: AW: @Hansueli
von: ottgunter@t-online.de

Geschrieben am: 17.12.2006 09:00:03
Hallo
Ich möchte mich recht herzlich für die superhilfe bedanken.
Ist mir auch noch garnicht aufgefallen, das z.B im Februar Märzdaten vorhanden sind.
Das soll natürlich nicht sein.Ich werd mal schauen, ob ich das geändert bekomme.
Ich wünsche euch allen ein schönes Wochenende ein frohes Weihnachtsfest bzw. alles gute im neuen Jahr.
Bild

Betrifft: @ottgunter@t-online.de
von: jockel
Geschrieben am: 17.12.2006 10:48:31
hi Gunter, in meinem beitrag hatte ich das eingearbeitet...
Bild

Betrifft: ... letzte neuigkeiten
von: EtoPHG

Geschrieben am: 17.12.2006 11:17:15
Hallo zusammen,
Um die Tage am Ende, die nicht zum Monat gehören, zum Verschwinden zu bringen, genügt es ab dem 29ten Tag die Formeln zu ändern, denn mir sind keine Monate mit weniger als 28 Tage bekannt ;-)
https://www.herber.de/bbs/user/39059.xls
Gruss Hansueli
Bild

Betrifft: ... zu guter letzt @Hansueli...
von: jockel
Geschrieben am: 17.12.2006 12:32:12
hi Hansueli, wo du recht hast, hast du recht. vielen dank für diesen thread! cu jörg
 Bild