Herbers Excel-Forum - das Archiv

Zelle abfragen

Bild

Betrifft: Zelle abfragen
von: Gerhard

Geschrieben am: 04.01.2007 21:48:15
Hallo zusammen und ein gutes neues Jahr wünsche ich Euch!
Wie kann ich via Formel oder als Makro den Inhalt der Spalte B abfragen und als Ergebnis in Spalte C darstellen?
Beispiel:
Die Zelle B2 ist Leer dann sollte als Anzeige in Zelle C2 das Zeichen Wingdings 251 in der Farbe rot in Schriftgröße 12 dargestellt werden.
Wenn in der Zelle B2 etwas eingetragen ist dann sollte in der Zelle C2 das Zeichen Wingdings 252 in der Farbe grün in Schriftgröße 12 dargestellt werden.
Vielen Dank für Eure Hilfe
Gruß
Gerhard
Bild

Betrifft: AW: Zelle abfragen
von: Ramses

Geschrieben am: 04.01.2007 22:01:09
Hallo
meinst du so ?
Tabelle2

 ABC
1 Textü
2  û
3   

Formeln der Tabelle
ZelleFormel
C1=WENN(ISTLEER(B1);"û";"ü")
C2=WENN(ISTLEER(B2);"û";"ü")

Bedingte Formatierungen der Tabelle
ZelleNr.: / BedingungFormat
C11. / Formel ist =B1 =""Abc
C12. / Formel ist =B1<>""Abc
C21. / Formel ist =B2 =""Abc
C22. / Formel ist =B2<>""Abc

Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML    Download  
Spalte C mit Schriftart Wingdings formatiert.
Die Zeichen werden mit der Jeannie nicht korrekt dargestellt, aber die Formel funktioniert.
Gruss Rainer
Bild

Betrifft: AW: Zelle abfragen
von: Uduuh
Geschrieben am: 04.01.2007 22:02:01
Hallo,
ganz einfach mit einer Wenn und bedingte Formatierung
=wenn(B2="";zeichen(251);zeichen(252)
Zelle in Wingdings formatieren und entsprechende bedingte Foratierung definieren.
Gruß aus’m Pott
Udo

Bild

Betrifft: AW: Zelle abfragen
von: Gerhard
Geschrieben am: 04.01.2007 22:28:26
Hallo zusammen,
vielen Dank für die schnelle Hilfe
funktioniert prima.
Gruß
Gerhard
Bild

Betrifft: AW: Zelle abfragen
von: chris b
Geschrieben am: 04.01.2007 22:02:35
Hallo ich glaube wenn ich dich richtig verstanden habe sollte dir das helfen.
Formel eintragen in Zelle C2
Und die Zelle Formatieren also Schriftart Wingdings
=WENN(B2="";"251";"252")
gruß Chris
Bild

Betrifft: AW: Zelle abfragen
von: Mustafa

Geschrieben am: 04.01.2007 22:05:13
Hallo Gerhard,
Formatiere die Zelle C2 mit der Schriftart Wingdings und schreibe die Formel hinein:
=WENN(B2="";ZEICHEN(251);ZEICHEN(252))
Danach über Format > Bedingte Formatierung die Bedingungen für die Bedingte Formatierung so formulieren:
Bedingung 1:
Formel ist
=$B$2=""
Format Schriftfarbe rot
Bedingung 2:
Formel ist
=$B$2<>""
Format Schriftfarbe Grün
Rückmeldung obs Hilft wäre nett.
Viele Grüße aus Köln.
 Bild
Excel-Beispiele zum Thema "Zelle abfragen"
Unterdrückung von Sicherheitsabfragen Name der aufrufenden Schaltfläche abfragen
Anzahl der einzufügenden Zeilen abfragen Start- und Enddatum abfragen und markieren
Passwort vergeben und bei CheckBox-Aktivität abfragen Werte von CheckBoxes in einer UserForm abfragen
Mit InputBoxes Zeilennummern abfragen und Summe bilden Suchbegriff über InputBox abfragen und Fundzeile löschen
Druckstart- und endzeilen über InputBox abfragen Beim Öffnen der Arbeitsmappe Passwort abfragen