Microsoft Excel

Herbers Excel/VBA-Archiv

anzahl mit einer bekannten und einer unbekannten

Betrifft: anzahl mit einer bekannten und einer unbekannten von: Harry
Geschrieben am: 09.10.2007 21:44:58

Ich habe folgendes Problem,

ich müsste in Tabelle2 die anzahl von kunden in Tabelle1 zählen, wobei diese kunden in gewissen touren und bis zu 30 40 Artikel bestellen können.
In tabelle2 müsste ich diese auf die diversen touren zuordnen.

Tour Kunde Artikel
1101 11111 1
1101 11111 2
1101 11111 3
1101 11112 2
1101 11112 5
1101 11113 1
1101 11113 2

  

Betrifft: AW: anzahl mit einer bekannten und einer unbekannten von: Hajo_Zi
Geschrieben am: 09.10.2007 21:56:14

Hallo Harry,

ich interpretiere es mal so das Du die unterschiedlichen Kunden-Nr. haben willst.

Tabelle1

 GHIJ
1TourKundeArtikelKunden
2110111111111111
3110111111211112
4110111111311113
51101111122 
61101111125 
71101111131 
81101111132 

Formeln der Tabelle
ZelleFormel
J2=H2
J3{=WENN(ODER(MIN(WENN(H3:$H$300>MAX(I2:$N2); WENN(H3:$H$300<>0;WENN(H3:$H$300<>"";H3:$H$300))))=0;J2=""); "";MIN(WENN(H3:$H$300>MAX(I2:$N2); WENN(H3:$H$300<>0;WENN(H3:$H$300<>"";H3:$H$300)))))}
J4{=WENN(ODER(MIN(WENN(H4:$H$300>MAX(I3:$N3); WENN(H4:$H$300<>0;WENN(H4:$H$300<>"";H4:$H$300))))=0;J3=""); "";MIN(WENN(H4:$H$300>MAX(I3:$N3); WENN(H4:$H$300<>0;WENN(H4:$H$300<>"";H4:$H$300)))))}
J5{=WENN(ODER(MIN(WENN(H5:$H$300>MAX(I4:$N4); WENN(H5:$H$300<>0;WENN(H5:$H$300<>"";H5:$H$300))))=0;J4=""); "";MIN(WENN(H5:$H$300>MAX(I4:$N4); WENN(H5:$H$300<>0;WENN(H5:$H$300<>"";H5:$H$300)))))}
J6{=WENN(ODER(MIN(WENN(H6:$H$300>MAX(I5:$N5); WENN(H6:$H$300<>0;WENN(H6:$H$300<>"";H6:$H$300))))=0;J5=""); "";MIN(WENN(H6:$H$300>MAX(I5:$N5); WENN(H6:$H$300<>0;WENN(H6:$H$300<>"";H6:$H$300)))))}
J7{=WENN(ODER(MIN(WENN(H7:$H$300>MAX(I6:$N6); WENN(H7:$H$300<>0;WENN(H7:$H$300<>"";H7:$H$300))))=0;J6=""); "";MIN(WENN(H7:$H$300>MAX(I6:$N6); WENN(H7:$H$300<>0;WENN(H7:$H$300<>"";H7:$H$300)))))}
J8{=WENN(ODER(MIN(WENN(H8:$H$300>MAX(I7:$N7); WENN(H8:$H$300<>0;WENN(H8:$H$300<>"";H8:$H$300))))=0;J7=""); "";MIN(WENN(H8:$H$300>MAX(I7:$N7); WENN(H8:$H$300<>0;WENN(H8:$H$300<>"";H8:$H$300)))))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

GrußformelHomepage


  

Betrifft: AW: anzahl mit einer bekannten und einer unbekannten von: Harry
Geschrieben am: 09.10.2007 22:15:54

Danke für die rasche Antwort,
aber ich brauche lediglich die anzahl der kunden pro Tour.


  

Betrifft: Anzahl unterschiedlicher Kunden von: WF
Geschrieben am: 09.10.2007 22:33:24

Hi,

folgende Arrayformel:
{=SUMME(WENN(B2:B99="";0;(1/ZÄHLENWENN(B2:B99;B2:B99))))}

Salut WF


  

Betrifft: AW: anzahl mit einer bekannten und einer unbekannten von: Christian
Geschrieben am: 09.10.2007 22:33:56

Hallo Harry,

als Ansatz:

Tabelle3

 ABCDEF
1TourKundeArtikel TourKunden
21101111111 11013
31101111112   
41101111113   
51101111122   
61101111125   
71101111131   
81101111132   
9      

Formeln der Tabelle
ZelleFormel
F2=SUMMENPRODUKT((VERGLEICH(A2:A100&B2:B100;A2:A100&B2:B100;0)=ZEILE(1:99))*(A2:A100=E2))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

MfG Christian


  

Betrifft: AW: anzahl mit einer bekannten und einer unbekannten von: Harry
Geschrieben am: 09.10.2007 23:19:48

Danke Christian dies war ein super tipp.

einziges manko die lange rechenzeit, sind ja doch ca. 48000 zeilen zum berechnen.


  

Betrifft: Anzahl der Kunden je Tour und Auflistung von: FP
Geschrieben am: 09.10.2007 23:19:00

Hallo Harry,

Tabelle3
 ABCD
1Tour100200300
2Anz5 3 2
3Ku #110 15 35
4Ku #220 25 70
5Ku #330 60  
6Ku #440   
7Ku #550   
8Ku #6   
Formeln der Tabelle
B1 : =MIN(Tabelle1!A:A)
C1 : =KKLEINSTE(Tabelle1!$A:$A;HÄUFIGKEIT(Tabelle1!$A:$A;B1)+1)
D1 : =KKLEINSTE(Tabelle1!$A:$A;HÄUFIGKEIT(Tabelle1!$A:$A;C1)+1)
B2 : =SUMME(N(HÄUFIGKEIT((Tabelle1!$A2:$A999=B1)*Tabelle1!$B2:$B999;(Tabelle1!$A2:$A999=B1)*Tabelle1!$B2:$B999)>0))-1
C2 : =SUMME(N(HÄUFIGKEIT((Tabelle1!$A2:$A999=C1)*Tabelle1!$B2:$B999;(Tabelle1!$A2:$A999=C1)*Tabelle1!$B2:$B999)>0))-1
D2 : =SUMME(N(HÄUFIGKEIT((Tabelle1!$A2:$A999=D1)*Tabelle1!$B2:$B999;(Tabelle1!$A2:$A999=D1)*Tabelle1!$B2:$B999)>0))-1
B3 : {=MIN(WENN(Tabelle1!$A2:$A999=B$1;Tabelle1!$B$2:$B$999))}
C3 : {=MIN(WENN(Tabelle1!$A2:$A999=C$1;Tabelle1!$B$2:$B$999))}
D3 : {=MIN(WENN(Tabelle1!$A2:$A999=D$1;Tabelle1!$B$2:$B$999))}
B4 : {=WENN(ZEILE(B2)>B$2;"";KKLEINSTE(WENN(Tabelle1!$A$2:$A$999=B$1;Tabelle1!$B$2:$B$999); HÄUFIGKEIT(WENN(Tabelle1!$A$2:$A$999=B$1;Tabelle1!$B$2:$B$999); B3)+1))}
C4 : {=WENN(ZEILE(C2)>C$2;"";KKLEINSTE(WENN(Tabelle1!$A$2:$A$999=C$1;Tabelle1!$B$2:$B$999); HÄUFIGKEIT(WENN(Tabelle1!$A$2:$A$999=C$1;Tabelle1!$B$2:$B$999); C3)+1))}
D4 : {=WENN(ZEILE(D2)>D$2;"";KKLEINSTE(WENN(Tabelle1!$A$2:$A$999=D$1;Tabelle1!$B$2:$B$999); HÄUFIGKEIT(WENN(Tabelle1!$A$2:$A$999=D$1;Tabelle1!$B$2:$B$999); D3)+1))}

Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  


Formeln aus Zeile 4 nach unten kopieren - falls Du die Auflistung der Kunden benötigst

Die Daten müssen dabei nicht sortiert vorliegen.

Es darf höchstens 255 Touren geben - ausser Du hast Office2007

Servus aus dem Salzkammergut
Franz


 

Beiträge aus den Excel-Beispielen zum Thema "anzahl mit einer bekannten und einer unbekannten"