Microsoft Excel

Herbers Excel/VBA-Archiv

Bestimmtes Ereignis in Spalte zählen

Betrifft: Bestimmtes Ereignis in Spalte zählen von: Born
Geschrieben am: 11.04.2008 16:23:48

Hallo und guten Tag,

ich habe diese Formel schon mal in einer Tabelle aber finde sie nicht mehr.
Und irgendwann wird die Sucherei einfach nervig. Deshalb erlaube ich mir
die Frage:

Wie zähle ich den Wechsel von irgendeiner positiven Zahl zu -1 in einer Spalte?

In folgendem Beispiel wäre das Ergebnis 2, weil der Wechsel zweimal vorkommt:

4
26
3
17
-1
-1
-1
-1
25
60
34
27
-1
-1
28
26
77
88

Danke, ufff,

Born

  

Betrifft: AW: Bestimmtes Ereignis in Spalte zählen von: UweD
Geschrieben am: 11.04.2008 16:58:40

Hallo

mit Hilfsspalte so...


 
 AB
14 
2260
330
4170
5-11
6-10
7-10
8-10
9250
10600
11340
12270
13-11
14-10
15280
16260
17770
18880
19  
20Summe2
Formeln der Tabelle
B2 : =(A1>0)*(A2=-1)
B20 : =SUMME(B1:B18)
 





Formel nach unten kopieren.


Gruß UD


  

Betrifft: Das geht auch mit Matrix, aber wie? von: Born
Geschrieben am: 11.04.2008 17:14:44

Hallo Uwe,
ja und danke. Aber da gibts eine (einfache) Matrixformel, mit der
das auch geht. Die such ich...

Danke,

Born


  

Betrifft: AW: Bestimmtes Ereignis in Spalte zählen von: Christian
Geschrieben am: 11.04.2008 17:02:16

Hallo Born,

als Ansatz:

Tabelle1

 ABC
14 3
226  
33  
417  
5-1  
6-1  
7-1  
8-1  
925  
1060  
1134  
1227  
13-1  
14-1  
1528  
1626  
1777  
1888  
19-1  

Formeln der Tabelle
ZelleFormel
C1{=SUMME((A1:A100>0)*(A2:A101=-1))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

MfG nach Berlin
Christian


  

Betrifft: AW: Bestimmtes Ereignis in Spalte zählen von: Born
Geschrieben am: 11.04.2008 17:32:41

Hallo Ranger,

ich hatte gehofft, daß Du irgendwo da draußen druch die Nacht reitest
und meinen Hilferuf hören würdest.

Im Ernst: Schön von dir zu hören, lesen. Und natürlich wars mal
wieder genau das, was ich gebraucht habe. Danke,

Born


 

Beiträge aus den Excel-Beispielen zum Thema "Bestimmtes Ereignis in Spalte zählen"