Das Archiv des Excel-Forums

Bestimmtes Ereignis in Spalte zählen

Bild

Betrifft: Bestimmtes Ereignis in Spalte zählen
von: Born

Geschrieben am: 11.04.2008 16:23:48

Hallo und guten Tag,
ich habe diese Formel schon mal in einer Tabelle aber finde sie nicht mehr.
Und irgendwann wird die Sucherei einfach nervig. Deshalb erlaube ich mir
die Frage:
Wie zähle ich den Wechsel von irgendeiner positiven Zahl zu -1 in einer Spalte?
In folgendem Beispiel wäre das Ergebnis 2, weil der Wechsel zweimal vorkommt:
4
26
3
17
-1
-1
-1
-1
25
60
34
27
-1
-1
28
26
77
88
Danke, ufff,
Born

Bild

Betrifft: AW: Bestimmtes Ereignis in Spalte zählen
von: UweD
Geschrieben am: 11.04.2008 16:58:40
Hallo
mit Hilfsspalte so...

 
 AB
14 
2260
330
4170
5-11
6-10
7-10
8-10
9250
10600
11340
12270
13-11
14-10
15280
16260
17770
18880
19  
20Summe2
Formeln der Tabelle
B2 : =(A1>0)*(A2=-1)
B20 : =SUMME(B1:B18)
 

Formel nach unten kopieren.
Gruß UD

Bild

Betrifft: Das geht auch mit Matrix, aber wie?
von: Born

Geschrieben am: 11.04.2008 17:14:44
Hallo Uwe,
ja und danke. Aber da gibts eine (einfache) Matrixformel, mit der
das auch geht. Die such ich...
Danke,
Born

Bild

Betrifft: AW: Bestimmtes Ereignis in Spalte zählen
von: Christian
Geschrieben am: 11.04.2008 17:02:16
Hallo Born,
als Ansatz:
Tabelle1

 ABC
14 3
226  
33  
417  
5-1  
6-1  
7-1  
8-1  
925  
1060  
1134  
1227  
13-1  
14-1  
1528  
1626  
1777  
1888  
19-1  

Formeln der Tabelle
ZelleFormel
C1{=SUMME((A1:A100>0)*(A2:A101=-1))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
MfG nach Berlin
Christian

Bild

Betrifft: AW: Bestimmtes Ereignis in Spalte zählen
von: Born

Geschrieben am: 11.04.2008 17:32:41
Hallo Ranger,
ich hatte gehofft, daß Du irgendwo da draußen druch die Nacht reitest
und meinen Hilferuf hören würdest.
Im Ernst: Schön von dir zu hören, lesen. Und natürlich wars mal
wieder genau das, was ich gebraucht habe. Danke,
Born

 Bild

Excel-Beispiele zum Thema "Bestimmtes Ereignis in Spalte zählen"

Die Ereignisse Zellauswahl, Eingabe und Doppelklick download SVERWEIS als Ereignisprozedur download
Im Change-Ereignis Eingabe in oder Leeren von Zellen erkennen download Makroverzweigung im Change-Ereignis download
ComboBox mit Ereigniscode in Tabellenblatt erstellen download DoubleClick-Ereignis für alle Arbeitsmappen initialisieren download
Begrenzung der Textlänge über Ereignis-Programmierung download Beispiele zum Einsatz des SelectionChange-Ereignisses download
Vorkommen von Zahlenreihen in Spalten download Funktion ANZAHL2 ohne ausgeblendete Spalten download
Spaltenbreite anpassen download Spalten einer Mehrbereichsauswahl ausblenden. download
Spaltennamen bestimmen download Spalten/Zeilen aus- und einblenden download
Zeilen und Spalten über ein Drehfeld ein- und ausblenden download In einem Dialog ausgewählte Spalten drucken download
Spalten bedingt summieren und Zellen formatieren download Abfrage der markierten Spalten download
Wert aus Spalte C, wenn Spalten A und B Bedingungen erfüllen download Beim Kopieren auch die Zeilenhöhe und Spaltenbreite übernehmen download
Zeilen löschen, wenn in bestimmten Spalten keine Werte stehen download Schmale Spalten nebeneinander drucken download
Werte in mehreren Spalten sortieren download Textreihe auf mehrere Spalten mit fester Seitenlänge verteilen download
Spalten A und B vergleichen und Doppel in C listen download Nach Verlassen von Spalte B Spalte C markieren download
Alle leeren Spalten ausblenden download Leere Zeilen und Spalten in ausgewähltem Bereich löschen download
Formel bis zur letzten Zeile der Nebenspalte kopieren download Alle leeren Zeilen und Spalten entfernen download
Wert aus 2. UserForm-ComboBox-Spalte berechnen download Jede zweite Spalte drucken download
Inhalt einer Zelle in Minutenabstand in einer Spalte auflisten download Über InputBoxes Zeile und Spalte auswählen und Ergebnis nennen download
Daten in jeweils einer Spalte zweier Tabellen vergleichen download Letzte Zelle einer Spalte mit Inhalt aus geschlossener Arbeitsmappe download
Spalte A mehrer Mappen in UserForm und aktives Blatt download Durch DoppelKlick Spalte in zweites Arbeitsblatt kopieren download
Bis zur 12. Zeile Cursor nach unten, dann nächste Spalte ansetzen download Werte in Spalte A in Abhängigkeit des Werte in Spalte B eintragen download
Tabellenblattinhalt unter Weglassung einer Spalte als Textdatei download Begriffe in ausgeblendeter Spalte suchen und Fundzeile markieren download
Bei Eingaben in Spalte B in Spalte A den Maximalwert anzeigen download Überschriften aus Spalte C in Spalte D in den relevanten Bereich download
Bei Eintrag in Spalte A aktuelle Zeile kopieren download Wertereihe nach dem Zufallsprinzip auf 4 Spalten verteilen download
Maximalwert aus einem Bereich ermitteln und in Spalte A eintragen download Alle Zellen in Spalte A ohne Eintrag gelb hinterlegen download
Zeilen in Abhängigkeit des Wertes in Spalte A kopieren download Abfrage zum Kopierbereich von Startzelle, Zeilen- und Spaltenanzahl download
Werte aus Spalte A mit Werten aus Spalte B multiplizieren download Einlesen von Spaltenköpfen in UserForm-ListBox download
Spalten ein-/ausblenden nach UserForm-ListBox-Vorgabe download Aus mehrspaltiger UserForm-ListBox Werte der 1. Spalte auslesen download
Aktuellen Bereich in den Spalten A:F als Druckbereich download Alle Werte mit Punkt aus Spalte A in Spalte B download
Zellauswahl in Abhängigkeit des Spaltenkopfes download UserForm-ListBox in Abhängigkeit zur aufrufenden Spalte füllen download