Microsoft Excel

Herbers Excel/VBA-Archiv

Informationen und Beispiele zum Thema RefEdit
BildScreenshot zu RefEdit RefEdit-Seite mit Beispielarbeitsmappe aufrufen

Abfrage aus Bereich - Abgleich mit 2 Werten | Herbers Excel-Forum


Betrifft: Abfrage aus Bereich - Abgleich mit 2 Werten von: Peter
Geschrieben am: 19.11.2009 15:06:47

Guten Tag

Ich suche eine Formel, mit der ich einen Wert aus einem Bereich abfragen kann. In diesem Bereich steht in der Spalte links eine Identifikationsnummer in den weiteren Spalten ist im Kopf der Spalte ein Datum vermerkt und in den Zeilen der Identifikationsnummer ein Wert.

Nun möchte ich auf Basis eines Identifikationscodes und eines Datums aus der Tabelle den Wert abfragen, der in der Spalte steht mit dem Datum im Kopf der Spalte, das gleich oder kleiner als das Abfragedatum ist.

Sorry für die Beschreibung - gar nicht so einfach, das zu beschreiben. Deshalb habe ich eine Musterdatei hochgeladen.

Danke für jede Hilfe.

Gruss, Peter

https://www.herber.de/bbs/user/66053.xls

  

Betrifft: =SVERWEIS(A9;H$2:K$6;VERGLEICH(B$7;I$1:K$1);0) von: Matthias5
Geschrieben am: 19.11.2009 15:10:07

Gruß,
Matthias


  

Betrifft: =SVERWEIS(A9;H$2:K$6;VERGLEICH(B$7;I$1:K$1)+1;0) von: nicht da
Geschrieben am: 19.11.2009 15:26:38


Gruß


  

Betrifft: Sag ich doch! ;-) von: Matthias5
Geschrieben am: 19.11.2009 15:32:04




  

Betrifft: AW: Sag ich doch! ;-) von: nicht da
Geschrieben am: 19.11.2009 15:36:41

nö... guckst Du:
entweder
=SVERWEIS(A9;H$2:K$6;VERGLEICH(B$7;H$1:K$1);0)
oder
=SVERWEIS(A9;H$2:K$6;VERGLEICH(B$7;I$1:K$1)+1;0)
lieben Gruß


  

Betrifft: Ich weiß!!!!! Deswegen der Zwinkerer! oT von: Matthias5
Geschrieben am: 19.11.2009 15:43:22




  

Betrifft: hattest du nicht..!!! von: jockel
Geschrieben am: 19.11.2009 15:37:30

hi Matthias, deine formel steht ganz rechts, und gibt nicht das gewünschte ergebnis...

Tabelle1

 BCDE
1516,00  1615,33
169,17  9,171,11
175,37  5,379,37
1817,00  1718

verwendete Formeln
Zelle Formel
B15 =SVERWEIS(A9;H$2:K$6;VERGLEICH($B$7;$H$1:$K$1);0)
D15 =SVERWEIS(A9;H$2:K$6;VERGLEICH(B$7;I$1:K$1)+1;0)
E15 =SVERWEIS(A9;H$2:K$6;VERGLEICH(B$7;I$1:K$1);0)

Tabellendarstellung in Foren Version 4.31





cu jörg eine rückmeldung wäre ganz reizend


  

Betrifft: AW: hattest du nicht..!!! von: Peter
Geschrieben am: 19.11.2009 15:39:35

Hallo miteinander
Für mich ist alles klar.
Besten Dank!
Peter


  

Betrifft: Weiß ich, alles ok! oT von: Matthias5
Geschrieben am: 19.11.2009 15:43:43




Beiträge aus den Excel-Beispielen zum Thema "Abfrage aus Bereich - Abgleich mit 2 Werten"