Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

sumif und zwei Bedingungen (Google Spreadsheet)

sumif und zwei Bedingungen (Google Spreadsheet)
Martin
Hallo,
ich würde gerne meine sumif -Formel optimieren:
Julian Fahrradschloss 8 gekauft
Julian Olchi-Bücher 20
Julian MP3-Player 40 bestellt
Nun soll nicht nur eine sumif in der Art erstellt werden:
=sumif(A2:A41, "Julian",C2:C41)
sondern nur, wenn "Julian" in Spalte "A" steht und "gekauft" in der "D"-Spalte.
Geht das mit sumif, besonders in Googles Spreadsheet?
SUMMENPRODUKT anstatt SUMMEWENN
23.11.2009 16:35:42
NoNet
Hallo Martin,
das löst man per SUMMENPRODUKT (engl.: SUMPRODUCT) :
ABCDEFG
1
2
3
4

Funktionen im Tabellenblatt :
Zelle Formel 
G1   =SUMMENPRODUKT((A2:A999="Julian")*(D2:D999="gekauft")

Gruß, NoNet
Anzeige
AW: sumif und zwei Bedingungen (Google Spreadsheet)
23.11.2009 16:37:27
IngGi
Hallo Martin,
in (englischsprachigem) Excel mit SUMPRODUCT:
=SUMPRODUCT((A2:A41="Julian")*(D2:D41="gekauft")*(C2:C41))
Gruß Ingolf
AW: sumif und zwei Bedingungen (Google Spreadsheet
24.11.2009 08:37:20
Martin
Hallo und danke für den Tipp.
Ich erhalte aber die Fehlermeldung:
"error range has no entry corresponding to this cell"
Habe es mit nur zwei (passenden) Zeilen probiert:
Julian Tresor 28 gekauft
Julian Fotoapparat 65
=SUMPRODUCT((A13:A14="Julian")*(D13:D14="gekauft")*(C13:C14))
AW: sumif und zwei Bedingungen (Google Spreadsheet
24.11.2009 08:58:23
IngGi
Hallo Martin,
und in den Zellen steht wirklich nur "Julian" bzw. "gekauft" und nicht zum Beispiel noch ein Leer- oder (unsichtbares) Sonderzeichen? Prüfe mal mit =LEN(A13). Das müsste dann ja 6 ergeben, bzw. 7 für D13.
Gruß Ingolf
Anzeige
AW: sumif und zwei Bedingungen (Google Spreadsheet
24.11.2009 10:25:06
Martin
Ja, das sieht korrekt aus.
Auch wenn ich in beide D-Spalten "gekauft" reinschreibe, erscheint die Fehlermeldung.
Julian Tresor 28 gekauft
Julian Fotoapparat 65 gekauft
Länge A-Spalten=6, D-Spalten=7
Wobei doch in den A- und D-Spalten auch andere Werte stehen sollen dürfen (toller Satz).
AW: sumif und zwei Bedingungen (Google Spreadsheet)
24.11.2009 10:36:34
IngGi
Hallo Martin,
dann scheint hier ein Unterschied zwischen Excel und Google Spreadsheets zu bestehen. In Excel funktioniert das so. Mit Google Spreadsheet kann ich das aber erst heute abend von zuhause aus testen. Daher Frage offen!
Gruß Ingolf
AW: sumif und zwei Bedingungen (Google Spreadsheet
24.11.2009 19:06:35
IngGi
Hallo Martin,
anders als in Excel ist die Summenproduktformel in Google Spreadsheet offensichtlich nicht implizit als Matrixformel angelegt. Daher muss die Formel in Google Spreadsheet explizit als Matrixformel eingegeben werden. Das heisst, du darfst die Formel nicht einfach mit ENTER abschließen, sonder musst dies mit STRG+UMSCHALT+ENTER tun. Dann funktioniert's!
Gruß Ingolf
AW: sumif und zwei Bedingungen (Google Spreadsheet
26.11.2009 10:17:12
Martin
Danke dir!
Ghet !

10 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige