Microsoft Excel

Herbers Excel/VBA-Archiv

Formelexperte gesucht | Herbers Excel-Forum


Betrifft: Formelexperte gesucht von: Frank H.
Geschrieben am: 04.12.2009 12:24:14

Hallo Zusammen!!!

Ich benötige eine Formel welche mir die Arbeit erleichtert und ich Änderungen nicht vopn Hand eingeben muss. Folgender Sachverhalt:

In Spalte BA ab Zeile 11 stehen Datumswerte vom 01.01.2006 - 31.12.2031. In der Spalte BI stehen Werte, welche summiert werden sollen. In der Spalte BR soll immer am Monatsletzten die Summe der Spalte BI vom Monatsersten - Letzten ausgegebern werden! Ist das per Formel möglich? Da die Monate ja immer unterschiedlich lang sind komme ich mit einfachem kopieren nicht so richtig weiter! Über Hilfe bin ich wie immer sehr dankbar!!!

Gruß Frank H.

  

Betrifft: AW: Formelexperte gesucht von: Josef Ehrensberger
Geschrieben am: 04.12.2009 12:34:22

Hallo Frank,

folgende Formel in BR11 sollte es tun (Formel runterkopieren bis zum Ende der Liste)

=WENN(BA11=DATUM(JAHR(BA11);MONAT(BA11)+1;0);SUMMENPRODUKT(MONAT(($BA$11:BA11)=MONAT(BA11))*( _
JAHR($BA$11:BA11)=JAHR(BA11))*$BI$11:BI11);"")
Gruß Sepp



  

Betrifft: AW: Formelexperte gesucht von: Frank H.
Geschrieben am: 04.12.2009 13:09:03

Hallo Sepp!!!

Funzt leider nicht!!! Fehlermeldung mit "" am Ende. Ohne "" keine Fehlermeldung, aber das Ergebnis ist FALSCH und am Monatsletzten ergibt es 0, was in meinem Fall nicht korrekt ist!!! Kannst du noch einmal schauen wo der Fehler liegen könnte!!!

Danke im Vorraus!!!

Frank H.


  

Betrifft: AW: Formelexperte gesucht von: Josef Ehrensberger
Geschrieben am: 04.12.2009 13:17:59

Hallo Frank,

also die Formel funktioniert.

Tabelle2

 BABIBR
1101.01.2009743 
1202.01.2009636 
1303.01.20091058 
1404.01.2009846 
1505.01.20091370 
1606.01.20091412 
1707.01.2009535 
1808.01.200993 
1909.01.20091143 
2010.01.20091038 
2111.01.2009717 
2212.01.2009400 
2313.01.20091220 
2414.01.2009913 
2515.01.2009681 
2616.01.20091352 
2717.01.2009707 
2818.01.20091235 
2919.01.2009921 
3020.01.2009231 
3121.01.2009955 
3222.01.2009147 
3323.01.2009428 
3424.01.2009501 
3525.01.20091235 
3626.01.2009732 
3727.01.20091456 
3828.01.20091320 
3929.01.2009150 
4030.01.20091319 
4131.01.2009106026554
4201.02.20091357 

Formeln der Tabelle
ZelleFormel
BR11=WENN(BA11=DATUM(JAHR(BA11); MONAT(BA11)+1;0); SUMMENPRODUKT(MONAT(($BA$11:BA11)=MONAT(BA11))*(JAHR($BA$11:BA11)=JAHR(BA11))*$BI$11:BI11); "")


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4




Gruß Sepp



  

Betrifft: AW: Formelexperte gesucht von: Frank H.
Geschrieben am: 04.12.2009 15:53:52

Hallo Sepp!!!

Leider erst jetzt dazu gekommen noch einmal zu testen! Jetzt funzt es wunderbar und dafür gebührt dir der allerherzlichste Dank!!! Beim Abtippen habe ich bestimmt einen oder mehrere Fehler produziert. Sorry!!!
Also jetzt ist alles bestens und du bist wieder einmal ein unsichtbarer Held!!!

Ein schönes Wochenende wünscht herzlichst Frank!!!


  

Betrifft: AW: Formelexperte gesucht von: BoskoBiati
Geschrieben am: 04.12.2009 19:17:22

Hallo,

Eine der beiden Formeln in BR12 eintragen und nach unten ziehen bringt das gleiche Ergebnis:

=WENN(BA13=DATUM(JAHR(BA12);MONAT(BA12)+1;1);SUMME($BI$11:BI12)-SUMME($BR$11:BR11);"")
=WENN(BA12=DATUM(JAHR(BA12);MONAT(BA12)+1;0);SUMME($BI$11:BI12)-SUMME($BR$11:BR11);"")
Gruß

Bosko


  

Betrifft: Beim Abtippen ... Fehler (hier ein Tipp) von: Matthias L
Geschrieben am: 05.12.2009 01:53:28

Hallo



Das 3 fache "p" in Tipppfehler ist ein Tippfehler ;o)