Microsoft Excel

Herbers Excel/VBA-Archiv

Mittelwertberechnung | Herbers Excel-Forum


Betrifft: Mittelwertberechnung von: Dagmar GP
Geschrieben am: 14.12.2009 16:44:32

Hallo alle miteinander,

vielleicht ist mir noch zu helfen?

Ich habe eine Temperaturtabelle auf der stündlich die Außentemperatur abgelesen wurde. Daraus lassen sich Tages-, Wochen- und Monatmittel errechnen. Soweit so gut. Jetzt kommt das Problem:

Heizungswerte werden sporadisch abgelesen. Es soll nun immer der Mittelwert der Außentemperatur im Ablesezeitraum errechnet werden. Dies ist immer ein unterschiedlicher Zeitraum. Ist das ohne Makro möglich? Ich habe es mit dem S-Verweis versucht, bekomme aber das Ergebnis nicht in die Mittelwertberechnung.

Vielen Dank für Eure Hilfe

Dagmar

  

Betrifft: AW: Mittelwertberechnung von: Josef Ehrensberger
Geschrieben am: 14.12.2009 17:37:32

Hallo Dagmar,

lade bitte eine Beispieltabelle mit Beschreibung hoch.


Gruß Sepp



  

Betrifft: AW: Mittelwertberechnung von: Tino
Geschrieben am: 14.12.2009 18:02:35

Hallo,
meinst Du so?

https://www.herber.de/bbs/user/66584.xls


Gruß Tino


  

Betrifft: AW: Mittelwertberechnung von: BoskoBiati
Geschrieben am: 14.12.2009 18:25:52

Hallo Dagmar,

wäre das etwas nach Deinen Vorstellungen:

Tabelle1

 ABCDE
2Datum/ UhrzeitT Ablesung 
311.11.2009 07:1012,3 12. Nov 
411.11.2009 08:1012,4 15. Nov12,89
511.11.2009 09:1012,5 28. Nov12,90
54303.12.2009 19:1012,5   
54403.12.2009 20:1012,4   
54503.12.2009 21:1012,5   
54603.12.2009 22:1012,6   
54703.12.2009 23:1012,7   
54804.12.2009 00:1012,8   

Formeln der Tabelle
ZelleFormel
E4=SUMMENPRODUKT(($A$3:$A$5000>=D3)*($A$3:$A$5000<(D4+1))*($B$3:$B$5000))/(DATEDIF(D3;D4;"d")+1)/24
E5=SUMMENPRODUKT(($A$3:$A$5000>=D4)*($A$3:$A$5000<(D5+1))*($B$3:$B$5000))/(DATEDIF(D4;D5;"d")+1)/24


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Gruß

Bosko


  

Betrifft: AW: Mittelwertberechnung von: Dagmar GP
Geschrieben am: 16.12.2009 09:36:26

Hallo,

vielen herzlichen Dank. Hier wird man ja überschüttet mit suuuper Lösungen.

Danke Tino, für Deine Formel habe ich mich jetzt letzten Endes entschieden. Es klappt gut und ich konnte sie auch für meinen eigenen Fall umstricken.

Ich bin immer wieder begeistert von diesem Forum. Leider kann ich selber kaum helfen, da die Fragen meistens meine Kennnisse übersteigen.

Schöne Grüsse
Dagmar