Microsoft Excel

Herbers Excel/VBA-Archiv

Formel akt. Woche | Herbers Excel-Forum


Betrifft: Formel akt. Woche von: walli
Geschrieben am: 23.12.2009 13:12:43

Hallo Forumsteilnehmer und Experten,
erst mal:
Ein schönes Weihnachtsfest, ein gesundes neues Jahr und Erfolg
im Job oder .... !
mfg Walli

M
Nun meine Frage, ich suche die laufende Woche,habe auch Musterdatei dabei.
Habe mal gestöbert und einige Formeln gefunden, allerdings kann ich
nicht so Richtig einsetzen.
Ich möchte den Bezug zum Jahr, Woche und Tag durchführen,
klappt nicht, siehe Muster.
=KÜRZEN((A1-WOCHENTAG(A1;2)-DATUM(JAHR(A1+4-WOCHENTAG(A1;2));1;-10))/7)
https://www.herber.de/bbs/user/66791.xls

Würde mich auf Unterstützung freuen,
mfg Walli

  

Betrifft: AW: Formel akt. Woche von: Josef Ehrensberger
Geschrieben am: 23.12.2009 13:27:16

Hallo Walli,

Tabelle2

 ABCD
1Jahr 2010 
2Monat 1 
3Tag ist Freitag 
4Januar 10   
5    
6  Woche ist: 
7    
8Fr153 
9Sa253 
10So353 
11Mo41 
12Di51 
13Mi61 
14Do71 
15Fr81 
16Sa91 
17So101 
18Mo112 
19Di122 
20Mi132 
21Do142 
22Fr152 
23Sa162 
24So172 
25Mo183 
26Di193 
27Mi203 
28Do213 
29Fr223 
30Sa233 

Formeln der Tabelle
ZelleFormel
A8=DATUM($C$1;$C$2;ZEILE(A1))
B8=TAG(A8)
C8=KÜRZEN((A8-WOCHENTAG(A8;2)-DATUM(JAHR(A8+4-WOCHENTAG(A8;2)); 1;-10))/7)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4




Gruß Sepp



  

Betrifft: AW: Formel akt. Woche von: Ramses
Geschrieben am: 23.12.2009 13:37:02

Hallo

Gleich wie Josef.
Korrekter Tabellenaufbau ist Voraussetzung für die Formel.
Ich habe lediglich die Formeln so angepasst, dass Sie dein Layout erfüllen

Tabelle2

 ABC
1Jahr 2010
2Monat 1
3Tag ist Freitag
4Januar 10  
5   
6  Kalender
7  woche
8Sa  
9So  
10Mo  
11Di  
12Mi  
13Do  
14Fr153
15Sa253
16So353
17Mo41
18Di51
19Mi61
20Do71
21Fr81
22Sa91
23So101
24Mo112
25Di122
26Mi132
27Do142
28Fr152
29Sa162
30So172
31Mo183
32Di193
33Mi203
34Do213
35Fr223
36Sa233
37So243
38Mo254
39Di264
40Mi274
41Do284
42Fr294
43Sa304
44So314

Formeln der Tabelle
ZelleFormel
C3=+A4
A4=DATUM(C1;C2;1)
B8=WENN(WOCHENTAG(DATUM($C$1;$C$2;1); 2)=6;DATUM($C$1;$C$2;1); "")
C8=WENN(B8="";"";KÜRZEN((B8-WOCHENTAG(B8;2)-DATUM(JAHR(B8+4-WOCHENTAG(B8;2)); 1;-10))/7))
B9=WENN(WOCHENTAG(DATUM($C$1;$C$2;1); 2)=7;DATUM($C$1;$C$2;1); WENN(B8="";"";B8+1))
C9=WENN(B9="";"";KÜRZEN((B9-WOCHENTAG(B9;2)-DATUM(JAHR(B9+4-WOCHENTAG(B9;2)); 1;-10))/7))
B10=WENN(WOCHENTAG(DATUM($C$1;$C$2;1); 2)=1;DATUM($C$1;$C$2;1); WENN(B9="";"";B9+1))
C10=WENN(B10="";"";KÜRZEN((B10-WOCHENTAG(B10;2)-DATUM(JAHR(B10+4-WOCHENTAG(B10;2)); 1;-10))/7))
B11=WENN(WOCHENTAG(DATUM($C$1;$C$2;1); 2)=2;DATUM($C$1;$C$2;1); WENN(B10="";"";B10+1))
C11=WENN(B11="";"";KÜRZEN((B11-WOCHENTAG(B11;2)-DATUM(JAHR(B11+4-WOCHENTAG(B11;2)); 1;-10))/7))
B12=WENN(WOCHENTAG(DATUM($C$1;$C$2;1); 2)=3;DATUM($C$1;$C$2;1); WENN(B11="";"";B11+1))
C12=WENN(B12="";"";KÜRZEN((B12-WOCHENTAG(B12;2)-DATUM(JAHR(B12+4-WOCHENTAG(B12;2)); 1;-10))/7))
B13=WENN(WOCHENTAG(DATUM($C$1;$C$2;1); 2)=4;DATUM($C$1;$C$2;1); WENN(B12="";"";B12+1))
C13=WENN(B13="";"";KÜRZEN((B13-WOCHENTAG(B13;2)-DATUM(JAHR(B13+4-WOCHENTAG(B13;2)); 1;-10))/7))
B14=WENN(WOCHENTAG(DATUM($C$1;$C$2;1); 2)=5;DATUM($C$1;$C$2;1); WENN(B13="";"";B13+1))
C14=WENN(B14="";"";KÜRZEN((B14-WOCHENTAG(B14;2)-DATUM(JAHR(B14+4-WOCHENTAG(B14;2)); 1;-10))/7))
B15=B14+1
C15=WENN(B15="";"";KÜRZEN((B15-WOCHENTAG(B15;2)-DATUM(JAHR(B15+4-WOCHENTAG(B15;2)); 1;-10))/7))
B16=B15+1
C16=WENN(B16="";"";KÜRZEN((B16-WOCHENTAG(B16;2)-DATUM(JAHR(B16+4-WOCHENTAG(B16;2)); 1;-10))/7))
B17=B16+1
C17=WENN(B17="";"";KÜRZEN((B17-WOCHENTAG(B17;2)-DATUM(JAHR(B17+4-WOCHENTAG(B17;2)); 1;-10))/7))
B18=B17+1
C18=WENN(B18="";"";KÜRZEN((B18-WOCHENTAG(B18;2)-DATUM(JAHR(B18+4-WOCHENTAG(B18;2)); 1;-10))/7))
B19=B18+1
C19=WENN(B19="";"";KÜRZEN((B19-WOCHENTAG(B19;2)-DATUM(JAHR(B19+4-WOCHENTAG(B19;2)); 1;-10))/7))
B20=B19+1
C20=WENN(B20="";"";KÜRZEN((B20-WOCHENTAG(B20;2)-DATUM(JAHR(B20+4-WOCHENTAG(B20;2)); 1;-10))/7))
B21=B20+1
C21=WENN(B21="";"";KÜRZEN((B21-WOCHENTAG(B21;2)-DATUM(JAHR(B21+4-WOCHENTAG(B21;2)); 1;-10))/7))
B22=B21+1
C22=WENN(B22="";"";KÜRZEN((B22-WOCHENTAG(B22;2)-DATUM(JAHR(B22+4-WOCHENTAG(B22;2)); 1;-10))/7))
B23=B22+1
C23=WENN(B23="";"";KÜRZEN((B23-WOCHENTAG(B23;2)-DATUM(JAHR(B23+4-WOCHENTAG(B23;2)); 1;-10))/7))
B24=B23+1
C24=WENN(B24="";"";KÜRZEN((B24-WOCHENTAG(B24;2)-DATUM(JAHR(B24+4-WOCHENTAG(B24;2)); 1;-10))/7))
B25=B24+1
C25=WENN(B25="";"";KÜRZEN((B25-WOCHENTAG(B25;2)-DATUM(JAHR(B25+4-WOCHENTAG(B25;2)); 1;-10))/7))
B26=B25+1
C26=WENN(B26="";"";KÜRZEN((B26-WOCHENTAG(B26;2)-DATUM(JAHR(B26+4-WOCHENTAG(B26;2)); 1;-10))/7))
B27=B26+1
C27=WENN(B27="";"";KÜRZEN((B27-WOCHENTAG(B27;2)-DATUM(JAHR(B27+4-WOCHENTAG(B27;2)); 1;-10))/7))
B28=B27+1
C28=WENN(B28="";"";KÜRZEN((B28-WOCHENTAG(B28;2)-DATUM(JAHR(B28+4-WOCHENTAG(B28;2)); 1;-10))/7))
B29=B28+1
C29=WENN(B29="";"";KÜRZEN((B29-WOCHENTAG(B29;2)-DATUM(JAHR(B29+4-WOCHENTAG(B29;2)); 1;-10))/7))
B30=B29+1
C30=WENN(B30="";"";KÜRZEN((B30-WOCHENTAG(B30;2)-DATUM(JAHR(B30+4-WOCHENTAG(B30;2)); 1;-10))/7))
B31=B30+1
C31=WENN(B31="";"";KÜRZEN((B31-WOCHENTAG(B31;2)-DATUM(JAHR(B31+4-WOCHENTAG(B31;2)); 1;-10))/7))
B32=B31+1
C32=WENN(B32="";"";KÜRZEN((B32-WOCHENTAG(B32;2)-DATUM(JAHR(B32+4-WOCHENTAG(B32;2)); 1;-10))/7))
B33=WENN(MONAT(B32+1)<>MONAT(B32); "";WENN(B32="";"";B32+1))
C33=WENN(B33="";"";KÜRZEN((B33-WOCHENTAG(B33;2)-DATUM(JAHR(B33+4-WOCHENTAG(B33;2)); 1;-10))/7))
B34=B33+1
C34=WENN(B34="";"";KÜRZEN((B34-WOCHENTAG(B34;2)-DATUM(JAHR(B34+4-WOCHENTAG(B34;2)); 1;-10))/7))
B35=B34+1
C35=WENN(B35="";"";KÜRZEN((B35-WOCHENTAG(B35;2)-DATUM(JAHR(B35+4-WOCHENTAG(B35;2)); 1;-10))/7))
B36=B35+1
C36=WENN(B36="";"";KÜRZEN((B36-WOCHENTAG(B36;2)-DATUM(JAHR(B36+4-WOCHENTAG(B36;2)); 1;-10))/7))
B37=B36+1
C37=WENN(B37="";"";KÜRZEN((B37-WOCHENTAG(B37;2)-DATUM(JAHR(B37+4-WOCHENTAG(B37;2)); 1;-10))/7))
B38=B37+1
C38=WENN(B38="";"";KÜRZEN((B38-WOCHENTAG(B38;2)-DATUM(JAHR(B38+4-WOCHENTAG(B38;2)); 1;-10))/7))
B39=B38+1
C39=WENN(B39="";"";KÜRZEN((B39-WOCHENTAG(B39;2)-DATUM(JAHR(B39+4-WOCHENTAG(B39;2)); 1;-10))/7))
B40=B39+1
C40=WENN(B40="";"";KÜRZEN((B40-WOCHENTAG(B40;2)-DATUM(JAHR(B40+4-WOCHENTAG(B40;2)); 1;-10))/7))
B41=B40+1
C41=WENN(B41="";"";KÜRZEN((B41-WOCHENTAG(B41;2)-DATUM(JAHR(B41+4-WOCHENTAG(B41;2)); 1;-10))/7))
B42=B41+1
C42=WENN(B42="";"";KÜRZEN((B42-WOCHENTAG(B42;2)-DATUM(JAHR(B42+4-WOCHENTAG(B42;2)); 1;-10))/7))
B43=B42+1
C43=WENN(B43="";"";KÜRZEN((B43-WOCHENTAG(B43;2)-DATUM(JAHR(B43+4-WOCHENTAG(B43;2)); 1;-10))/7))
B44=B43+1
C44=WENN(B44="";"";KÜRZEN((B44-WOCHENTAG(B44;2)-DATUM(JAHR(B44+4-WOCHENTAG(B44;2)); 1;-10))/7))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

https://www.herber.de/bbs/user/66794.xls


Gruss Rainer


  

Betrifft: Hallo Sepp und Rainer von: walli
Geschrieben am: 23.12.2009 14:04:28

Herzlichen Dank für die Unterstützung.
Könnte man auch die Kalenderwochen ausblenden, die sich wiederholen.
So das die Woche 53 angezeigt wird, dann z.b. am 17.1. die 1. und dann
wieder am 24.1. 2. .
Also nur die akt. ?

Danke im Voraus
mfg Walli


  

Betrifft: Hallo Sepp und Rainer Beispiel von: walli
Geschrieben am: 23.12.2009 14:42:37

Hallo Ihr Zwei,
habe nochmals Muster erstellt.
Damit es verständlich ist was ich meine, bin ja nicht der
Excel Papst.

https://www.herber.de/bbs/user/66796.xls


mfg walli


  

Betrifft: AW: Hallo Sepp und Rainer Beispiel von: Josef Ehrensberger
Geschrieben am: 23.12.2009 14:56:55

Hallo Wali,

https://www.herber.de/bbs/user/66798.xls


Gruß Sepp



  

Betrifft: DANKE Sepp -) von: walli
Geschrieben am: 23.12.2009 15:51:00

Hallo Sepp,
recht herzlichen Dank,
schönes Fest und ein gesundes neues Jahr !!!

mfg Walli


  

Betrifft: Hallo Sepp entschuldige aber von: walli
Geschrieben am: 23.12.2009 16:46:34

Hallo Sepp,
bitte entschuldige aber wie kann es sein wenn ich 2011 reingebe und
den 1. dann erscheinen die letzten Zahlen wieder ???

https://www.herber.de/bbs/user/66800.xls

mfg walli


  

Betrifft: AW: Hallo Sepp entschuldige aber von: Josef Ehrensberger
Geschrieben am: 23.12.2009 17:55:27

Hallo Walli,

dann halt so.

https://www.herber.de/bbs/user/66802.xls



Gruß Sepp



  

Betrifft: Herzlichen Dank und --)) von: walli
Geschrieben am: 24.12.2009 11:26:47

Guten Morgen Sepp,

herzlichen klappt jetzt einwandfrei !!!

Ein schönes Weihnachtsfest und viel Gesundheit für das
neue Jahr,
recht herzlich Walli !


Beiträge aus den Excel-Beispielen zum Thema "Formel akt. Woche"