Microsoft Excel

Herbers Excel/VBA-Archiv

Statistik erstellen | Herbers Excel-Forum


Betrifft: Statistik erstellen von: René
Geschrieben am: 06.01.2010 22:57:36

Hallo liebe Excelprofis,

ich habe folgendes Problem, an dem ich mir die Zähne ausbeiße:
Auf einem Tabellenblatt habe ich ein Mitgliederverzeichnis für einen Verein erstellt. In einer Spalte wird das Alter entsprechend des Geburtsdatums berechnet. Nun soll auf einem weiteren Blatt eine Statistik eine Aussage über die Alterszusammensetzung der Mitglieder geben.
Also zum Beispiel:

Anzahl 16 - 25 Jahre: 27
Anzahl 26 - 35 Jahre: 13
usw.

Für einen Lösungsvorschlag wäre ich echt dankbar!

Viele Grüße,
René

  

Betrifft: AW: Statistik erstellen von: Josef Ehrensberger
Geschrieben am: 06.01.2010 23:02:35

Hallo René,

angenommen, das Alter steht in Spalte B, für den Bereich 16-25

=SUMMENPRODUKT((B2:B100>=16)*(B2:B100<=25)*1)
Gruß Sepp



  

Betrifft: AW: Statistik erstellen von: René
Geschrieben am: 06.01.2010 23:12:21

Hallo Sepp,

habe gerade die Formel angepasst und getestet. Funktioniert aber leider nicht!
Ich bekomme als Wert immer "0" zurück.


  

Betrifft: AW: Statistik erstellen von: Josef Ehrensberger
Geschrieben am: 06.01.2010 23:23:59

Hallo René,

sicher geht das und das *1 braucht's gar nicht.

Tabelle1

 ABCDEFG
1GeburtsdatumAlter  AlterAnzahl 
217.03.198228  16-254 
323.05.199020  26-351 
404.12.197436  36-451 
516.08.198723     
614.02.199416     
728.06.199317     
8       

Formeln der Tabelle
ZelleFormel
F2=SUMMENPRODUKT((B2:B7>=16)*(B2:B7<=25))
F3=SUMMENPRODUKT((B2:B7>=26)*(B2:B7<=35))
F4=SUMMENPRODUKT((B2:B7>=36)*(B2:B7<=45))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Gruß Sepp


  

Betrifft: AW: Statistik erstellen von: René
Geschrieben am: 06.01.2010 23:32:45

Hallo Sepp,

muss wohl ein Format-Problem beim Test gewesen sein...
Ich hab's nochmal mit einem neuen Blatt getestet - da geht's!
Das mit der "*1" war mir schon aufgefallen. ;-)

Vielen Dank!
René


  

Betrifft: AW: Statistik erstellen von: René
Geschrieben am: 06.01.2010 23:25:54

allerdings ist mir SUMMENPRODUKT in der Anwendung auch nicht geläufig.


  

Betrifft: AW: Statistik erstellen von: Daniel
Geschrieben am: 06.01.2010 23:30:45

Hi

ich würde über den SVerweis mit einer kleinen Hilfstabelle eine Altersgruppe zuweisen, damit kannst du dann einfach über ZÄHLENWENN oder noch einfacher über die Pivot-Tabelle auswerten.

gruß, Daniel


  

Betrifft: AW: Statistik erstellen von: Stefan
Geschrieben am: 07.01.2010 10:24:30

Hallo René,

ich würde sowas mit der Funktion Häufigkeit lösen.

Beispiel: =HÄUFIGKEIT(A3:A8;D3:D6)

Die Funktion ist in der Excel-Hilfe gut erklärt. Du brauchst neben den Daten noch eine kleine Tabelle mit den Klassen. Die Formel muß als Matrixformel eingegeben werden.

Gruß

Stefan


Beiträge aus den Excel-Beispielen zum Thema "Statistik erstellen"