Microsoft Excel

Herbers Excel/VBA-Archiv

Autofilter und Sverweis | Herbers Excel-Forum


Betrifft: Autofilter und Sverweis von: Tom
Geschrieben am: 08.01.2010 21:37:52

Hallo zusammen,

benötige mal wieder Euer Fachwissen.

Ich habe zwei Tabellen, in der ersten Tabelle stehen Artikelnummern in Spalte A, in Spalte B stehen Lagerorte. In der zweiten Tabelle stehen die gleichen Artikelnummern in Spalte A und in Spalte B die Lagerorte. Da in jedem Lagerort die gleiche Artikelnummer vorkommen kann, nutze ich die Autofilterfunktion in der ersten Tabelle und filtere z.Bsp. nach Lagerort 10 in der zweiten Tabelle setze ich ebenfalls den Filter auf Lagerort 10.

In der ersten gefilterten Tabelle in Spalte C gebe ich nun eine Formel mit =Sverweis ein um aus der zweiten gefilterten Tabelle aus Spalte C die Mengen auszulesen, es werden auch bestimmte Mengen angezeigt, aber leider nicht die richtigen.

Habt Ihr eine Idee woran das liegen könnte?

Danke im Voraus.

Grüße
Tom

  

Betrifft: AW: Autofilter und Sverweis von: fcs
Geschrieben am: 09.01.2010 00:05:11

Hallo Tom,

...denn die im Schatten siehst du nicht, aber SVERWEIS schon.
SVERWEIS sucht immer in allen Daten also auch in den per Filter ausgeblendeten, kommt eine Artikelnummer mehrfach vor, dann gibt Sverweis das Ergebnis der ersten Fundstelle aus.

Verwende eine Formel nach folgenden Schema, um die Menge eines Artikels an einem Lagerort aus Tabelle2 nach Tabelle1 einzulesen.
=SUMMENPRODUKT((Tabelle2!$A$2:$A$28=Tabelle1!A2)*(Tabelle2!$B$2:$B$28=Tabelle1!B2) *Tabelle2!$C$2:$C$28)

Gruß
Franz


Beiträge aus den Excel-Beispielen zum Thema "Autofilter und Sverweis"