Microsoft Excel

Herbers Excel/VBA-Archiv

Formel .. Einzigartigkeit | Herbers Excel-Forum


Betrifft: Formel .. Einzigartigkeit von: Mike
Geschrieben am: 11.01.2010 16:56:42


Hallo Cracks,

mit den nachfolgenden beiden Grundlagen soll im Endeffekt die Anzahl Interpreten sowie Anzahl Album als auch Interpret / Anzahl Album zur Verfügung stehen. Ein Zählenwenn() funktioniert (noch) nicht wirklich.

Wer hat 'ne besser Variante?

Interpret Album
A-ha Minor Earth Major Sky
ABBA Gold
ABBA Gold
ABBA Gold
ABBA Gold
ABBA Gold
ABBA Gold
ABBA Gold
ABBA Gold
ABBA Gold
ABBA Gold
ABBA Gold
ABBA Gold
ABBA Gold
ABBA Gold
ABBA Gold
ABBA Gold
ABBA Gold
ABBA More Gold
ABBA More Gold
ABBA More Gold
ABBA More Gold
ABBA More Gold
ABBA More Gold
ABBA More Gold
ABBA More Gold
ABC Die Ultimative 80'er Fete
ABC Die Ultimative 80'er Fete
Aerosmith Get A Grip
Aerosmith Get A Grip
Aerosmith Get A Grip
Aerosmith Get A Grip
Aerosmith Get A Grip

Danke und Gruss, Mike

  

Betrifft: Doppelspalten-Solisten von: WF
Geschrieben am: 11.01.2010 17:25:07

Hi Mike,

die Band steht in Spalte A / der Titel in B

folgende Arrayformel:
{=SUMME((VERGLEICH(A1:A1000&"x"&B1:B1000;A1:A1000&"x"&B1:B1000;0)=ZEILE(1:1000))*1)-1}

ARRAY-Formel {=geschweifte Klammern} nicht eingeben;
Abschluß der Formel mit gleichzeitig Strg / Shift / Enter (statt Enter allein); - das erzeugt sie.

Salut WF


  

Betrifft: AW: Doppelspalten-Solisten von: Mike
Geschrieben am: 11.01.2010 17:33:10


Hallo WF,

das tönt für den zweiten Teil der Aufgabe schon mal verheissungsvoll, aktuell
leider noch mit #NV.

Die Daten beginnen in Zeile 6, formeltechnisch vorbereitet bis 5000, brauchts daher für die Zeilenangabe 1:1000 den Wert 6:5005, oder wie genau?

Danke und Gruss, Mike


  

Betrifft: anpassen - aber tricky von: WF
Geschrieben am: 11.01.2010 17:42:42

Hi Mike,

{=SUMME((VERGLEICH(A6:A1000&"x"&B6:B1000;A1:A994&"x"&B1:B994;0)=ZEILE(6:1000))*1)-1}

Salut WF


  

Betrifft: manuell .. anpassen von: Mike
Geschrieben am: 12.01.2010 10:24:58


Hallo WF,

besten Dank für die Anpassung und bitte entschuldige die späte Antwort.

Deine Formel definiert ja nun mal die verschiedenen Interpreten. Gerne
hätte ich jedoch auch die Werte gemäss den beiden "manuell"-Spalten.
Wie liesse sich dies realisieren?


Tabelle1

 ABCDE
4      manuellmanuell
5      InterpretAlbum
6A-haMinor Earth Major Sky411
7ABBAGold  11
8ABBAGold     
9ABBAGold     
10ABBAGold     
11ABBAGold     
12ABBAGold     
13ABBAGold     
14ABBAGold     
15ABBAGold     
16ABBAGold     
17ABBAGold     
18ABBAGold     
19ABBAGold     
20ABBAGold     
21ABBAGold     
22ABBAGold     
23ABBAGold     
24ABBAMore Gold    1
25ABBAMore Gold     
26ABBAMore Gold     
27ABBAMore Gold     
28ABBAMore Gold     
29ABBAMore Gold     
30ABBAMore Gold     
31ABBAMore Gold     
32ABCDie Ultimative 80'er Fete  11
33ABCDie Ultimative 80'er Fete     
34AerosmithGet A Grip  11
35AerosmithGet A Grip     
36AerosmithGet A Grip     
37AerosmithGet A Grip     
38AerosmithGet A Grip     

verwendete Formeln
Zelle Formel
C6 {=SUMME((VERGLEICH(A6:A1000&"x"&B6:B1000;A1:A994&"x"&B1:B994;0)=ZEILE(6:1000))*1)-1}
{} Matrixformel mit Strg+Umschalt+Enter abschließen

Tabellendarstellung in Foren Version 4.28



Danke und Gruss,
Mike


  

Betrifft: offen .. von: Mike
Geschrieben am: 12.01.2010 11:13:19

.. noch offen

Gruss
Mike


  

Betrifft: AW: offen .. von: Hajo_Zi
Geschrieben am: 12.01.2010 11:16:36

Hallo Mike,

ist das nicht ein weinig viel Information, warum offen?

Gruß Hajo


  

Betrifft: AW: offen .. von: Mike
Geschrieben am: 12.01.2010 12:06:17


Hallo Hajo,

weil bei der Antwort an WF das Häckchen bei "Frage noch offen"
nicht nachträglich angepasst werden kann.

Gruss Mike


  

Betrifft: habs .. von: Mike
Geschrieben am: 12.01.2010 16:47:48


Hallo,

habs nun mit dem guten Zählenwenn gelöst:

Tabelle1

 BCDEFGHI
4      manuellmanuell  FormelFormel
5      InterpretAlbum  InterpretAlbum
6A-haMinor Earth Major Sky411  1 1
7ABBAGold  11  1 1
8ABBAGold        - -
9ABBAGold        - -
10ABBAGold        - -
11ABBAGold        - -
12ABBAGold        - -
13ABBAGold        - -
14ABBAGold        - -
15ABBAGold        - -
16ABBAGold        - -
17ABBAGold        - -
18ABBAGold        - -
19ABBAGold        - -
20ABBAGold        - -
21ABBAGold        - -
22ABBAGold        - -
23ABBAGold        - -
24ABBAMore Gold    1  - 1
25ABBAMore Gold        - -
26ABBAMore Gold        - -
27ABBAMore Gold        - -
28ABBAMore Gold        - -
29ABBAMore Gold        - -
30ABBAMore Gold        - -
31ABBAMore Gold        - -
32ABCDie Ultimative 80'er Fete  11  1 1
33ABCDie Ultimative 80'er Fete        - -
34AerosmithGet A Grip  11  1 1
35AerosmithGet A Grip        - -
36AerosmithGet A Grip        - -
37AerosmithGet A Grip        - -
38AerosmithGet A Grip        - -

verwendete Formeln
Zelle Formel
D6 {=SUMME((VERGLEICH(B6:B1000&"x"&C6:C1000;B1:B994&"x"&C1:C994;0)=ZEILE(6:1000))*1)-1}
H6 =WENN(ZÄHLENWENN(B$6:B6; B6)>1; 0; 1)
I6 =WENN(ZÄHLENWENN(C$6:C6; C6)>1; 0; 1)
H7 =WENN(ZÄHLENWENN(B$6:B7; B7)>1; 0; 1)
I7 =WENN(ZÄHLENWENN(C$6:C7; C7)>1; 0; 1)
H8 =WENN(ZÄHLENWENN(B$6:B8; B8)>1; 0; 1)
I8 =WENN(ZÄHLENWENN(C$6:C8; C8)>1; 0; 1)
H9 =WENN(ZÄHLENWENN(B$6:B9; B9)>1; 0; 1)
I9 =WENN(ZÄHLENWENN(C$6:C9; C9)>1; 0; 1)
H10 =WENN(ZÄHLENWENN(B$6:B10; B10)>1; 0; 1)
I10 =WENN(ZÄHLENWENN(C$6:C10; C10)>1; 0; 1)
H11 =WENN(ZÄHLENWENN(B$6:B11; B11)>1; 0; 1)
I11 =WENN(ZÄHLENWENN(C$6:C11; C11)>1; 0; 1)
H12 =WENN(ZÄHLENWENN(B$6:B12; B12)>1; 0; 1)
I12 =WENN(ZÄHLENWENN(C$6:C12; C12)>1; 0; 1)
H13 =WENN(ZÄHLENWENN(B$6:B13; B13)>1; 0; 1)
I13 =WENN(ZÄHLENWENN(C$6:C13; C13)>1; 0; 1)
H14 =WENN(ZÄHLENWENN(B$6:B14; B14)>1; 0; 1)
I14 =WENN(ZÄHLENWENN(C$6:C14; C14)>1; 0; 1)
H15 =WENN(ZÄHLENWENN(B$6:B15; B15)>1; 0; 1)
I15 =WENN(ZÄHLENWENN(C$6:C15; C15)>1; 0; 1)
H16 =WENN(ZÄHLENWENN(B$6:B16; B16)>1; 0; 1)
I16 =WENN(ZÄHLENWENN(C$6:C16; C16)>1; 0; 1)
H17 =WENN(ZÄHLENWENN(B$6:B17; B17)>1; 0; 1)
I17 =WENN(ZÄHLENWENN(C$6:C17; C17)>1; 0; 1)
H18 =WENN(ZÄHLENWENN(B$6:B18; B18)>1; 0; 1)
I18 =WENN(ZÄHLENWENN(C$6:C18; C18)>1; 0; 1)
H19 =WENN(ZÄHLENWENN(B$6:B19; B19)>1; 0; 1)
I19 =WENN(ZÄHLENWENN(C$6:C19; C19)>1; 0; 1)
H20 =WENN(ZÄHLENWENN(B$6:B20; B20)>1; 0; 1)
I20 =WENN(ZÄHLENWENN(C$6:C20; C20)>1; 0; 1)
H21 =WENN(ZÄHLENWENN(B$6:B21; B21)>1; 0; 1)
I21 =WENN(ZÄHLENWENN(C$6:C21; C21)>1; 0; 1)
H22 =WENN(ZÄHLENWENN(B$6:B22; B22)>1; 0; 1)
I22 =WENN(ZÄHLENWENN(C$6:C22; C22)>1; 0; 1)
H23 =WENN(ZÄHLENWENN(B$6:B23; B23)>1; 0; 1)
I23 =WENN(ZÄHLENWENN(C$6:C23; C23)>1; 0; 1)
H24 =WENN(ZÄHLENWENN(B$6:B24; B24)>1; 0; 1)
I24 =WENN(ZÄHLENWENN(C$6:C24; C24)>1; 0; 1)
H25 =WENN(ZÄHLENWENN(B$6:B25; B25)>1; 0; 1)
I25 =WENN(ZÄHLENWENN(C$6:C25; C25)>1; 0; 1)
H26 =WENN(ZÄHLENWENN(B$6:B26; B26)>1; 0; 1)
I26 =WENN(ZÄHLENWENN(C$6:C26; C26)>1; 0; 1)
H27 =WENN(ZÄHLENWENN(B$6:B27; B27)>1; 0; 1)
I27 =WENN(ZÄHLENWENN(C$6:C27; C27)>1; 0; 1)
H28 =WENN(ZÄHLENWENN(B$6:B28; B28)>1; 0; 1)
I28 =WENN(ZÄHLENWENN(C$6:C28; C28)>1; 0; 1)
H29 =WENN(ZÄHLENWENN(B$6:B29; B29)>1; 0; 1)
I29 =WENN(ZÄHLENWENN(C$6:C29; C29)>1; 0; 1)
H30 =WENN(ZÄHLENWENN(B$6:B30; B30)>1; 0; 1)
I30 =WENN(ZÄHLENWENN(C$6:C30; C30)>1; 0; 1)
H31 =WENN(ZÄHLENWENN(B$6:B31; B31)>1; 0; 1)
I31 =WENN(ZÄHLENWENN(C$6:C31; C31)>1; 0; 1)
H32 =WENN(ZÄHLENWENN(B$6:B32; B32)>1; 0; 1)
I32 =WENN(ZÄHLENWENN(C$6:C32; C32)>1; 0; 1)
H33 =WENN(ZÄHLENWENN(B$6:B33; B33)>1; 0; 1)
I33 =WENN(ZÄHLENWENN(C$6:C33; C33)>1; 0; 1)
H34 =WENN(ZÄHLENWENN(B$6:B34; B34)>1; 0; 1)
I34 =WENN(ZÄHLENWENN(C$6:C34; C34)>1; 0; 1)
H35 =WENN(ZÄHLENWENN(B$6:B35; B35)>1; 0; 1)
I35 =WENN(ZÄHLENWENN(C$6:C35; C35)>1; 0; 1)
H36 =WENN(ZÄHLENWENN(B$6:B36; B36)>1; 0; 1)
I36 =WENN(ZÄHLENWENN(C$6:C36; C36)>1; 0; 1)
H37 =WENN(ZÄHLENWENN(B$6:B37; B37)>1; 0; 1)
I37 =WENN(ZÄHLENWENN(C$6:C37; C37)>1; 0; 1)
H38 =WENN(ZÄHLENWENN(B$6:B38; B38)>1; 0; 1)
I38 =WENN(ZÄHLENWENN(C$6:C38; C38)>1; 0; 1)
{} Matrixformel mit Strg+Umschalt+Enter abschließen

Tabellendarstellung in Foren Version 5.3



Gruss
Mike


Beiträge aus den Excel-Beispielen zum Thema "Formel .. Einzigartigkeit"