Microsoft Excel

Herbers Excel/VBA-Archiv

Leere Zelle gleich Null? | Herbers Excel-Forum


Betrifft: Leere Zelle gleich Null? von: Josef_T
Geschrieben am: 20.01.2010 16:12:01

Tag zusammen,

Verständnisfrage: Wenn ich einen Zellbereich als Zahl oder Standard formatiere, ist dann für Excel die Zelle leer, oder eine 0 (Null) drin?

Danke schon mal

Gruß Josef

  

Betrifft: je nachdem was drin steht von: Björn B.
Geschrieben am: 20.01.2010 16:22:05

Hallo Josef,

ganz einfach, wenn ne 0 in der Zelle steht, dann ist für Excel ne 0.
Wenn die zelle leer ist, ist sie auch für Excel leer. Das hat doch nix mit Format zu tun.
Wenn Du mit einer leeren Zelle rechnest, dann nimmt Excel dafür eine 0, sonst aber nicht.

Beispiel:
in A1 = 5
in B1 = 0
in C1 = "" also leer.

Bei Rechnung kein Unterschied
D1 = A1*B1 = 0 (5 mal 0 gleich 0)
E1 = A1*C1 = 0 (5 mal nix gleich 0)

Aber der Wert macht nen Unterschied z.B. bei Verketten:
D2 = VERKETTEN(A1;B1) = 50
E2 = VERKETTEN(A1;C1) = 5


Ein Format ändert nur die Darstellung, aber niemals den Wert (Value) der Zelle.

Kannst Du mit dem hier prüfen bzw. testen:

msgbox activecell
Hoffe, das hat geholfen.

Gruß
Björn B.


  

Betrifft: AW: je nachdem was drin steht von: Josef_T
Geschrieben am: 20.01.2010 16:48:20

Hallo Björn

."...Wenn Du mit einer leeren Zelle rechnest, dann nimmt Excel dafür eine 0, sonst aber nicht."
Ich muß den Mittelwert bestimmen, bei dem eine leere Zelle den Wert verfälschen würde. Habe bislang
immer ein 0 (Null) händig eingegeben und wollte mir einfach dieses lästige nullen ersparen.

Danke für die Erklärung

Gruß Josef


  

Betrifft: irgendwie beides von: Rudi Maintaire
Geschrieben am: 20.01.2010 16:24:15

Hallo,
zb.
=a1 ergibt 0
=istleer(a1) ergibt WAHR

Gruß
Rudi


  

Betrifft: AW: irgendwie beides von: Josef_T
Geschrieben am: 20.01.2010 17:03:09

Hallo Rudi

Danke erst mal für Deine Arbeit.

Ich war mir nur nicht sicher, (überzeugt bin ich immer noch nicht) ob ich ohne eine o (Null) händig
einzutragen, den Mittelwert überhaupt korrekt ermitteln kann.

Gruß Josef


  

Betrifft: Die Fkt MITTELWERT errechnet denselben... von: Luc:-?
Geschrieben am: 20.01.2010 17:51:47

...stets ohne leere Zellen, Josef.
will heißen, diese Zellen wdn auch nicht mitgezählt! Wenn du eine 0 einträgst, wird die Summe sich nicht ändern, aber die Anzahl, so dass der Mittelwert kleiner wird. Wenn du das beabsichtigst — üblich ist das nicht —, musst du entweder weiter so verfahren oder statt der Fkt eine Fml benutzen, bspw...
=SUMME(zellbereich)/ZEILEN(zellbereich)
...wenn die Daten in Zeilen stehen, sonst SPALTEN für zellbereichnur eine Zeile oder Spalte. Wenn es sich bei zellbereich um eine Matrix handelt, musst du...
=SUMME(zellbereich)/(ANZAHL(zellbereich)+ANZAHLLEERZELLEN(zellbereich))
...verwenden.
Gruß Luc :-?


  

Betrifft: AW: Die Fkt MITTELWERT errechnet denselben... von: Josef_T
Geschrieben am: 20.01.2010 21:58:20

Guten Abend Luc,

Sorry das ich so spät erst antworte.

Danke erstmal, dass Du mir mit Deiner Aufklärung über den Mittelwert (Null oder Leer) eine ganze
Menge Arbeit erspart hast. Der Mittelwert soll nicht kleiner gehalten werden.
Also ab sofort keine 0 mehr.

Danke nochmal und Gute Nacht

Gruß Josef


  

Betrifft: Bitte sehr! Gute Nacht! owT von: Luc:-?
Geschrieben am: 20.01.2010 22:24:25

:-?


Beiträge aus den Excel-Beispielen zum Thema "Leere Zelle gleich Null?"