Summieren nach kriterium



Excel-Version: Excel 2002
nach unten

Betrifft: Summieren nach kriterium
von: dr.E
Geschrieben am: 11.04.2002 - 13:12:12

Hi Leute,

ihr könntet mir echt bei einem problem helfen...
ich möchte ein sheet summieren, aber nicht ganz einfach, cih zeig euch das mal:
CustomerID Group1 Group2 Name ZahlA ZahlB
1 A B X 56 45
1 A B X 44 30
2 L M Y 33 66

also solange CustomerId die selbe ist summieren von ZAhlA ebenda ZahlB soaber das ergebnis in nur einer reihe:

CustomerID Group1 Group2 Name ZahlA ZahlB
1 A B X 100 75
2 L M Y 33 66

any ideas????

thx


nach oben   nach unten

Re: Summieren nach kriterium
von: Benoit
Geschrieben am: 11.04.2002 - 14:42:53

Die Lösung ist durch Pivot-Tabelle zu finden.
Unter "Daten >> Pivot-Tabellenbericht..."

Viel Spass beim Probieren


nach oben   nach unten

Re: Summieren nach kriterium
von: dr.E
Geschrieben am: 11.04.2002 - 15:54:35

gibt es keine möglichkeit? ich meine für ein Makro das es kann, ich habe es mit While versucht und weiteren verschachtelungen aber es gibt doch sicherlich eine schöne lösung, da man keine Pivot hier haben will!

andere idee?


nach oben   nach unten

Re: Summieren nach kriterium
von: Arnim
Geschrieben am: 11.04.2002 - 16:27:58

Hallo dr.E.,
wenn ich das richtig verstehe, soll in Spalte G und H jeweils der Saldo für die Zahlen der jeweiligen CustomerID-Nr.
Das ginge mit folgenden Array-Formeln:
Eingabe der Formeln mit Tasten "Strg"+"Shift" und dann "Enter"

Spalte G: =WENN(A2=A3;"";SUMME(WENN($A$2:$A$1000=A2;E$2:E$65)))
Spalte H: =WENN(A2=A3;"";SUMME(WENN($A$2:$A$1000=A2;F$2:F$65)))

Gruß Arnim

nach oben   nach unten

Re: Summieren nach kriterium
von: dr.E
Geschrieben am: 12.04.2002 - 09:57:44

Verstehe ich nicht?!

ich will doch einfach nur, wie in access die tabelle gruppieren und summieren...


Hilfeeeeee


nach oben   nach unten

Re: Summieren nach kriterium
von: Benoit
Geschrieben am: 12.04.2002 - 11:24:44

Ich werde folgende vorschlagen:
Das Verfahren mit der Pivot-Tabelle probieren, aber gleichzeitig als Makro aufzeichnen lassen. Es wird ein Einstieg in die VBA-Funktionen für Pivot-Tabellen geben.

Danach kannst Du mit diese Funktionen spielen und Liste in Array bauen, ohne dass es zu eine Blattänderung kommt.

Alle Info über eine Funktion erhälst Du, wenn im VBA-Editor der Cursor auf der Funktion liegt und F1 gedrückt wird!

Viel Spass beim Probieren

Benoit

 nach oben

Beiträge aus den Excel-Beispielen zum Thema "Summieren nach kriterium"