Microsoft Excel

Herbers Excel/VBA-Archiv

Erbitte Hilfe bei Formeln über versch. Blätter | Herbers Excel-Forum


Betrifft: Erbitte Hilfe bei Formeln über versch. Blätter von: Claudia
Geschrieben am: 01.02.2010 16:02:54

Hallo liebe Helfer/innen hier im Forum

Ich benötige bitte dringend Eure Hilfe da ich nicht weiterkomme. Problem:
Ich muss in der beigefügten Tabelle Eingaben für unsere Mitarbeiter hier in der Niederlassung tätigen. Diese Angaben werden im Hauptbüro dann für die Löhne und Gehälter weiterverarbeitet. Ich weis das in der Datei extrem viel mit INDIREKT gearbeitet wird und das nicht sonderlich gut ist, aber die Zentrale will’s und macht’s halt so.

In den Tabellenblättern 0 und 2 werden manuelle Eingaben getätigt, bzw. sind Angaben aus anderen Tabellenblättern als Übertrag enthalten. In diesen Tabellenblättern werden in den Spalten B bis M die Monate Januar bis Dezember dargestellt.

Im Tabellenblatt LG werden zurzeit nur die Angaben aus dem Monat Januar angezeigt.

https://www.herber.de/bbs/user/67673.xls

Ist es möglich mittels Formeln über ein Dropdownfeld das beim Auswählen eines Monats die jeweiligen Werte aus genau diesen Monat in den Felder angezeigt werden können?

Oder kann man das nur mit VBA machen? Und wie würde dass dann funktionieren, habe mit VBA nur eingeschränkt Erfahrung.

Wer kann mir bitte helfen?

Liebe Grüße aus meinem Verschneiten Büro
Claudia

  

Betrifft: AW: Erbitte Hilfe bei Formeln über versch. Blätter von: Renee
Geschrieben am: 01.02.2010 16:25:12

Hallo Claudia,

Mache folgendes
In einen Zellenbereich untereinander die Monate Januar, Februar... Dezember
Diesen Bereich benennen. Beispeil M1...M12, Name MonatsListe
Spalte M ausblenden.
Zelle B3: Daten - Gültigkeit - Liste : =MonatsListe
Formel in C2 und runterkopieren

=SUMME(INDIREKT("'"&$A4&"'!"&ADRESSE(15;VERGLEICH($B$3;MonatsListe;0)+1)))

Die Formeln nach rechts D4 ff. mit den richtigen Zeilennummern ...ADRESSE(21; ... anpassen.

GreetZ Renée


  

Betrifft: ein Ansatz mit WVereis und Indirekt von: Christian
Geschrieben am: 01.02.2010 16:25:18

Hallo Claudia,

als Ansatz:
LG

 ABCDEFGH
1Verzeichnis 2010     
2 LohnBetrag LohnBetrag Ü-StdBetrag U-GeldPrämieZuschlägeSonstiges
3 Januar      
40Max Mustermann1700,00 2,50 25,00 100,00 10,00 3,00
52Maximiliane Musterfrau144,40 1,25 3,80 50,00 75,00 2,00
6        
7        

Formeln der Tabelle
ZelleFormel
C4=WVERWEIS($B$3;INDIREKT("'"&$A4&"'!$B$4:$M$33"); VERGLEICH(C$2;INDIREKT("'"&$A4&"'!$A$4:$A$33"); 0); 0)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

die Überschriften habe ich mal geändert, so das sie zur Bezeichnung in den einzelnen Tab.-Blättern passen.

MfG Christian


  

Betrifft: ein Ansatz mit WVerweis und Indirekt von: Christian
Geschrieben am: 01.02.2010 16:30:22

Hallo Claudia,

soll natürlich WVERWEIS heissen, den Tip für Dropdown/Datengültigkeit hat dir ja Renee schon gegeben.

MfG Christian


  

Betrifft: SUUUPER siehe Text von: Claudia
Geschrieben am: 01.02.2010 16:55:09

Hallo Renée,
hallo Christian,

beide Lösungen klappen wunderbar, habe jetzt die Qual der Wahl für welche ich mich entscheide.

Danke Euch zwei
Gruß
Claudia


  

Betrifft: AW: SUUUPER siehe Text von: Renee
Geschrieben am: 01.02.2010 19:51:34

Hallo Claudia,

BTW hab ich festgestellt, dass du bei meinem Vorschlag auf SUMME() verzichten kannst.
D.h. es genügt mit =INDIREKT(...) zu arbeiten.

GreetZ Renée


  

Betrifft: AW: SUUUPER siehe Text von: Claudia
Geschrieben am: 01.02.2010 20:16:49

Hallo Renée,

danke für die Info, ich werds morgen mal ausprobieren.
Gruß
Claudia


Beiträge aus den Excel-Beispielen zum Thema "Erbitte Hilfe bei Formeln über versch. Blätter"