Text ersetzt Zahl



Excel-Version: 97se
nach unten

Betrifft: Text ersetzt Zahl
von: Manfred
Geschrieben am: 06.05.2002 - 22:50:46

Hallo zusammen !,

Problem:Aktualisierende Plazierung!
Starter(Team Namen mit Startnummern bekannt)
vor dem Rennen...
Platz(1)-10 Toni
Platz(2)-9 Franz
Platz(3)-8 Elvis usw.

nach 1Stunde ist die Plazierung
Platz(1)-"9" [hier sollte EXCEL Automatisch Franz eintragen]
Platz(2)-"10" [hier sollte EXCEL Automatisch Toni eintragen]
Platz(3)-"8" [hier sollte EXCEL Automatisch Elvis eintragen]

nach 2Stunde ist die Plazierung
Platz(1)-"8" [hier sollte EXCEL Automatisch Elvis eintragen]
Platz(2)-"10" [hier sollte EXCEL Automatisch Toni eintragen]
Platz(3)-"9" [hier sollte EXCEL Automatisch Franz eintragen]

und so weiter...
Man gibt nur noch die Startnummer ein, Excel setz den
Teamnamen automatisch dahinter...
Wie kriegt man das hin? Kann mir jemand einen tip geben ?

in Hoffnung auf eure hilfe:
manfred




nach oben   nach unten

Re: Text ersetzt Zahl
von: MRR
Geschrieben am: 06.05.2002 - 23:26:49

Ich sehe 2 Möglichkeiten:
Du schreibst die Zahl in die eine Spalte, in der nächsten Spalte setzt Du per SVERWEIS-Formel den Namen ein. Die Namen würden dann in einer separaten Liste geführt. Stehen diese z.B. in D1:E3 (10 Toni, 9 Franz, 8 Elvis), dann würde ich in A1:A3 haben:

MS Excel von MRR an Manfred
 AB
18=SVERWEIS(A1;$D$1:$D$3;2;FALSCH)
29=SVERWEIS(A2;$D$1:$D$3;2;FALSCH)
310=SVERWEIS(A3;$D$1:$D$3;2;FALSCH)

Eine Alternative wäre dann noch, dass er Dir in dem Moment, in dem Du in Spalte A eine Nummer eingibst, den Namen holt und direkt hinter die Nummer einsetzt, bevor er die Zelle tatsächlich verlässt. Willst Du es so haben? Das bekommen wir dann aber nur mit VBA hin.
Matthias

nach oben   nach unten

Re: Text ersetzt Zahl
von: Matthias
Geschrieben am: 07.05.2002 - 10:33:41

Hallo Matthias,

danke für deine schnelle Antwort.
Was meinst du wird besser sein wenn
Umfang mehr sein als 3. Teilnehmer
ca. 300 Teams und die Zeitdauer 24h

bis bald:
manfred

nach oben   nach unten

Re: Text ersetzt Zahl
von: MRR
Geschrieben am: 07.05.2002 - 19:25:11

Hmmm - abgesehen von der Verwendung einer Datenbank würde ich dann vielleicht eher die INDEX-Funktion benutzen. Stell' die Daten in eine separate Tabelle und verweise dann per INDEX auf sie. Das sollte dann vielleicht schneller gehen.
Hilft Dir das? Kennst Du diese Funktion (ggf. Hilfe aufrufen)?
Matthias

nach oben   nach unten

Re: Text ersetzt Zahl
von: Manfred
Geschrieben am: 07.05.2002 - 19:59:05

Ja Stichwort "Datenbank" wird das Problem
besser zu bewältigen sein mit Access oder so.
Geh ich mir mal ein Access Forum suchen...
danke Matthias !

nach oben   nach unten

Re: Text ersetzt Zahl
von: MRR
Geschrieben am: 08.05.2002 - 14:06:54

Nicht lange suchen: MS-Office-Forum
HTH, Matthias
 nach oben

Beiträge aus den Excel-Beispielen zum Thema "Userform"