Summenbildung nach verschieden



Excel-Version: 10.0 (Office XP)
nach unten

Betrifft: Summenbildung nach verschieden
von: Micha
Geschrieben am: 17.05.2002 - 21:40:48

2. Versuch: Wer kann mir helfen:
Ich habe in einer Tabelle Spalten mit Vornahmen, Namen, Wohnort Datum, Wochentag, Tierarten, Anzahl, Schlachtverfahren, Untersuchungsergebnissen usw. aufgelistet. Orte u.a. Spalten werden über Listenfelder beschrieben.
Nun möchte ich z.B. die Anzahl, die zu einen bestimmten Namen oder bestimmten Ort in einem bestimmten Zeitraum passt, summieren ?
Das Ergebnis soll in einer anderen Tabelle der gleichen Mappe übertragen werden. Welche Formeln können dazu am besten eingesetzt werden ?
Mit gespannter Erwartung
Micha
Ich würde auch eine Beispieldatei anhängen, nur wie ?

nach oben   nach unten

Re: Summenbildung nach verschieden
von: BerndL
Geschrieben am: 17.05.2002 - 21:47:32

Experimentiere mal mit folgenden Formeln:
SUMMEWENN
ZÄHLENWENN
WENN

Und wenn das alles nichts bringt, was ich nicht glaube, dann gibt's noch die Möglichkeit der Matrix-Formeln. Hierzu dann die Excel-Hilfe zu Rate ziehen und erneut experimentieren; Erklärungen würden hier zu weit führen.

nach oben   nach unten

Re: Summenbildung nach verschieden
von: Arnim
Geschrieben am: 17.05.2002 - 23:34:42

Hallo Micha,
ich zeige Dir mal 2 Möglichkeiten auf:
Deine Spaltenüberschriften sind in der gleichen Reihenfolge in Zeile 1 eingetragen.
In Spalte B also die Namen, in D das Datum, in G die Anzahl.
In Tabelle 2 machst Du für die Zusammenfassung die gleiche Einteilung, nur schreibst Du in D2 z.B. eine "1" für Januar. Die Spalte formatierst Du mit MMMM,
so daß sich die Eins in "Januar" umwandelt.
In Tabelle2 G2 schreibst Du folgende Array-Formel:

=SUMME((Tabelle1!G$2:G$500)*(MONAT(Tabelle1!D$2:D$500)=D2))
Eingabe der Formel erfolgt mit den Tasten "Strg"+"Shift" und "Enter".

Du hast jetzt die Summe für den Monat Januar!
Willst Du nun auch die einzelnen Januarsummen für die einzelnen Namen haben (die in Spalte B stehen), dann schreibe statt der obigen Formel folgende Array-Formel:

=SUMME((Tabelle1!B$2:B$500=B2)*(Tabelle1!G$2:G$500)*(MONAT(Tabelle1!D$2:D$500)=D2))
wieder Eingabe mit Strg/Shift/Enter

Macht Dir die Eingabe der Formel Schwierigkeiten, dann ersetze "Summe" durch "Summenprodukt",
also z.B. =SUMMENPRODUKT((Tabelle1!G$2:G$500)*(MONAT(Tabelle1!D$2:D$500)=D2))

Gruß Arnim

 nach oben

Beiträge aus den Excel-Beispielen zum Thema "Summenbildung nach verschieden"