Zählenwenn



Excel-Version: 8.0 (Office 97)
nach unten

Betrifft: Zählenwenn
von: Nora
Geschrieben am: 22.05.2002 - 10:14:39

Hallo an alle!

Ich habe ein kleines Problem, aber irgendwie bin ich nicht in der Lage es zu lösen:

Und zwar habe ich eine lange Tabelle mit 2 Spalten:

Zeile____A_______B________C
1______A5B123__1________Zählenwenn
2______A5B124__2
3______A5B125__1
4______A5B129__0
5______A5B134__1
6______A5B146__1
7______A5B234__0
..._____A5B789__1
1128___________0
1129___________0
1130___________0
..._____________0
1500___________0

In der Zelle, wo ich jetzt Zählenwenn hingeschrieben habe, soll ein Befehl hin:

Zähle alle Nullen "0", solange in Spalte A etwas drin steht.

Also in diesem Fall bis Zeile 1127.

Das muß doch möglich sein, würd mich über Vorschlag freuen.
Nora

nach oben   nach unten

Re: Zählenwenn
von: Andreas
Geschrieben am: 22.05.2002 - 10:38:40

Hallo Nora,

folgende Formel, zählt die Nullen in Spalte B, wenn in Spalte A etwas drinsteht:
=SUMME(WENN(ISTLEER(A1:A1500);0;WENN(B1:B1500=0;1-ISTLEER(B1:B1500);0)))
Diese Formel ist eine Array-Formel, also mit STRG+SHIFT+ENTER abschließen!!!

Viel Spaß,
Andreas

PS:(Den Bereich A1:A1500 und B1:B1500 noch auf Deinen Bereich anpassen)

nach oben   nach unten

Re: Zählenwenn
von: Uwe
Geschrieben am: 22.05.2002 - 10:43:17

Hallo Nora
für dein Problem bin ich unter
http://www.excelformeln.de/formeln.html
fündig geworden.


Diese Formel müßte klappen.
=SUMMENPRODUKT((A1:A1127<>"")*(B1:B1127=0))

Gruß Uwe

nach oben   nach unten

Danke dir!
von: Nora
Geschrieben am: 22.05.2002 - 10:46:11

:-)
nach oben   nach unten

Re: Zählenwenn (Vorsicht)
von: Andreas
Geschrieben am: 22.05.2002 - 10:54:21

Hallo Uwe,

die Formel an sich ist vollkommen richtig, allerdings bei Bedingung =0 werden auch leere Zellen mitgezählt (jedenfalls bei mir ;-))
Deswegen so:
=SUMMENPRODUKT((A1:A1127<>"")*(B1:B1127=0-ISTLEER(B1:B1127)))

Andreas

nach oben   nach unten

Re: Zählenwenn (Vorsicht)
von: Uwe
Geschrieben am: 22.05.2002 - 12:57:30

Danke für die Info!

Gruß
Uwe


 nach oben

Beiträge aus den Excel-Beispielen zum Thema "Spalte markieren (Zelle) VBA"