Durchschnittstd-Runden



Excel-Version: 8.0 (Office 97)
nach unten

Betrifft: Durchschnittstd-Runden
von: womperdinger
Geschrieben am: 23.05.2002 - 19:24:40

hallo!

habe folgendes problem:

bekomme beim teilen der werte geleistete Stunden der letzte
3monate (z. b. 460,00 std.): anzahl der arbeitstage der letzten
3monate (64 tage) = das ergebnis 7,1875 Std.

das ergebnis muß aber auf 7,25 std. gerundet werden, da ansonsten
folgerechnungen nicht richtig wären.

mein problem ist die formelerstellung für das ab- bzw.
aufrunden. nachstehende werte müssten z. b. (da stunden-
wert vor dem komma variabel) auf- und abgerundet werden:

7,00 bis 7,124 = 7,00 std.
7,125 bis 7,324 = 7,25 Std.
7,325 bis 7,624 = 7,50 std.
7,625 bis 7,874 = 7,75 std.
7,875 bis 7,99 = 8,00 std.

kann mir jemand weiterhelfen, wäre diesem menschen
mehr als dankbar.

tschüss

nach oben   nach unten

Re: Durchschnittstd-Runden
von: sam
Geschrieben am: 23.05.2002 - 19:47:43

Hallo womperdinger,

tja, du hast mir ca. 5 Minuten mehr zu denken gegeben, da du offenbar die Grenzen nicht richtig gesetzt hast :-)

Die Grenze 7,325 ist nicht richtig! Es muss 7,375 sein!
Aber gut.

Hier hast du deine (mehr als erwartete) Formel:
A1: Wert
B1: =RUNDEN(A1/0,25;0)*0,25

Viel Spaß damit,
Sam

 nach oben

Beiträge aus den Excel-Beispielen zum Thema "Strings"