Microsoft Excel

Herbers Excel/VBA-Archiv

Werte zuordnen | Herbers Excel-Forum


Betrifft: Werte zuordnen von: Thomas
Geschrieben am: 03.01.2012 07:54:26

Hallo Forum,

ich habe eine Wertetabelle.
In der Spalte A befinden sich die Werte.
In der Spalte B möchte ich eine Zuordnung für die Spalte A treffen.
Es gibt eine weitere Tabelle, wo von-bis Werte mit einer Zuordnung angegeben sind.

Kann man mit einer Standard Excelfunktion diese Aufgabe erledigen, oder muß man ein Macro programmieren?
Beim Durchstöbern der Excelhilfe bin ich auf keine passende Funktion getroffen. Vielleicht könnte mir jemand bei meinem Problem behilflich sein.
Ich habe mal ein Beispiel unter folgendem Link abgelegt.

https://www.herber.de/bbs/user/78184.xlsx

Gruß Thomas

  

Betrifft: WENN(UND()) ... von: Matthias L
Geschrieben am: 03.01.2012 08:09:52

Hallo

Probier mal ...

Tabelle1

 ABCDEF
1   WerteZuordnung
2WerteZuordnung vonbis 
3177,4B 159,5163,5A
4178,6B 176,5179,5B
5164,3  187,5190,5C
6160,1A    
7188,3C    

Formeln der Tabelle
ZelleFormel
B3=WENN(UND(A3>=$D$3;A3<=$E$3);$F$3;WENN(UND(A3>=$D$4;A3<=$E$4);$F$4;WENN(UND(A3>=$D$5;A3<=$E$5);$F$5;"")))
B4=WENN(UND(A4>=$D$3;A4<=$E$3);$F$3;WENN(UND(A4>=$D$4;A4<=$E$4);$F$4;WENN(UND(A4>=$D$5;A4<=$E$5);$F$5;"")))
B5=WENN(UND(A5>=$D$3;A5<=$E$3);$F$3;WENN(UND(A5>=$D$4;A5<=$E$4);$F$4;WENN(UND(A5>=$D$5;A5<=$E$5);$F$5;"")))
B6=WENN(UND(A6>=$D$3;A6<=$E$3);$F$3;WENN(UND(A6>=$D$4;A6<=$E$4);$F$4;WENN(UND(A6>=$D$5;A6<=$E$5);$F$5;"")))
B7=WENN(UND(A7>=$D$3;A7<=$E$3);$F$3;WENN(UND(A7>=$D$4;A7<=$E$4);$F$4;WENN(UND(A7>=$D$5;A7<=$E$5);$F$5;"")))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Gruß Matthias


  

Betrifft: AW: WENN(UND()) ... von: Thomas
Geschrieben am: 03.01.2012 08:59:41

Mattias,

vielen Dank für deine schnelle Hilfe.

Gruß Thomas


  

Betrifft: AW: WENN(UND()) ... von: Thomas
Geschrieben am: 03.01.2012 13:02:32

Hi Matthias,

ich habe doch noch eine Frage zu dieser Wenn Funktion.
Meine von-bis Werte Tabelle beinhaltet 9 Zeilen mit von - bis Werten.
Ich habe versucht eine Formel nach deinem Beispiel zu erstellen.
Ich erhalte von Excel die Meldung, dass die angegebene Formel nicht eingegeben werden kann, da ich mehr Verschachtelungsebenen verwende, als im aktuellen Dateiformat zulässig ist.
Gibt es eine Möglichkeit, die Formel noch anders auf zubauen?

Meine Formel lautet im Moment:
=WENN(UND(O2>=Tabelle1!$C$3;O2<=Tabelle1!$D$3);Tabelle1!$F$3;WENN(UND(O2>=Tabelle1!$C$4;O2<=Tabelle1!$D$4);Tabelle1!$F$4;WENN(UND(O2>=Tabelle1!$C$5;O2<=Tabelle1!$D$5);Tabelle1!$F$5;WENN(UND(O2>=Tabelle1!$C$6;O2<=Tabelle1!$D$6);Tabelle1!$F$6;WENN(UND(O2>=Tabelle1!$C$7;O2<=Tabelle1!$D$7);Tabelle1!$F$7;WENN(UND(O2>=Tabelle1!$C$8;O2<=Tabelle1!$D$8);Tabelle1!$F$8;WENN(UND(O2>=Tabelle1!$C$9;O2<=Tabelle1!$D$9);Tabelle1!$F$9;WENN(UND(O2>=Tabelle1!$C$10;O2<=Tabelle1!$D$10);Tabelle1!$F$10;WENN(UND(O2>=Tabelle1!$C$11;O2<=Tabelle1!$D$11);Tabelle1!$F$11;"")))

Diese Formel kann Excel nicht mehr verarbeiten.
Hast du eine Idee?

Gruß Thomas


  

Betrifft: Archivsuche: -> 7 wenn von: Matthias L
Geschrieben am: 04.01.2012 08:24:33

Hallo

Gib mal in der Archiv-Schnellsuche:
7 wenn
ein.

Gruß Matthias


  

Betrifft: AW: Archivsuche: -> 7 wenn von: Thomas
Geschrieben am: 04.01.2012 08:43:37

Hi Matthias,

cool !!!!
Danke für die Info.

Gruß Thomas


  

Betrifft: SVERWEIS anschauen...oT von: robert
Geschrieben am: 03.01.2012 08:10:30




  

Betrifft: AW: SVERWEIS anschauen...oT von: Thomas
Geschrieben am: 03.01.2012 08:58:07

Hallo Robert,

den Befehl SVERWEIS kannte ich noch nicht. Ich bin mal die Excelhilfe überflogen. Dieser Befehl scheint das Gleiche zu machen, wie die WENN / UND Funktion.
Mal sehen, ob ich es mit dieser Funktion auch hinbekomme.
Vielen Dank für deine schnelle Hilfe.
Gruß Thomas


  

Betrifft: Nachfrage... von: robert
Geschrieben am: 03.01.2012 09:08:01

Hi Thomas,

wenn ein Wert nich in den Bereich fällt, soll dann keine ! Zuordnung erfolgen?

Dann würde SVERWEIS nicht greifen!

Gruß
robert


  

Betrifft: AW: Nachfrage... von: Thomas
Geschrieben am: 03.01.2012 09:27:26

Hi Robert,

ja das ist richtig, es soll dann keine Zuordnung erfolgen.

Also bist du dann der Meinung, das ich die Funktion SVERWEIS nicht nehmen sollte.
Vielen Dank für diesen Hinweis.

Gruß Thomas


  

Betrifft: AW: Nachfrage... von: Reinhard
Geschrieben am: 03.01.2012 09:58:17

Hallo Thomas,

um den Fehler in B8 wegzukriegen, schreibe in D2 eine 1 und formatiere D2 mit "von"
Schreib in F2 ein Leerzeichen, dann kommt auch keine 0 in B8.

Tabellenblatt: [Mappe1]!Tabelle1
  │   A   │     B     │
--┼-------┼-----------┼
2 │ Werte │ Zuordnung │
--┼-------┼-----------┼
3 │ 177,4 │ B         │
--┼-------┼-----------┼
4 │ 178,6 │ B         │
--┼-------┼-----------┼
5 │ 164,3 │           │
--┼-------┼-----------┼
6 │ 160,1 │ A         │
--┼-------┼-----------┼
7 │ 188,3 │ C         │
--┼-------┼-----------┼
8 │   100 │    #NV    │
--┼-------┼-----------┼
9 │   300 │           │
--┴-------┴-----------┴
Benutzte Formeln:
B3: =WENN(A3<=INDEX(E:E;VERGLEICH(A3;$D$1:$D$7));INDEX(F:F;VERGLEICH(A3;$D$1:$D$7));"")
B4: =WENN(A4<=INDEX(E:E;VERGLEICH(A4;$D$1:$D$7));INDEX(F:F;VERGLEICH(A4;$D$1:$D$7));"")
B5: =WENN(A5<=INDEX(E:E;VERGLEICH(A5;$D$1:$D$7));INDEX(F:F;VERGLEICH(A5;$D$1:$D$7));"")
B6: =WENN(A6<=INDEX(E:E;VERGLEICH(A6;$D$1:$D$7));INDEX(F:F;VERGLEICH(A6;$D$1:$D$7));"")
B7: =WENN(A7<=INDEX(E:E;VERGLEICH(A7;$D$1:$D$7));INDEX(F:F;VERGLEICH(A7;$D$1:$D$7));"")
B8: =WENN(A8<=INDEX(E:E;VERGLEICH(A8;$D$1:$D$7));INDEX(F:F;VERGLEICH(A8;$D$1:$D$7));"")
B9: =WENN(A9<=INDEX(E:E;VERGLEICH(A9;$D$1:$D$7));INDEX(F:F;VERGLEICH(A9;$D$1:$D$7));"")

A2:B9
haben das Zahlenformat: Standard

Gruß
Reinhard


  

Betrifft: AW: Nachfrage... von: Thomas
Geschrieben am: 04.01.2012 07:45:42

Guten Morgen Reinhard,

ich habe mal deine Formel ausprobiert. Mit dieser Formel konnte ich mehrere Kriterien vergleichen, was ich mit der WENN / UND Funktion nicht hinbekommen habe.
Vielen Dank!!!

Gruß Thomas


Beiträge aus den Excel-Beispielen zum Thema "Werte zuordnen"