Microsoft Excel

Herbers Excel/VBA-Archiv

Informationen und Beispiele zum Thema SpinButton
BildScreenshot zu SpinButton SpinButton-Seite mit Beispielarbeitsmappe aufrufen

Wenn bedingt formatiert, dann... | Herbers Excel-Forum


Betrifft: Wenn bedingt formatiert, dann... von: Chris
Geschrieben am: 20.01.2012 13:19:54

Hallo zusammen,

ich hoffe ihr könnt mir weiterhelfen bei Excel 2010:
Ich lasse mir die Schrift (Datumswerte) über bedingte Formatierung in Spalte C formatieren, sobald es sich um einen Feiertag handelt.
Ein paar Spalten weiter rechts (AA) möchte ich eine Formel eingeben, die jedoch Null bzw. "" ausgibt, wenn der Wert in Spalte C dunkelrot ist, also ein Feiertag.
Kann man in 2010 bedingte Formatierung in Formeln einbauen und wenn ja, wie?

Gruß
Chris

  

Betrifft: AW: Wenn bedingt formatiert, dann... von: Rudi Maintaire
Geschrieben am: 20.01.2012 13:26:27

Hallo,
du kannst doch einfach als Bedingung in die Formel einbauen, ob C ein Feiertag ist.
Wie ermittels du Feiertage?

=Wenn(istfeiertag(C1);"";Wert)

Gruß
Rudi


  

Betrifft: AW: Wenn bedingt formatiert, dann... von: Chris
Geschrieben am: 20.01.2012 13:40:41

Ich habe in einer Hilfstabelle alle Daten aufgelistet, die in den nächsten Jahren Feiertage sind und für den Bereich einen Namen "feiertage" definiert. Die bedingte Formatierung lautet dann:

=SVERWEIS($C6;feiertage;1;FALSCH)

Bei der Formel mit ...istfeiertage meckert Excel


  

Betrifft: Feiertage von: Rudi Maintaire
Geschrieben am: 20.01.2012 13:45:31

Hallo,
Bei der Formel mit ...istfeiertage meckert Excel
natürlich. Stattdessen musst du deine Feiertags-Formel einsetzen.
Oder: =wenn(Zählenwenn(Feiertage;C1);Formel;"")

Gruß
Rudi


  

Betrifft: AW: Feiertage von: Chris
Geschrieben am: 20.01.2012 13:57:29

Hmm, irgendwas stimmt da nicht: Es wird bspw. mit der folgenden Formel nur "Wahr" und "Falsch" ausgegeben
=WENN(feiertage=C6;"";Formel)

Auch deine Formel gibt "Wahr" und "Falsch" aus
=wenn(Zählenwenn(Feiertage;C1);Formel;"")


  

Betrifft: Denk nach owT von: Rudi Maintaire
Geschrieben am: 20.01.2012 14:08:44




  

Betrifft: AW: Denk nach owT von: Chris
Geschrieben am: 20.01.2012 14:44:34

Sorry, total doof, waren beide Formeln hintereinander. Das hier funktioniert:
=WENN(ZÄHLENWENN(feiertage;C6);"";Formel)

danke!


Beiträge aus den Excel-Beispielen zum Thema "Wenn bedingt formatiert, dann..."