Microsoft Excel

Herbers Excel/VBA-Archiv

Ermitteln der Zelle bei Grenzwertüberschreitung | Herbers Excel-Forum


Betrifft: Ermitteln der Zelle bei Grenzwertüberschreitung von: Berni
Geschrieben am: 25.01.2012 16:40:54

Hallo Excellenzen!

Ich habe schon einmal eine Formel ausprobiert, die funktioniert aber noch nicht zu meiner Zufriedenheit.
Vielleicht hat da jemand eine Idee.

Also:
Ich habe in den Spalten B:M (Monate Jan bis Dez) aufsteigende Werte stehen. In die Spalte N möchte ich dann jenen Differenzwert schreiben, wenn der jeweilige Grenzwert (hier konkret 1.000.000) überschritten wird. Also, wenn z.B. in der Zelle H3 der Wert 1.052.000, dann soll in N3 nur mehr der überschrittene Werte aufscheinen.

Schick euch mal die Patiententabelle, vielleicht lässt sich da was machen.

https://www.herber.de/bbs/user/78596.xls

  

Betrifft: AW: Ermitteln der Zelle bei Grenzwertüberschreitung von: Josef Ehrensberger
Geschrieben am: 25.01.2012 16:52:15


Hallo Berni,

ich weiß nicht, ob ich dich richtig verstanden habe.

Tabelle1

 KLMNOPQR
1   Grenzwert    
2OktNovDez1.000.0005.000.00015.000.00025.000.00050.000.000
3271.914298.974329.022     
41.050.6211.177.2941.240.30850.621    
5911.7541.024.9381.116.64724.938    
61.135.9471.267.6941.415.572135.947    
713.339.98014.896.62015.945.480140.4801.582.240945.480  
88.114.9929.080.6569.784.568422.320281.880   
9853.488950.0761.044.69544.695    
101.112.9851.228.0481.335.164112.985    
111.184.8021.283.3821.393.66080.246    
1213.670.64015.381.72016.510.86076.4001.282.000381.720  
13382.950399.933449.550     
141.266.2371.404.5341.553.52092.741    
152.706.0663.000.2823.282.00671.249    
162.230.5542.459.1902.664.49288.178    
17        

Formeln der Tabelle
ZelleFormel
N3{=WENN(ZÄHLENWENN($B3:$M3;">"&N$2)>0;MIN(WENN($B3:$M3>N$2;$B3:$M3))-N$2;"")}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4






« Gruß Sepp »



  

Betrifft: AW: Ermitteln der Zelle bei Grenzwertüberschreitung von: Berni
Geschrieben am: 25.01.2012 16:59:26

Perfekt Sepp!

Schöner kanns gar nicht werden. Wie du gesehen hast, hab ich es mit Index und Min versucht. Das war aber offensichtlich die falsche Fährte. Deine Lösung ist genau die richtige.

Danke vielmals

LG Berni


Beiträge aus den Excel-Beispielen zum Thema "Ermitteln der Zelle bei Grenzwertüberschreitung"