Microsoft Excel

Herbers Excel/VBA-Archiv

Formelproblem



Excel-Version: 8.0 (Office 97)

Betrifft: Formelproblem
von: MikeS
Geschrieben am: 06.06.2002 - 15:56:41

Hallo Leute,

mit nachfolgender Formel wird in die Zelle B1 ein Teil (die Zahl
nach "Pos") des Blattnamens reingeschrieben.

z.B. Blattname = "Pos11 Januar" ergibt in Zelle B1 = "11"

=TEIL(ZELLE("dateiname";B1);FINDEN("]";ZELLE("Dateiname";B1))+4;2)*1

Ich möchte aber, daß wenn keine Zahl in B1 steht,
daß "" in der Zelle "auftaucht".

Habe es mit dieser Formel probiert und erhalte immer
eine Fehlermeldung.

=Wenn(ISTZAHL(TEIL(ZELLE("dateiname";B1);FINDEN("]";ZELLE("Dateiname";B1))+4;2)*1;TEIL(ZELLE("dateiname";B1);FINDEN("]";ZELLE("Dateiname";B1))+4;2)*1))

Was muß ich ändern?

Vielen Dank, MikeS





  

Problem gelöst!!!
von: MikeS
Geschrieben am: 06.06.2002 - 16:02:28

Alles klar:

=WENN(ISTZAHL(TEIL(ZELLE("dateiname";B1);FINDEN("]";ZELLE("Dateiname";B1))+4;2)*1);TEIL(ZELLE("dateiname";B1);FINDEN("]";ZELLE("Dateiname";B1))+4;2)*1;"")

Ciao MikeS

  

Re: Formelproblem
von: @lex
Geschrieben am: 06.06.2002 - 16:07:32

Hallo !
So gehts:
=WENN(ISTZAHL(TEIL(ZELLE("dateiname";B1);FINDEN("]";ZELLE("Dateiname";B1))+4;2)*1);TEIL(ZELLE("dateiname";B1);FINDEN("]";ZELLE("Dateiname";B1))+4;2)*1;"")

Alex

  

Kuck mal Deine Klammern an
von: Alan Hathway
Geschrieben am: 06.06.2002 - 16:07:43

Du hast
=Wenn(ISTZAHL(TEIL(ZELLE("dateiname";B1);FINDEN("]";ZELLE("Dateiname";B1))+4;2)*1;TEIL(ZELLE("dateiname";B1);FINDEN("]";ZELLE("Dateiname";B1))+4;2)*1))

Richtig ist
=WENN(ISTZAHL(TEIL(ZELLE("dateiname";B1);FINDEN("]";ZELLE("Dateiname";B1))+4;2)*1);TEIL(ZELLE("dateiname";B1);FINDEN("]";ZELLE("Dateiname";B1))+4;2)*1;"")

Tipp für die Zukunft.

Schreib mal "Pos11 Januar" in Feld G13 und versuch Dein Forel mit G13 zum laufen zu bringen. Später G13 durch der vorher korrekte Formel
TEIl(ZELLE("dateiname";B1);FINDEN("]";ZELLE("Dateiname";B1))+4;2)

Deien Formel wäre dann

=Wenn(ISTZAHL(G13*1;G13*1))

was ziemlich klar nicht richtig ist.

Alan Hathway